Nortel Venture MLT 10 30 Problem

I saw an unanswered post from 2004 with the exact same issue, I tried to respond to it but google does not allow.

Has anyone ever had a problem with a Nortel Venture phone where the phone comes on, self tests ok, then posts a message MLT 10 30 ? It has a limited menu with three options at that point, and I tried them all. Is there some key sequence that can pull this phone out of it, or am I stuck with a new doorstop?

These phones have nice features, but both of the phones I own have had problems. The MLT 10 30 issue, and my "working" phone no longer picks up on Line 2. It seems something is fried because you hear very faint, distorted audio and thats it. The line says "Extension in Use". I've tried 3 different phone lines and all had the same problem, and two dist blocks. Also checked ports on the phone for crossed contacts, no help. This I assume is a hardware problem and cannot be helped.

So does anyone know how to fix the first (or even the second) problem? If not, can you recommend a comparable CORDED system on the market today? I'm in Nor-hell right now, and have to either fix these, or buy some new phones.

Reply to
Loading thread data ... Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.