Question about switch/nic behavior in experiment

I moved to a new apartment recently. I guess the previous owners really lik
ed using the phone because it had SEVERAL phone sockets on every room, clos
et and bathroom, all of them leading to an ancient Panasonic PBX.
I threw away the Panasonic PBX made use of some of the cabling and jacks vi
a a Grandstream ATA and made a FreeSwitch box with a Raspberry PI. Now I ha
ve phones in more than every useful place in the apartment. Still phone jac
ks remain everywhere so I decided to try and turn them into ethernet, just
for fun in my spare time.
I was pretty sure most of them wouldn't work as it's a large appartment and
most of the wiring is old flat 4 conductor telephone cable, spliced by han
d with electrical tape in many places, and running near 120v lines. Still,
I had lots of cat5 jacks laying around unused, and a couple of routers and
The results of the experiment were much better than expected. Except for th
e room farthest apart, everything worked great. Even in places where I used
two telephone cables to get all 4 pairs for a gigabit connection I got a s
olid connection, no packet loss, 1000/100 speeds depending on how I wired t
he connection.
The room farthest apart has probably about 40 meters of telephone cable fro
m the switch to the port and didn't work, when it established a link it dro
ped a second later. I didn't expect anything to work from the beginning any
way so I didn't care.
But then I accidentally plugged the LAN pot of my Grandstream ATA instead o
f the switch to it and I was surprised to see that the LED started to blink
. I made some tests and it worked perfectly. Again, no packet loss, iperf t
ested 96mbit, rock solid connection for days. I even started using it to st
ream HD video.
But being very curious I ran some tests. I tried every switch I could get a
hold on with every NIC I could find. I tried all combinations. I opened ev
ery one of them to determine which brand of chip it's using.
Cisco Linksys SE8200: Broadcom
Adtran Netvanta 1554: Broadcom
Adtran Netvanta 1335: Broadcom
Airlink 101 ASW208: Realtek
D-Link DIR-600: Ralink
Asus RT-N66U: Broadcom
I also used several other devices for testing:
HP Microserver integrated NIC: Realtek
HP Microserver with Intel NIC: Intel
VIZIO Co-Star: Marvell
ThinkPad Laptop: Intel
Raspberry PI: SMSC
Cubieboard: Allwinner
PC Engines Alix 2.d3: VIA
Finally the Grandstream ATA appears to have an Infineon chip. (It has resin
on top so it's only partially visible, but a google search also points to
an Infineon chip.)
At the end everything worked perfectly with the Grandstream ATA's LAN port
coupled to any NIC. But every other switch/router wouldn't work with any NI
So the question is:
Does the Infineon chip pump more mW? Does it have better noise filtering? W
hy does the link fail completely with every piece of hardware, but works pe
rfectly even after days of testing with the Grandstream ATA's port attached
to anything?
Also, is it possible to get a NIC or switch with an Infineon chip?
Reply to
Loading thread data ...
It may have nothing to do with Infineon. When dealing with dodgy cable, I've found enforcing half-duplux is the first and most important measure. TX is RX worst problem.
Otherwise, with flat ribbon, put pairs on inside-outside straddle (USOC) or on the diagonal for quad.
-- Robert
Reply to
Robert Redelmeier Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.