Strange Routing Problem with EIGRP over Tunnels

Can anyone throw any light on this.

I have a small network connecting 2 x sites together. The LAN's are

192.168.143.X/24 and 10.10.X.X /16 respectively. All the routers WAN IP's are 10.250.X.X/16.

Between RTR1 and RTR3 I have a point-to-point GRE Tunnel & /24. Between RTR2 and RTR4 I run a DMVPN with RTR5 (the NHRP server). The DMVPN Tunnel IP's are, .2 & .3 /24 repectively). I use a route-map on RTR1 and RTR3 that prioritise important IP traffic to go over the RTR1 to RTR3 Tunnel. Any traffic not matched is forwarded normally over the DMVPN. NB RTR1 & RTR3 are HSRP active routers for their LANs.

On the RTR1 - RTR3 connection the bandwidth is 32k and delay 5000. On the RTR2 - RTR4 link the bandwidth is 256k and delay 1000. This means all traffic should prefer the RTR2 - RTR4 link due to the better metric assuming no route-map match.

I advertise my 10.250.X.X WAN in RIP (including no validate update source + passive interface on he LAN). I advertise my Tunnels and LAN in EIGRP.

My problem - RTR1 & RTR3 (on their respective LAN's) think the best path to the remote LAN is via RTR2 & RTR4. However, RTR2 & RTR4 think the best path is via RTR1 & RTR3.

Is it possible that the switch simulating the WAN may be throwing the routing metrics out when RIP and EIGRP routing updates are being learned by the routers.

I don't redistribute between routing protocols.

Diagram: /24 | | Rtr3 Rtr4 (DMVPN) | | (WAN - Catalyst Switch) 10.250.X.X ----Rtr5 (DMVPN) for Rtr 2 & 4 | | Rtr1 Rtr2 (DMVPN) | | /16
Reply to
Darren Green
Loading thread data ...

The switch shouldn't be involved in the routing protocols at all.

Can you post the routing table from each router. That may help.

Reply to

Unfortunately I have now taken the lab apart as I have to install the kit for real. I am hoping that when the router are installed and connect to the real PE's this scenario won't occur again.

I knew the switch was layer 2. I just thought that in my simulated lab that multicasts from EIGRP & RIPv2 ( & .10) were somehow not correctly being sent / received.

When I install the kit I will post a config if I get the same error.

Thanks for the reply.



Reply to
Darren Green Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.