Set Long Preamble on WRT54G

Is there a way to set the preamble to long on a WRT54G? I would assume it would be in the web interface on the Wireless_Advanced page, but I don't see it.


Reply to
Nemo Oudeheis
Loading thread data ...

I have no idea, but I'm curious as to why you would want to do this. A long preamble is a left over from 802.11 (1 and 2 mbits/sec), where the receiver took a long time to synchronize. The preamble is transmitted with every packet and is ineffecient with airtime. If you enable long preamble and do a before/after wireless performance test, you'll find about a -15% reduction in thruput. Unless you have 802.11 (1 or 2Mbits/sec) client radios in your system, there's no need for a long preamble. The default for most access points is "automagic". It only enables long preambles when associated with a 1 or 2Mbit/sec client radio. Some AP's will use a short preamble for 1 and

2Mbits/sec connections, unless it detect decoding errors, which imply that the client requires the older long preamble.


formatting link

Reply to
Jeff Liebermann

My reason for doing it was that I was advised to try it by ATT Technical Support. I thought I might as well at least attempt the experiment before telling them that they were not being helpful.

I recently acquired an AT&T Plug&Share Ultra 6550G PCI wireless adapter for one of my desktop systems that had been passed by in my "domestic wireless buildout". I bought it not because I had any real intention of using its proprietary 108 Mbps data rate, but because it was quite inexpensive and was supposed to be compatible with the 802.11g + WPA setup I was using. I had to upgrade their driver to get the WPA support, which, as usual, forces you to not use their ATT configuration client, but rather the WinXP Wireless Zero Configuration.

The card installs fine, and I am able to connect to an 802.11b open access point in the little coffee shop down the street (it's over 500m away!). But I cannot connect to my own WRT54G (which works OK with my two laptops). It looks as though it is unable to negotiate the DHCP transaction with the router, as the WZC just sits and spins in the "Renewing your IP address" phase. No addresses ever get assigned.

I'm on WinXP Pro SP2 using WPA-PSK and MAC address filtering. The cards MAC is in the router's table.

I'm sort of grasping at straws at this point.

Reply to
Nemo Oudeheis

Well, permit me to be the 2nd to suspect that AT&T knows not what they speak. If you were running 1 or 2Mbit/sec instead of 108Mbits/sec, perhaps a long preamble would be useful.

It shouldn't really force you do use XP Wireless Zero Config. WPA is in the device driver, not the admin tools. You can always try to disable WZC in: Control Panel -> Admin Something -> Services It's near the bottom of the list. However, if the AT&T config utility does not have any way to enter the WPA pass phrase, you're stuck with using WZC.

Impressive. The RF part is working.

Anything odd about the WRT54G? Which hardware version? Are you using Linksys firmware or some alternative (HyperWRT, Sveasoft, etc).

I keep seeing this exact problem on various hardware and software platforms. If you turn off WEP/WPA encryption, DHCP will deliver a proper IP address. You can sometimes get it to work with a static (manually assigned) IP address, netmask, gateway, and DNS server. However, as soon as encryption is enabled, DHCP fails. Basically WEP and WPA are failing.

I had this happen a few daze ago with a WRT54G v3.0. The Linksys clients (WPC54G) had no problems connecting with encryption enabled. However, the two DLink DWL-G520 PCI cards wouldn't work. Neither would the DWL-G630 in my laptop. Turn off encryption and no problems. I was using a Hex WEP key, so it wasn't an ASCII to Hex translation issue.

I had a spare WRT54G v1.1 router with me loaded with Satori firmware. I replace the customers shiny new router with my beat up old loaner and everything worked. DHCP delivered IP's as expected with WEP or WPA enabled.

I wish I could say that I loaded Satori on the customers WRT54G v3.0 router and everything was wonderful. Instead, the customer wanted to return his new router and buy one with "factory support". So, I reset everything, packed it back up, loaned in my junker, and am awaiting the arrival of a DLink DI-624. Sigh.

I'm still not sure if it's a router problem, or a client problem.

The real problem, in my never humble opinion, is that neither MS Wireless Zero Config or the usual device drivers offer any form of connection progress diagnostics. It's almost imposible to assign the blame to any device, driver, or protocol without proper verbose diagnostics.

Anyway, try:

  1. Turn off encryption temporarily and see if DHCP works.
  2. If using WEP, try using a Hex key.
  3. Turn off MAC address filtering for now.
  4. Set to "open authentication".
  5. If ambitious (or desperate), try downloading and installing Sveasoft Satori firmware..

Maybe. Windoze does NOT necessarily use the cards hardware MAC address. It uses whatever it finds in the registry. This is lots of fun especially on a cloned machine, where Windoze inherits the MAC address of whatever was in the old machine. Check the MAC address with the site survey tool and don't rely on what's printed on the label.

Well, a long preamble is certainly not going to help here. Temporarily disable all the goodies (encryption, MAC filtering) and use "open authentication". Put the access point back into a very basic (default) configuration.

One more clue and anecdote. I had the same problem with a WRT54GS v1.0 and some Netgear PCMCIA cards. DHCP would only work if encryption were off. Since there was a SUSE Linux 9.1 server available, I reconfigured the WRT54GS as an access point instead of a router, disabled the build in DHCP server, and used the DHCP server in the Linux box. It worked. However, don't ask me what happened or why. I didn't have time to test.

Oh yeah, testing. Try downloading the DHCP query tool from:

formatting link
's at the bottom of the list. You do NOT need to have an IP address assigned to use the query tool as DHCP works with broadcasts.

Reply to
Jeff Liebermann

I'm slow to reply to this message because immediately after I received it I got another response from AT&T support which urged me to use their utility to try to iron things out. I started it up, and curiously enough, got it to come up once and show me a WPA screen. I tried entering the PSK, and the utility immediately crashed. Going back and forth a few times, disabling and re-enabling the Wireless Zero Configuration service, I never got their utility to run again.

Exchanged a few more messages with AT&T support, and then decided to back out the whole installation and try over, but relying on the XP installation wizard instead of their installer.

Then I went to the router and disabled MAC filtering and WAP. I was able to connect to my router in "open" configuration. Then I re-enabled MAC filtering, and was still able to connect. At this point, while I was catching my breath, because the machine was connected to the Internet again for the first time in months, a Windows automatic update started, and I decided to let it run.

I suppose that was methodologically impure in my "experiment"; but I thought, what the hey, it might just fix something. When it was done, I rebooted.

Then I went to the router administration, turned on the WPA again, and tried connecting. Behold! I will show you a mystery! It just worked. My wheezy old desktop box is now a full-fledged member of my wireless LAN.

The router is a Linksys WRT54G rev 2, with firmware version 3.01.3. The AT&T Plug&Share Ultra 6550G PCI wireless adapter has driver version I am staying away from the AT&T utility and using only WZC.

Thanks for your patient help!

Reply to
Nemo Oudeheis Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.