Wireless Problems With DHCP


I am troubleshooting a wireless network where all laptops with built in wireless work 100%, as soon as a laptop with a PCMCI wireless card tries to connect, it is not getting an IP from the DHCP server.

The server is Win2k3 SBS and is the only DHCP on the network. AP is Netgear, PCMCIA cards are Gigabyte.

I have manipulated the AP in every way possible and still no luck. Laptops with built in Wireless ALWAYS connect and Laptops with wireless cards NEVER connect.

If I, for example, connect wired connection to the laptops with the wireless cards, they immediately obtain an IP from the DHCP on both LAN and WLAN. After that happens I can disconnect the cable and network keeps functioning fine. If I then "Repair" the connection using the Windows repair function, it again can't get an IP.

I also have a wireless network at home and have tested all the PCMCIA cards on my network and they all work 100%. The only difference between the two networks is that the AP I use at home is set as the DHCP server.

What couls be causing this bizarre problem?

Thanks in advance :)

Reply to
Loading thread data ...

"Mantas" hath wroth:

What level of encryption do you have set? WEP, WPA, WPA2? Are you using a RADIUS server?

What model Netgear AP? What model Gigabyte PCMCIA card? What model laptops with built in wireless that works? What card? Numbers please, not vague descriptions.

Have you tried it with encryption disabled?

I'll assume the laptops are running Windoze XP Home with SP2.

Sounds more like a probem with the Gigabyte PCMCIA cards or drivers. Are you using Windoze Wireless Zero Config or are you using the vendor supplied Gigabyte wireless drivers?

Have you tried a different model PCMCIA card?

Disable the SBS2003 DHCP, enable the Netgear DHCP server and see if that works. If this fixes the problem, the question remains whether it's the Gigabyte hardware, Gigabyte drivers, or SBS2003 DHCP server. I can't tell from here.

Also, you might want to try a DHCP query tool: |

formatting link
don't need an IP address for this tool to work. Type in anything for the "device identifier". If you have a static IP address setup on the test client, you'll get from the DHCP server. One common wireless suprise is connecting to the neighbors wireless DHCP server.

If you're using Wireless Zero Config, you might try turning on wireless logging and see what it delivers. Be prepared for huge log files. |

formatting link
Also see: |
formatting link

Reply to
Jeff Liebermann

Any MAC or IP address filtering set up?

Reply to

Hi Jeff,

Thanx for replying so promptly.

Just to let you know that I sorted out the problem. It seems to have been a whole range of things.

Firstly I tried a lucent PCMCIA and that also worked fine (besides for the fact that it only supports WEP)

Then I took my Netgear AP to the site and all the combinations worked with that (even the Gigabyte cards).

That pointed me to looking at the "Troublesome" AP. Flashed the firmware to the latest version and re-configured. Then the gigabyte cards would connect only when there was no security enabled. That then made me think that the cards might have a problem too.

Downloaded the latest Gigabyte Utility, enabled WPA on AP and all is well that ends well :)

I am, however, still baffeled as to why the Gigabyte cards would work

100% with my netgear AP on the same network, but not with the AP installed on site.

The main lesson I learnt from this whole eppisode is.... NEVER EVER supply Gigabyte WLAN cards EVER again (they screw up your whole weekend) :)

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.