Less than Positive Experience installing Linksys WPC54G/WRT54G on Win2K SP4.

I've seen this before once. It was caused by spyware trying to modify the registry at the same time as the installation. Only one program can scribble to the registry at a time. Methinks (not sure) that Linksys non-cleverly tries to hold the registry open and locked for most of the installation. If another program comes along and wants to make changes to the registry, you get a lock error or some bogus error message.
Yep. That's it. My traditional guess(tm) is spyware. However, with all the installs and removals of software you've been doing in the last day and a half, methinks it best to roll back the system to where it was before you started. You didn't bother to specify the operating system, but if it's XP Pro, run the "System Restore" and roll it back to before where you started. If XP Home, my may be lucky and had some program create a restore point for you. The Dell C600 comes with XP so it's a fairly good guess.
For Spyware removal, I use two programs as I can't seem to find one that catches everything. Ad-Aware and Spybot S&D. Both are free and available from:
formatting link
would also suggest running a virus scan with whatever program you find useful.
Time for a mini-rant. You should try doing system troubleshooting over the telephone. It's not easy. It's like back seat driving while blindfolded. However, you're correct about their lack of insight. The common trend in this newsgroup is for people to supply a detailed and often artistic description of what they had done, without supplying any information about what problem they are trying to solve or what hardware/software they have to work with. That makes "insight" important as my crystal ball and Ouija Board run on insight.
That should be a clue. The chances of two different card drivers having the same error are quite small. That also limits the cause of the problem to something in your operating system.
Ok, you have it partially installed. The monitor icon in the system tray probably (not sure) is initiated (started) by the driver. If the driver doesn't start, the icon won't appear. Methinks you're seeing the effects of a partial driver install, not a seperate problem.
The Netgear monitor icon and Wireless Zero Config are mutually hostile. I've seen systems where either the Netgear monitor, WZC icon, or sometimes both appear. However, this is the first time I've heard of neither one appearing. I suggest you dive into: Control Panel -> Admin Tools -> Services and disable (not remove) Wireless Zero Config, and see if the Netgear icon appears.
Ok, you win, maybe.
Hold on. My idea of "connected" includes delivering a DHCP assigned IP address from the router. What did you get? Start -> Run -> cmd to get an MSDOS window. Run: ipconfig If the wireless IP address is 169.254.xxx.xxx, you didn't get a DHCP assigned IP address. If it's 192.168.1.xxx, then it's working. If it's 0.0.0.0, the driver is toast or you didn't give it enough time.
Ok, so we can assume that the router is working normally on the LAN ports.
Oh good. It's working, maybe. However, it doesn't sound like this is going to be a particularly reliable connection if it takes that long to connect. Something is still busted. Incidentally, while you're in the Network window in the Control Panel, see if you have a "Network Bridge" icon. If so, remove it as it screws up connectivity. Here's what it looks like:
formatting link
rid of it.
Yep. Tech support is responsible for fixing what methinks is a screwed up XP system. Methinks if you tried some of the other vendors tech support, your results and probably your opinion of their "insight" would be similar.
Well, let's see.... You probably spent about 2 hours on the phone with free tech support. My guess is that cost Linksys for outsourced support about $60. The WPC54G cost about $50 with about $5 profit to Linksys. Therefore, if 12 people bought WPC54G cards, and you were the only one to call tech support with a problem, Linksys would break even. How much more are you willing to pay to have support improve?
Reply to
Jeff Liebermann
Loading thread data ...
Don't you love the Tech Support Gurus from Bangledesh!!!!
Will we ever see good old American tech support again? We have just switched over to an outsource group in Bagalore at Honeywell, and it is Customer Service HELL!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
RED
Reply to
RED
They're the only people on the planet that can tolerate the job. Burnout rate for domestic tech support people was about 18 months average and about 12 months median (half the people quit within 12 months).
Probably not. Think of it as a subtle hint to learn the programs, operating system, hardware, and RTFM to be able to support your own job function or system. This way you won't need to deal with Bangalore support. There is some hope as Dell is fighting the trend:
formatting link
(Hint: I buy and recommend LOTS of Dell hardware).
No, I think you mean internal support hell. Customer Service is for paying customers, not employees.
This is for ISP's, not wireless hardware vendors, but there are quite a few domestic outsourced support companies.
formatting link
that doesn't come close to the number of such companies in India:
formatting link
reading the "Outsourcing Times" should ruin your day:
formatting link

Reply to
Jeff Liebermann

Hoping this will help someone else that's in Linksys Techsupport Hell
(if you've called them you know what I mean).
I bought the router and wireless adapter from BestBuy. Had no trouble
installing the router at all but the adapter was a problem. Following
the instructions and installing with the wizard resulted in the
following error:
Installation Failed
ErrorCode=-3
ErrorDesc=Required data not found or disk space not enough.
After spending a day and a half running around with Linksys techsupport
(their final analysis was some registry lock problem and that I had to
call MicroSoft), I struck out to surf the various forums I could find.
I found that I was not the only one with this problem as was implied
by Linksys TS's lack of insight. I had even gone so far as to buy a
separate WPC11 Linksys adapter (one of their suggestions) and try that
but had the same result. I was able to have my laptop (Dell C600)
recognize the WRT54G adapter without any problems and it seemed to
install the drivers automatically but it wouldn't connect to the router
and I had no monitor program due to the above error. When I did the
same with the WPC11 adapter I had bought, it installed the drivers and
amazingly it connected to the router!! Of course I still had no
monitor to view signal strength but I figured if that could connect
with the WPC11 then there was no reason I couldn't get the WRT54G
adapter working.
I started from scratch and tried installing from the
'
formatting link
'
formatting link
files
instead of the CD and still had the same problem. So after about a
million reboots and more than twice as many curses, I realized that the
downloaded stuff (and probably the stuff on the CD) had ./Autostart and
./Utility directories. So I double-clicked on the Setup.exe in the
./Utility directory. This launched a less fancy (ie. more useful)
installation wizard. It worked fine with the exception of a "Severe"
error popup referring to a problem reading a key from the registry (but
it didn't specify which key). After clicking to the popup, the
installation wizard continued fine. When all was said and done the
wireless monitor was working finally.
I still didn't have a wireless connection though. The monitor gave an
inaccurate status saying I was connected to the router but the router
was not connected to the internet. If I plugged in a wired connection
to the router then I had connectivity (obviously) and the monitor was
happy. I went into the Network and Dial-up Connections portion of the
Control Panel and disabled the Local Area Network connection. After
waiting a few minutes, the wireless adapter suddenly connected to the
router and now seems to work fine.
Anyway, I plan on sending this back to Linksys with my rather low opion
of their Techsupport service and would advise everyone else who had
problems to do the same. Hopefully if they get enough negative
feedback they might actually improve things (but I'm not holding my
breath).
mike
Reply to
snowdog512
There is plenty of good old *american* tech support available at your local full service computer store. Just look in the yellow pages. When you decide to be cheap and buy discount at BestBuy you are agreeing to solve your issues yourself. I doubt that there is anything wrong with the equipment. Sounds like it is some type of issue with your computer.
Reply to
Si Ballenger
I received the same error code reported by Snowdog512 on a windows 98 se
compaq presario 1685. While the comment made by another reply stated
that the problem may be that the registry is being to by another
program could be true, I encountered the problem shortly after
formatting the entired hard drive and starting from scratch, meaning
that this problem is not due to spyware. Attempted installation in
safe mode produced the same error. I installed AVG antivirus and
AdAware SE and there were no signs of any spyware. Following Snowdog's
advice of using the setup in the Utility folder, I did not receive a
serious error message (but I did receive a message about a driver, but
it seemed to have no effect). I did *not* have to stop any other LAN
or modem connections. After setup and putting in the card, I similarly
saw the card connect to the router after about 2 minutes and then to
the internet after another 5. I'm not sure what caused the problem,
but thanks Snowdog for finding a solution that unfortunately is the
only option unless Linksys takes some initiative.
Reply to
jparsons33

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.