DWL-G650 Rev B3 and DHCP Make Homer Go Crazy!

Hi All,

I have spent about six hours trying to solve a wireless DCHP problem that I am having but to no avail, so I thought I would ask for the advice of some experts who know more that I.


ASUS Laptop with DWL-G650 Rev B3 PCMCIA Card D-Link Router (Can't remember the model number) MS XP Home


Originally I was using the same laptop and router together flawlessly with another DWL-G650 Rev C2 PCMCIA card which I had borrowed but I had to give that back so I purchased a DWL-G650 card of my own.

Little did I know that there are actually about seven variants of this card (HW Versions A1-3, B1-4 and C1-2 I think). The problems started when I changed cards.

First I uninstalled the existing Rev C2 card and re-booted. I then installed the supplied software for the Rev B3 card as per the instruction.

The B3 card is recognised by the laptop and connects to the network (WEP) BUT it cannot resolve an IP address from the Router. Easy I thought, I'll manually assign an IP address, not the best solution but it will get me going. However, when I assign an IP address the connection is established but the wireless MAC address then becomes and I cant do anything.

What Have I tried?

I have manually assigned an IP address: As above.

I have upgraded to the latest drivers from the D-Link web site: No change.

I have removed the B3 card and re-installed the C2 card: Works fine, but I don't own the C2 card.

I have searched the internet for ages to find a solution to the DHCP problem and manually assigning an IP was supposed to be the solution. I have never seen anything written on the MAC address complication though.

Can anyone help? I'm thinking of just throwing the freaking B3 card away but IT SHOULD WORK. It's driving me insane.

Anyone come across this before?



Reply to
Loading thread data ...

fwiw I had similar snafu not saying its your snafu, but might be,,, router here, di624a associated original mac with laptop name,,, would not clear this via normal reboot nor overwriting with firmware.bin I stick in a new pc card in the laptop, the router would always assign that laptop an ip to the laptop name but always to the wrong same old mac address.

Had to Power down and up the router while holding in the reset to get the router to totaly clear itself and ask for path to firmware. Then reprogram the whole thing manually... which is painful here, because the error still exists in saved config.bin . Once router was clean and manually re-configured everything was fine.

Reply to

"bumtracks" wrote in news:oidze.29939$mr4.3469@trnddc05:

Actually there is an easier way (I have a Dl624 not the 624a so there may be a difference). If you disable the MAC filter, the router will let the laptop connect with the new card, it will also show the MAC in the filter menu so you can clone it and associate with the laptop. After this enable MAC filtering again.

Hope this helps

Reply to

Thanks for the help guys but this is not relevant in my setup. I don't have MAC filtering enabled on the router at all.



Reply to

"Ish" wrote in news: snipped-for-privacy@dnews.tpgi.com.au:

The only other thing I can think of is a flaky wireless card. I got the B revision G650 and it was very unstable. It did connect, but not always and sometimes reported a very low signal. I returned it and got a revision C. That solved the problem. Good Luck

Reply to

I had a very similar problem only I had a desktop computer that could not connect to the DI624. I could get an IP address but could not ping the router or get internet access. The solution was to change the "media" settings for the network adapter from "Autosense" to 100mbps full duplex. When in Autosense, it had a problem negotiating a reliable connection to my router. Now everything works well. MC-

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.