DHCP doesn't give right IP

I just got my Linksys WRT54GL wireless router, set it up and DHCP doesn't get my laptop right IP. Router IP is set to and DHCP server is enabled (IP range I can connect to it but internet wouldn't work cause it sets my parameters like this:

-IP address: or 217

-Default gateway:

-DHCP Server:

-DNS Servers: I have ADSL line and modem Sagem 3344. I deleted entry for DHCP on my modem and it's working in modem mode (no username and password set in setting). My connection is set from modem to router and then from router to 2 switches for desktop PCs (I manually set their IPs and internet works for them without problem). Also tried on other laptop and same story. If I manually set IPs on wireless adapter internet works with no problem. At first I thought that maybe if I upgraded firwmare problem would be solved but it didn't help. I upgraded to Tomato firmware version 1.10. If anybody has any idea what could be wrong I would really appreciate it :)

------------------------------------------------------------------------ View this thread:

formatting link

Reply to
Loading thread data ...

I suspect that your laptop is getting its IP from another WAP - one with IPA=, instead of your intended router. Probably a router in a neighboring house.

Reply to
Bob Willard

Claymore hath wroth:

That's not your DHCP server. Try changing the entire Class C network IP block in case you're getting your numbers from the neighbors. Something like: 192.168.5.xxx

Hmmmm... You apparently have two DHCP *SERVERS* running. One in the modem and one in the router. You can do that but if Tomato has DHCP passthru or proxy DHCP enabled, it's possible for the clients to end up getting their IP's from the modem instead of the router. Methinks it best to totally disarm the DHCP server in the modem, and rely on the DHCP server in the router. The DHCP *CLIENT* in the router should be unaffected.

OK, so it's not the unspecified operating system running on the client computers. That leaves the router and the modem.

Try this simple test. Disconnect the modem from the router. Power cycle the router. Flush the DNS cache on your unspecified operating system client computer(s). Get a new IP from the router with the modem disconnected. Does that work? If yes, then fix the setting in your modem. If not, then there's something goofy in the router.

You can also do some diagnostics using a DHCP tool:

There's also a similar Linux DHCP tool.

Tomato is now at 1.11.

Reply to
Jeff Liebermann

Change the SSID of your router to make sure you are connecting to it Lots of folks leave the "Linksys" name as the default SSID, and it looks like you are connecting to someone else's Linksys Access Point.

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.