802.11g vs b (and why I hate my wireless adapter)

Hi everyone,

So, I have a Satellite A85-S107 with an Atheros AR5005G wireless adapter (with the driver) and I'm having this issue where, I can be sitting dead-square in front of a 802.11b access point and I can "see" the access point using different utilities, but the adapter will absolutely not connect to it.

Yet, if there is even the slightest chance that there is an 802.11g access point on my side of the planet, this puppy will do everything in its power to connect to the g.

Worse yet, if I have the above combined into one situation, my computer hopelessly looks for g's when there's plenty of b's.

Please, if the above alphabet soup makes sense to you, tell me if there's a way to have my adapter choose WHATEVER'S STRONGEST/CLOSEST, as opposed to this elitist mentality that it currently uses to shoot itself (and me) in the foot. The adapter is supposedly 802.11b/g compatible, but I'm just not seeing it.


Reply to
Loading thread data ...

Open the card properties in Device Manager, and look for an Auto setting. It is likely set to "g" only.

Reply to

[I assume that's the latest driver from Toshiba? I'm not seeing drivers on the Atheros site...]

Is there anything in the driver that'll allow you to pick your preferred mode, or select "B Only"? Check the Device Manager...

Reply to
William P.N. Smith

What's the make and model of your 802.11b access point?

Other have suggested the "g-only" mode as a potential culprit. It's possible but as I recall, the access point is what determines if it's going to play g, b, or both, not the client. Dunno, but it's worth checking.

I like to troubleshoot things by substitution. Some questions:

  1. Are you using Windoze Wireless Zero Config as a client/driver or are you using the Atheros monitor program? Windoze WZC has a feature in the advanced settings that says something like "connect to any available access point". That may not be the cause but it certainly will not help if it's checked. Also, edit the preferred order of SSID's that it will try to connect. If it's really full of other SSID's and you're is at the bottom, it may never get around to connecting.
  2. It's not clear if you are able to connect to your 802.11b access point in the absense of 802.11g traffic. Is this the case? If not, then it may be a simple WEP or WPA key mismatch that's causing the client radio to look for alternative access points. Can you connect at all? If not, have you tried connecting to your 802.11b access point with another wireless client? If it's misconfigured or defective, nothing will connect.
  3. Can your client radio connect to any of the other 802.11g access points that it hears? I'm trying to determine if the Atheros card and driver are actually functional
  4. I've seen flakey RADIUS authentication servers do something vaguely similar when AP can't find the authentication server. Are you using RADIUS?

You'll have to wait for 802.11r to be released, which will do that in addition to fast roaming and switching between access points.

Reply to
Jeff Liebermann

Is this an Atheros card, or an Atheros chipset on someon else's branded card?

Does this card have "extendedor "turbo" abilities on 802.11b? I could not get my SMC-something card to connect to a Netgear WGR614v4 until I disabled the 22Mbps mode on the SMC card.

Reply to

Thank you all for your replies! I'll answer your questions as they appeared:

Quaoar: No, there's no option like that unfortunately; that would be a nice fix

Mr. Smith: Yes, that's the latest driver from Toshiba. I don't know why Atheros doesn't have customer support options...

Mr Liebermann: I think they're all SMC. I'll check for the model #s No, I can't connect to 802.11b APs at all. All of our APs have the same SSIDs (and thus all take the same WEP password), it's just that some are b and some are g. I can't connect to any of the Bs but CAN connect to the Gs. Do you think I need to change my Authentication Method from "Open" to "shared"?

Mr Dold: This is a real Atheros card and chipset as far as I can tell. As for the "turbo" mode, no, all is has is a long and short word option, that's about it.

Any ideas folks?

thanks for the help thus far!!

Reply to

You didn't mention that they all had the same SSID. With all the SSID's identical, you have zero control over which access point your client will connect. Most, if not all, client software does not offer you a selection of SSID/MAC addresses, just a selection of SSID.

Incidentally, how do you know that you're connecting to the "g" and not the "b" AP's if all the access points use the same SSID? By the MAC address? By the speed?

I've seen this before and I don't think it's fixable. The problem is that the "philosphy" of the driver writers is to always use the fastest connection possible. There's also a tendency to have the access points control the connection instead of the client. With a network of identical SSID access points, the Toshiba/Atheros client will always try to connect to the fastest, not the strongest, access point. If you temporarily setup an 802.11b access point with a different SSID, you'll find that you can easily connect.

I temporarily "solved" (kludged) a similar derrangement of mixed access points by setting the speed on the 802.11g access points to a fixed 9Mbits/sec which is the slowest OFDM rate. Most of the clients would then connect almost randomly between the access points. I really don't know how well it worked in practice because a week later, I replace the 802.11b access points with all 802.11g access points.

Well, with identical SSID's on the access points, you should *NOT* be able to select which access point you connect. How are you making this connection selection?

No, open is more secure.

Reply to
Jeff Liebermann


I have a (graphically) neat little Toshiba software program called Configfree which has this radar-like screen showing all the APs in range. It gives their MAC address, b/g setting, etc etc. But when I try to connect, it doesn't let me go to the b's, probably for the reason you stated above.

That's great..even if it's the weakest??

Client side, I suppose I could always try and find a way to shut off the g capabilities of the client when I know I'm in a strong b / weak g area.

Thanks for your help!

Reply to

Config Free is actually a nifty program for fixing network problems. The radar display shows the strongest access points near the center and the weaker near the edge. I never could get auto-switch to work right for more. There were some updates recently to fix some Bluetooth problems. You might wanna check for updates for your unspecified model laptop:

formatting link

Some day, I'll learn to spell philosophy.

I think so (not sure). When the client radio is in the 802.11g mode, it will not hear 802.11b access points. Same when in the 802.11b mode. It won't hear 802.11g access points. It has to intentionally "scan" for access points. All it takes is for the client software to force the mode to 802.11g and it's deaf to anything that's stuck on


My guess(tm) is that the Toshiba driver is scanning for access points starting with the highest speed and protocol possible. The radar like display might show two access points with the same SSID as different target access points. However, when your client scans downward in speed, and sees the highest speed access points with the correct SSID, it will stop and connect without ever continuing downward in speed. This is what 802.11n is suppose to address, but I suspect they too don't want to deal with 802.11b "legacy" hardware and operate much in the same way. Again, this is my guess(tm) and may not be the way it works. You can prove the point by temporarily changing the SSID of one of these access points to something else and see if your small Toshiba magically connects.

I don't think that's possible. The access point controls the speed and mode of the client. What is possible is that you can disarm Config Free and use Windoze Wireless Zero Config. There's a setting in Config Free to "Start when Windoze Starts" or something similar. Uncheck, reboot, right click on the wireless device icon in the system tray, select "Show Available Networks" and see if things work better. I don't think it will help, but it's worth a try just in case Config Free is causing the problem.

Any more clues such as the model of your laptop, Windoze operating system version, and whether it has SP2 installed? Do these multiple access points have some type of load balancing scheme going such as:

formatting link

Reply to
Jeff Liebermann

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.