1/2 of my.yahoo Modules not working unless connected to VPN


I posted this on one of the Cox Internet groups, but thought maybe someone here would see this and know instantly what is going on.

I do not know much about VPNs or the "pipes???" that data takes when one is connected or disconnected. As I picture it, if I make my VPN connection, and then open a browser and connect to a website, the data is being transferred through my company's T1 then through Cox to me. If I disconnect the VPN, then my data is coming just through Cox.

If I'm right about that, would that account for the behavior I observe tonight as described below?

Thank you. This may be a bit off topic for this group, but I figured that there must be some smart VPN types over here that could give me a clue. Cox tech support did not sound like they knew very much, though maybe that is because I know a lot less!

Thank you. Tester


For awhile tonight, I thought there was something wrong with my.yahoo.

You know how you select 50 or 60 modules, like REUTERS TOP NEWS STORIES, or a TV GUIDE and they all pop up on your my.yahoo page and display a list of stories or whatever? Mine has always worked fine, for years, with few problems.

Today, about half of the modules say "no items." All the REUTERS, the TV stations, the TV GUIDE, San Diego Daily Transcript, and others.

Stock Portfolios seem OK, and so do things like Chicago Tribune, Tom's Hardware guide...

I figured that Yahoo was having server problems or something.

However, I used a VPN connection to connect to my computer at the office for a few minutes, and happened to open my browser while connected through the VPN, and the local my.yahoo page worked fine. As soon as I disconnected the VPN, it went bad again.

Any ideas?

If you are tech savvy enough, you might know immediately what's up with the difference between the VPN and no VPN connection.

The Cox tech support told me it was not their problem and I should talk with my company or Yahoo. It seems pretty obvious to me that the problem is not theirs.

He didn't seem to really catch on about what my.yahoo is, but I told him you could add modules and that they display when you log on. He said maybe something is wrong with my cookies, that the info about what to display on the my.yahoo page is stored in my cookies and not on the Yahoo server, and that is probably it.

That doesn't seem like the problem to me.

Please help. I already cleared my cache, rebooted, have latest S/W versions, and get the same results with both IE and Firefox, all on a WINXP PRO box.

Please help.

Thanks! Tester

Reply to
Loading thread data ...


I am not the most tech savvy guy, but after 30 years of fooling around with computers, I sometimes get it right.

It appears to have been the MTU setting on my router.

I found that if I connected the PC directly to the cable modem it would work. When I reinserted the router, it would not. I have had a number of strange things happen because of this DI-514 router that I never had with my

704P. When it died, I had the 514 laying around and used it.

It is amazing to me how much weird stuff starts to happen out of the blue that is caused by this router.

All fixed.

IMHO, Cox could have suggested disconnecting the router, etc. They are supposed to be a bit smarter and more helpful than their guy was last night.

Reply to

Cox does not pay enough to attract and keep people who are smarter and more helpful.

Anyhow. Dlink has some pretty bad firmware bugs. Make sure you upgrade your router if it is running old versions. I cannot say that the latest version is always the best choice either. They have been known to introduce bugs in new revisions that didn't exist before.

I'm sure that the Cox troubleshooting training would include disconnecting routers and firewalls as a troubleshooting step. The person you talked to just didn't think of trying this.

Good call on the MTU setting though. Devices are supposed to figure out the path MTU automatically but it can often fail for unexpected reasons. Perhaps Cox started filtering ICMP traffic on one of their routers causing the MTU calculation to fail. A provider will sometimes turn off ICMP to avoid certain denial of service attacks. It would be better if they could disable it only when the load on the router climbs too high.

Reply to
Que Ball

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.