Linksys BEFSX41 Odd Behavior?

Firewall Wizards,

I've been using above mentioned router for several years now and have been happy with it for the most part. However, I believe I have narrowed down a problem I'm having to it, and wanted to know if anybody else has seen this. Firmware version is 1.43.3. I know there is newer firmware, and I might upgrade if it is strongly recommended, but my research on *that* shows some mixed reviews. So I'd like to save that option as a last resort.

Brief description of the problem... I recently connected a Prismiq MediaPlayer unit to my home network. This device streams audio, video, and images from a media server (in my case a W2K Pro box with their accompanying Media Manager software installed) over a home network to a TV. Audio and video work fine, but the images won't display. After a conversation with their tech support, I learned of several ports over which the media server and the MediaPlayer must communicate in order for everything to work as advertised.

I connected the MediaPlayer via crossover directly to the media server, and everything worked, including images. But with the two connected via the BEFSX41, no images. It is the same behavior whether I have the A/V software (Norton) and the firewall software (ZoneAlarm) on the media server enabled or disabled. The ports that need to be wide open between the two devices are 7777, 8081, 8080, 2498, 2650 & 554. However, I didn't think the BEFSX41 was supposed to in any way block traffic between LAN ports.

Here is another data point. I have a 4-port dumb hub connected to the BEFSX41, and have both of these two devices on that hub. With the hub jacked into the Linksys device, images do not work, but they do if I disconnect the hub from the Linksys box. I suppose that's because everything has the Linksys box as its default gateway, so when it's in the loop so to speak all traffic goes to it as the next hop.

The only thing I could see anywhere on the Linksys box management interface that even remotely looked like it might be involved was that remote management (default port 8080) was disabled. However, it is my understanding that is meant to block port 8080 requests inbound to the WAN port, and supposedly doesn't affect 8080 traffic on the LAN side. Just for grins, I temporarily enabled it anyway , but still no joy.

Anybody got any ideas? BTW, this Prismiq unit is pretty cool, if I could ever coax full compatibility with my network out of it. :-) It's functionality is pretty basic, for instance the web browser is workable if spartan, but for what it was designed to do it is pretty slick for the money. (I don't work for Prismiq and don't know anybody who does, although I feel like I know the tech support staff :-).

Thanks for your time and consideration, LLB

Reply to
Loading thread data ...

Roger that on keeping the ports closed on the router.

Let me clarify on the connectivity issues. The specific problem is only with images; video and audio stream successfully if the router is in the picture or not. In all cases, the Prismiq device and the PC media manager W2K box see each other IP-wise. They can ping each other, and as I mentioned, video and audio always work.

Under the following circumstances, audio and video *and* images are work and are displayed correctly at the TV: - if PC and Prismiq device are directly connected via crossover ethernet cable; - if PC and Prismiq device are each connected to hub port and hub is not connected to Linksys router.

Under the following circumstances, audio and video work at the TV, but images will *not* display: - if PC and Prismiq device are each connected to Linksys ports; - if PC and Prismiq device are each connected to hub ports, and hub is connected to Linksys router.

Thanks for your time and help, LLB

Reply to

Both devices have fixed IP addresses configured, and (I should have put this in the original post) always have. Likewise, the Linksys router has now and has always had DHCP serving disabled. These reported results as originally posted are with the configuration you suggested in your first response.

Reply to

So, if you direct cable between the box and the tv it works, even though neither device has an IP?

If the devices work when using a X-Over cable you must have assigned IP's to the devices, this means that you need to correct for the linksys IP once you put it in the picture:


IP of Linksys (internal network address) Mask

Device 1 (if not DHCP ready) IP Address Mask Gateway DNS1 (or ISP's DNS1)

Device 2 (if not DHCP ready) IP Address Mask Gateway DNS1 (or ISP's DNS1)

Now, all devices connected to the LINKSYS 4 ports, hub can connect to one if needed.

Now, all devices can see each other.

DO NOT OPEN ANY PORTS ON THE ROUTER unless you want the outside world to be able to get INTO YOUR DEVICES. Port Forwarding is from External Network to Internal Network and has nothing to do with internal devices being able to see each other.

Reply to

It's not the Linksys, it will run TCP/UDP on the internal network without any rules/blocking.

It would seem to me that you have a IP address problem, so, open the Linksys configuration settings, disable DHCP service, so that the router can not issue addresses, then assign a fixed IP to each device as I outlined in the prior post.

When you connect the Linksys, since it defaults to DHCP enabled, it's issuing an IP to anything that asks for it - and I'm guessing that something you have Prisimq or PC have fixed IP's and they don't align with the router properly.

Please set the devices as I posted in the prior post, reboot everything, then tell us if you still have a problem.

Reply to

How about posting the full IP config of each device:

IP Address: MASK: Gateway: DNS1: DNS2:

IP Address: MASK: Gateway: DNS1: DNS2:

IP Address: MASK: Gateway: DNS1: DNS2:

IP Address: MASK: Gateway: DNS1: DNS2:

Reply to

Ok, I'll play along. Could you please help me understand why you are convinced it is an IP address problem when two of the three media types always work, namely audio and video, but not jpg images? I would sincerely like to understand your line of reasoning on this. I have read and re-read your posts, and am not seeing it. Also, during this testing, there is no active WAN link to the ISP, and DNS is not even in the picture, everything is at the IP address level, but I've included DNS info as you asked. Here are the network configs:

Linksys router LAN side IP Address: MASK: DNS1: DNS2:

Prismiq MediaPlayer IP Address: MASK: Gateway: DNS1: DNS2:

Media Manager PC: IP Address: MASK: Gateway: DNS1: DNS2:

Reply to

Because inside the network, the 192.168.66.X network, there is NOTHING that the Linksys will do that can cause the problem. You said the machines/devices do not work when connected to the linksys, and since the linksys is acting as a network switch and gateway, there is little that it can be, other than improperly configured gateway/ip information.

Lets make life simple:

Linksys router at: IP: MK:

Prisim Media Player IP: MK: GW:

Media Manager PC: IP MK: GW:

All systems use DNS as you have it: DNS1: DNS2:

To test, from the PC, Ping - should be good Ping - should be good Ping - should also be good Ping, should be Ping, should be

If the Media Player allows diagnostics, them do the same PING's and let me know how it works, everything should ping good.

I understand that you think it should have already been working, but, based on your information, it appears to be time to go back to basics.

One other thing - If you are running ANY firewall applications on ANY of those systems, you need to disable them. The router will protect you against inbound attacks during this test.

Reply to
Leythos Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.