VPN client disables my LPT1 parallel printer port

I am running the VPN client on my Windows XP SP2 machine (an AMD Athlon 2600 on an MSI Nforce2 motherboard with an onboard parallel port connected to an old but trustworthy dot matrix printer.) I use it to connect to the National Institutes of Health, where I work.

It seems that every time I connect, it permanently disables my parallel printer port. After a week of hair pulling, I stumbled upon a way to get my printer working again. What I have to do is go to the Control Panel, System, Hardware, Device Manager, Ports, Parallel Port, Port Settings. I can then change the value of Filter Resource Method to anything at all (use, not use, or sometimes use interrupts) and click OK. Then my printer works.

I have to do this every time I use the VPN and want to print afterwards.

Is this a "feature" of some kind? Is it trying to protect me from attack by my poor old printer?

Is there any way to stop this behavior? If not, is there some way to correct it without going through the cumbersome dance described above?

I'd report the problem to CISCO but I couldn't find a good way to do it on their website.

Thank you very much.


Reply to
Alan Meyer
Loading thread data ...

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.