STP and Apple Mac's


I have 3 offices, each with a 6000/6500 series switch, each with Sup2/MSFC2's. Each office has a mix of apple mac's and PC's/servers. At 2 of my offices, the apples connect to the network with no problems, but at 1 site, i get problems. The problems are, that when you reboot the mac, it comes up saying the appletalk network is now available. You then have to go to control panel|appletalk, and save the settings. You can then use chooser as normal, and the zones are displayed correctly. Without going to control panel, the zones do not display, and you get limited functionality. The office with the problem, runs RAPID-PVST+, and I have enabled portfast on the ports. (with or withough portfast makes no change)

Anyone got any ideas, as all my mac users have to follow the procedure a couple of times a day!

The only solution I can think of is to disable spanning tree completely on the switch, but I don't really want to!

Many thanks to you all,


Reply to
Loading thread data ...

there are some other Cat options that can delay port startup.

Try the "set post host" macro on the affected devices and see if that helps.

if you have got portfast turned on , then it isnt (shouldnt be) spanning tree.

Reply to

Perhaps the time budget is very tight? You may want to turn off other negotiation protocols PAgP etc. with the macro "set port host" command.

The only other thing I would try is to shut down *ALL* Appletalk talking devices (printers, MACs, Columbia Appletalk Unix boxes etc) for

15+ minutes.
Reply to
Hansang Bae

Hi all.

Thanks very much for the replies. The set port host command seems to have done the trick. I looked at the port config before running it, and it seems to have just changed the trunking to off, instead of auto, and port channel to off.

Nice tool!

Thanks again,


Reply to
Imayroam Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.