ospf flood kills interface

Thanks in advance for any help. I realize that I probably won't give enough info at first but I can post configs or diagram if needed. I have a multi-area ospf network with Cisco 3640's running IOS 12.4. I initially had 2 areas configured. Area 0 and are 2. Router 1 is my ASBR in area 0 with 5 fa interfaces. Router 2 is my CORE in area 0 and in area 2 with 3 fa interfaces. When I set this all up in my lab initially before deployment all worked well. Router 2 has the interface in area 2 (ACCESS) for my wireless ISP customers with Netgear, Dlink, Linksys, etc. routers at their locations. Roughly 40 customers. After about 4-10 hrs. of uptime I start to get OSPF floods from src. to dest. The MAC addresses that show up seem to be random MACs with a src of Once this starts it is a matter of seconds before that interface just dies.

Etherpeek capture: SRC:IP- DEST:IP- 74 0.005002 ICMP DestUnreach Protocol unreachable: I know is the OSPF advertising

FA3/0 is the CORE side of the router in area 0. FA0/0 is the ACCESS side of the router in area 2

Now if I reload the router or shutdown the ACCESS interface it will come back for a while and do the same thing in a matter of hours. I have eliminated hardware by replacing the routers with different chassis and FA cards. But still get the same results. I also configured 2 more routers with the same config to try and make the problem happen in the lab but I cannot regenerate it. I currently have the production routers setup with static routes and OSPF turned off and have no problem besides the overwhelming static route additions for all my other routers to deploy. This network is a stub network at the present moment but I did not configure it as a stub since I plan to hang another router from this area.

Reply to
Loading thread data ...

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.