[Linksys/Cisco BEFSX41] Connected DSL, ping works, all DNS queries fail


All is in the title.

The brand new router is connected to my ISP through his DSL box, which is configured in simple bridge mode.

The connection is on: from the PC in IPCONFIG /ALL, I can see the IP of the DNS servers, and I can successfully ping them.

But simply pinging any domain name fails: no resolution. And so no Web etc.

I tried on LAN side both in DHCP and fix IP mode, no change. I tried to completely disable the firewall, no change.

Actually, the router simply does not properly propagate the DNS queries :-(

Notice that the same connection works when replacing only the router with my old one (Netgear).

Maybe a tip... I adjusted the MTU to 1492 because it is recommended for the DSL box. I've read in some advices that there could be a related problem with some Linksys routers (due to a bug in the firmware ?).

Any idea of what is happening ? Thank you.

-- Best regards.

-- /**************************************************\\

  • Patrick BRUNET
  • E-mail: link in
    formatting link
Reply to
Patrick 'Zener' Brunet
Loading thread data ...

Hello Me.

"Patrick 'Zener' Brunet" a écrit dans le message news: f9mhhi$m2c$ snipped-for-privacy@shakotay.alphanet.ch...

So if someone finds the question, here is the answer:

I got it to work by setting the MTU to disable (custom value), so enabling automatic management.

Finally if it manages to manage, why not ?


Reply to
Patrick 'Zener' Brunet

Me again.

"Patrick 'Zener' Brunet" a écrit dans le message news: f9n4ij$aob$ snipped-for-privacy@shakotay.alphanet.ch...


OK, DNS works but many timeouts after, really unusable :-@

I downgraded the builtin firmware v.1.50.18 to old 1.45.3 and now, all works fine, even when setting back the MTU to manual value of 1492.


Reply to
Patrick 'Zener' Brunet

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.