DHCP relay problem

post the config without passwords

Reply to
Loading thread data ...

My Windows XP SP2 client is unable to acquire IP address from Windows 2003 DHCP server. I configured ip helper-address on SVI... ip forward-protocol udp has been entered. I tried this on Catalyst3750 and 2811 router and there is no success...please help... My windows client always acquire address from dhcp server when they are both in the same VLAN. Of course, interVLAN routing works properly...

Is there something else to be configured?

B.R. Igor

Reply to

The command "no service dhcp" maybe disabling the DHCP relay agent.

Try removing that command to see if the router will perform the required DHCP realy agent function.

Please post outccome.

Reply to

Here is my show run output:

------------------ show running-config ------------------

Building configuration...

Current configuration : 6301 bytes ! ! Last configuration change at 10:06:48 CET Fri Feb 11 2005 by manager ! NVRAM config last updated at 17:47:56 CET Wed Feb 9 2005 by manager ! version 12.1 no service pad service timestamps debug uptime service timestamps log datetime localtime service password-encryption no service dhcp ! hostname INEM_c3750 ! logging buffered informational enable secret ******** ! username ******* password ******* clock timezone CET 1 ip subnet-zero ip routing ! ! policy-map test ! cluster enable Koncar 0 cluster member 2 mac-address 0011.21f7.0b40 ! ! spanning-tree mode pvst no spanning-tree optimize bpdu transmission spanning-tree extend system-id spanning-tree vlan 1 priority 24576 ! ! !

interface GigabitEthernet1/0/15 description This is where DHCP client connects switchport access vlan 3 no mdix auto no cdp enable spanning-tree portfast spanning-tree guard root

interface Vlan1 description This is SVI for DHCP Server's VLAN ip address !

! interface Vlan3 description SVI for DHCP client's VLAN ip address ip helper-address ! router eigrp 1 redistribute static metric 1000000 20 255 1 1500 network network network network auto-summary no eigrp log-neighbor-changes ! ip classless ip route ip route ip http server ! ip access-list extended CMP-NAT-ACL dynamic Cluster-HSRP deny ip any any dynamic Cluster-NAT permit ip any any ! logging snmp-server community RO snmp-server community RO

! line con 0 line vty 0 4 exec-timeout 0 0 login local line vty 5 15 exec-timeout 0 0 login local ! ntp clock-period 36028942 ntp server end

------------------------------------------ B.R. Igor

Reply to

I tried to enable DHCP service, but there is still nothing... I checked what's happening using 'debug ip dhcp server packets' and discovered that my switch actually do dhcp bootp messages forwarding to the ip helper address... So, it seems that there is a problem with DHCP server config.

I suppose that the following is happening:

- switch forwards bootp message and rewrites 'giaddr ' field (with value of client's SVI ip address)

- DHCP server receives this message and reads that according to 'giaddr' field' client is not on the subnet for which server has a range (this is my production DHCP server, so it has a range on single subnet and VLAN for client is testing environment).

- DHCP server refuses to send DHCP offer.

If this is a cause of my problem then it's obvious that I'm expecting the impossible:) I hoped that my DHCP server will issue a production range (just to test if my dhcp relay is working), but I overlooked 'giaddr' field...

Next week I will create an additional scope on my DHCP server and then try again...

Of course, I'll post outcome

B.R. Igor

Reply to

Yep. That's your problem.

That'll work.



Reply to
M.C. van den Bovenkamp

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.