Clear Lines via SNMP

Does anyone know how to clear a tty line via SNMP? I tried using the tsClrTtyLine Oid but I always get -1 as a response, which indicates no line has been cleared.

To be clear, I'm sending a SET request for and the value is the tty line number (so 1 for line 1, etc).

Any ideas?

Reply to
Loading thread data ...

An snmpwalk of a router here does not return that branch at all.

We want -

enterprises. = Timeticks: (184249) 0:30:42.49 enterprises. = 23482 = enterprises

This is on an 877 with

(C870-ADVIPSERVICESK9-M), Version 12.4(15)T7

I guess that they finally did away with the old (useful) mibs:-(

I use an ancient but free UCD set of snmp command line utilities for windows. UCD-snmp version: 4.2.3

There may be an equivalent in the new mibs? I will have a bit of a look, however I find it all a bit obscure.

Reply to

This is on an AS2511-RJ. Quite old but still insanely useful for what it does. Walking this device does show it there, and it does respond to the set (ie I do not get a null branch response). In fact, a 2821 I tried it on also responded with -1. According to Cisco's MIB locator the MIB this Oid is in is supported by both of these routers, with the IOS versions they have (12.3.26 for the 2511 and 12.4.24T1 for the 2821). The Oids above it are marked as not accessible in the MIB, so a walk probably wouldn't get there. Try a get aimed at that Oid. The number it returns to you indicates the last line that was cleared by the command or -1 if no line was cleared. I just can't make the thing work like the Cisco documentation says it should (ie issue a set command to that oid with the number of the line you want to clear).

Reply to
bthetford Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.