AS 2511 RJ ...open

Guys! I wonder if you have used one in a cisco lab? I am using a rollover and the no exec command under line 1 16 ...

and ip host 2501 2001 172.25.1.1 (the loopback)

and all it does is say conncting ... open and it hangs there! No returning or anything breks it to the router prompt!!!

Any ideas? Thanks

snipped-for-privacy@gmail.com

Reply to
william
Loading thread data ...

Thanks Merv, I did that as a last ditch effort, I am connecting to a

2500 (6 of them) and 2x 2621's... I will try again and post the error.
Reply to
william

here is wha tit looks like: The config from the 2511 and the sh line (clear) and then the command I try and the "...open" resonse: AS2511rj#sh run Building configuration...

Current configuration : 694 bytes ! version 12.3 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname AS2511rj ! boot-start-marker boot-end-marker ! enable secret 5 $1$RKbh$hVnrDrW4JTdXJaYNviptr/ ! no aaa new-model ip subnet-zero ip host r1r1 2001 172.21.25.11 ! ! ! ! interface Loopback0 ip address 172.21.25.11 255.255.255.255 ! interface Ethernet0 ip address 192.168.1.254 255.255.255.0 ip directed-broadcast ! interface Serial0 no ip address shutdown ! no ip http server ip classless ip route 0.0.0.0 0.0.0.0 192.168.1.1 ! ! line con 0 line 1 16 no exec transport input telnet line aux 0 transport input all line vty 0 4 password cisco login ! end

---------- AS2511rj#sh line Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

  • 0 CTY - - - - - 3 0 0/0 - 1 TTY 9600/9600 - - - - - 2 1 0/0 - 2 TTY 9600/9600 - - - - - 0 0 0/0 - 3 TTY 9600/9600 - - - - - 0 0 0/0 - 4 TTY 9600/9600 - - - - - 0 0 0/0 - 5 TTY 9600/9600 - - - - - 0 0 0/0 - 6 TTY 9600/9600 - - - - - 0 0 0/0 - 7 TTY 9600/9600 - - - - - 0 0 0/0 - 8 TTY 9600/9600 - - - - - 0 0 0/0 - 9 TTY 9600/9600 - - - - - 0 0 0/0 - 10 TTY 9600/9600 - - - - - 0 0 0/0 - 11 TTY 9600/9600 - - - - - 0 0 0/0 - 12 TTY 9600/9600 - - - - - 0 0 0/0 - 13 TTY 9600/9600 - - - - - 0 0 0/0 - 14 TTY 9600/9600 - - - - - 0 0 0/0 - 15 TTY 9600/9600 - - - - - 0 0 0/0 - 16 TTY 9600/9600 - - - - - 0 0 0/0 - 17 AUX 9600/9600 - - - - - 0 0 0/0 - 18 VTY - - - - - 3 0 0/0 - 19 VTY - - - - - 0 0 0/0 - 20 VTY - - - - - 0 0 0/0 - 21 VTY - - - - - 0 0 0/0 - Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
22 VTY - - - - - 0 0 0/0 -

AS2511rj#r1r1 Translating "r1r1"...domain server (255.255.255.255) (255.255.255.255)Trying r1r1 (172.21.25.11, 2001)... Open

(THEN NOTHING...nothing at all until I hit cntrl shift 6,x) which dissconnects. What am I missing?

Reply to
william
  1. config is okay

  1. are you sure that the console port you are trying to connect to is configured at 9600 bps ? have you connecedt to the console port directly using a PC?

  2. have you tried using any other ports on the as2511 to test reverse telnet besides line 1 ?

  1. from what I could find, I believe the pinout for the as2511-RJ async ports are as follows and thus would require a straight thru cable

Terminal Server Port pin outs

pin signal

1 CTS 2 DSR 3 RXD 4 Signal Ground 5 Signal Ground 6 TXD 7 DTR 8 RTS

Cisco Console Port (DTE)

Pin Signal Input/Output

1 - - 2 DTR Output 3 TxD Output 4 GND - 5 GND - 6 RxD Input 7 DSR Input 8 - -
Reply to
Merv

are you hitting the enter key after you get the open message ?

Reply to
Merv

this is what the 2600 Con 0 looks like: ! ! line con 0 line aux 0 line vty 0 4 login ! end

------- when I use a straight thru I get this message:

AS2511rj#clear line 1 [confirm] [OK] AS2511rj# [Resuming connection 1 to r1r1 ... ]

[Connection to r1r1 closed by foreign host] AS2511rj# AS2511rj# AS2511rj#

- I have tried one 3 of the 2500's and 2 of the 2600's also!

I feel like I am really close, so I appreciate the help!

Reply to
william

Have you tried using line 2 on the as2511 - i.e reverse telnet from

2002
Reply to
Merv

Yes sir, about 2-10 times....

Reply to
william

Well its the same sresult if I use the rollover, "open" and if I use the straight thru it looks like this: AS2511rj#telnet 172.21.25.11 2002 Trying 172.21.25.11, 2002 ... % Connection refused by remote host

Reply to
william

Here's the config I use on mine and it works fine. line 1 15 no exec exec-timeout 30 0 logging synchronous transport input all transport output none stopbits 1 flowcontrol hardware

Reply to
Brian V

Try port 8 with a straight-thru cable and ensure you clear the line before you attempt the reverse telnet

Reply to
Merv

Did that; cleared the line, then I tried on async 8. same....open!

this is killing me. And all these Con0's work with a straight thru console session and a pc (with hyperterm, and SecureCRT) and I have tried through the 2511 console, through telnet through the console, and telnet from my desktop through to the 2511 and then reverse telnet from those connections too!

Reply to
william

Hello! Glad nobody has given up yet! it did not change a thing... you have a as2511rj? what do you have on your Con0's on the other routers? Any security settings or anything?

Also, can I check the health of these ports (async ports?) I AM ABOUT TO CHANGE MY IOS!!!!

I did the research and got the latest non buggy for the 2511 series, here is the sh ver:

(Anything I am missing?) Brian, what version are you using? AS2511rj#sh ver Cisco Internetwork Operating System Software IOS (tm) 2500 Software (C2500-C-L), Version 12.3(18), RELEASE SOFTWARE (fc3) Technical Support:

formatting link
(c) 1986-2006 by cisco Systems, Inc. Compiled Thu 16-Mar-06 00:19 by dchih Image text-base: 0x03057BCC, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c)XB1, PLATFORM SPECIFIC RELEASE SOFTWARE (fc1) BOOTLDR: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c)XB1, PLATFORM SPECIFIC RELEASE SOFTWARE (fc1)

AS2511rj uptime is 4 hours, 24 minutes System returned to ROM by power-on System image file is "flash:c2500-c-l.123-18.bin"

cisco AS2511-RJ (68030) processor (revision K) with 14336K/2048K bytes of memory. Processor board ID 22786698, with hardware revision 00000000 Bridging software. X.25 software, Version 3.0.0. SuperLAT software (copyright 1990 by Meridian Technology Corp). TN3270 Emulation software.

1 Ethernet/IEEE 802.3 interface(s) 1 Serial network interface(s) 16 terminal line(s) 32K bytes of non-volatile configuration memory. 16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

AS2511rj#

Reply to
william

I saw an article on Cisoc site saying to configure lines with modem inout ; cannot hurt at this point

line 1 16 modem inout

Reply to
Merv

Given that you know the various router console ports are good and your cables are good, the only thing not provend yet is whetehr the 2511 async ports are good.

You could try setting up Windows to the server port testing using the following Cisco doc:

formatting link

Reply to
Merv

I will give this a try tonight and let youguys know...

Reply to
lingwalla

I will make a new rollover tonight as well....

Reply to
lingwalla

The AS2511-RJ in our lab has rolled cables and the interface leads are as follows:

Modem hardware state: CTS DSR* DTR RTS

#sh line 8 Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns 8 TTY 9600/9600 - - - - - 2 31

0/0

Line 8, Location: "unconnected", Type: "" Length: 24 lines, Width: 80 columns Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits Status: Ready Capabilities: EXEC Suppressed, Hardware Flowcontrol In, Hardware Flowcontrol Out Modem state: Ready Modem hardware state: CTS DSR* DTR RTS Special Chars: Escape Hold Stop Start Disconnect Activation ^^x none - - none Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch never never none not set Idle Session Disconnect Warning never Modem type is unknown. Session limit is not set. Time since activation: never Editing is enabled. History is enabled, history size is 10. DNS resolution in show commands is enabled Full user help is disabled Allowed transports are pad v120 telnet rlogin. Preferred is telnet. No output characters are padded No special data dispatching characters

Reply to
Merv

Bam! The issue, Layer 1 of course!

2 rollovers from cisco (light blue) - the flat blue rollovers that I had they must have not been made coorectly OR the cables relied on the db9 "snap-in" connectors to make it a true rollover. I could not tell by looking at thee nds of them if they were correct rollovers. . So I made a plenum cat6 (all I had) rollover on my own and it worked like a champ!! With No configs on the receiving Con0 and only "no exec" and "preferred telnet" under lines 1 16 on the 2511. On thing is for sure My humble advice: Building your own lab brings you all kinds of "accidental" knowledge. Unbelievable, painful, but good solid learning. I know now more than I ever wanted about async's and rollovers and 2511's! A big Thank you.
Reply to
william

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.