Actiontec GT704 and DNS

If you use an Actiontec GT704-WG wireless ADSL router, are familiar with configuring it, and have a spare 5 minutes or so, perhaps you could run a quick test. I am having a problem with my GT704 and feel that it is inherent in the firmware and not a defect of my particular router but I cannot be 100% certain.

I have found that if I set up the router in DHCP configuration, but specify what DNS servers should be issued to the clients (static rather than dynamic), the modem still continues to issue its own LAN IP address and the local ISP DNS server IP address rather than the IP addresses that I have specified. I would like to know if this the case for all GT704s or only mine.

In order to run the test you must first configure the GT704 to use two DNS servers that are not associated with your ISP. A good set of instructions, if you are not familiar with the procedure or do not know of two DNS servers to use, can be found at

formatting link

After you have rebooted the GT704 and confirmed that IP addresses you entered have been saved, one way of determining what DNS server IP addresses are being issued to your Windows XP client (assuming it is using DHCP to obtain an IP address and DNS server information) is to open up a command prompt and issue the command "IPCONFIG /renew" followed by the command "IPCONFIG /all". The DNS servers listed by the second command should show the addresses you configured the GT704 to issue. I would be curious if that was the case, or if it continues to issue the LAN IP address of the GT704 (probably a address) and your local ISP DNS server IP address.

After the test you can repeat the configuration procedure but select dynamic rather than static to return your GT704 to its original configuration. Thanks for your help.

Reply to
Loading thread data ...

The GT-704 dns functions is broken big time.. They've known about the issue for a long time.. (2yrs?) Same goes for those turkeys @ TI , who shipped the broken reference firmware to the OEMs.

The internal dproxy program, eventually runs out of file handles(1024) in the limited busybox, (linux 2.4.17 ramonly), environment and either hangs or crashes in a couple of days. Do not use it..

I recommend pointing all of your PC dns entries to your ISP's DNS IP addresses.. and kill off the dproxy process by telneting into the GT-704.. Log in as 'admin'.... Password.. "your web password" and type kill -9 `pidoff dproxy`.. and then exit.

If you run servers behind this DSLmodem/gateway.. I also recommend doing the following.. before logging out.

cd /proc/sys/net/ip4/netfilter

echo 1800 > *close_wait echo 3600 > *established

Which prevents /proc/net/ip_conntrack (NAT function) table overflow when someone lunches a spoof attack.

Note: Each time you reboot/power cycle.. all of these configuration settings are lost. If you need to retrain/reset the DSL connection, simply disconnect the phone line connection for a second or two.

Actiontec has posted only one firmware.. GT704 for the unit.. All of them suffer from the same problem. Actiontec tech support is virtually non-existant.

Note: 3rd party OEM's like Quest may have fixed these bugs in the versions they ship to their customers.

Reply to
T. Keating

Thanks for that suggestion.

That is what I was trying to avoid. My ISP's DNS servers are sometimes slow which makes browsing slow despite a broadband connection. Then Open DNS servers seem to be much more responsive under some conditions.

I will give those a try and incorporate them into my script. I solved my DNS problem by saving a series of echo commands as a text file and then cutting and pasting it at the command prompt after telneting to the Actiontec as you do. This saves typing them each time the configuration is lost due to a reset. The text is as follows:

echo start > /var/tmp/udhcpd.conf echo end >> /var/tmp/udhcpd.conf echo interface br0 >> /var/tmp/udhcpd.conf echo opt router >> /var/tmp/udhcpd.conf echo opt domain >> /var/tmp/udhcpd.conf echo opt dns >> /var/tmp/udhcpd.conf echo opt subnet >> /var/tmp/udhcpd.conf echo opt lease 86400 >> /var/tmp/udhcpd.conf echo conflict_time 86400 >> /var/tmp/udhcpd.conf echo lease_file /var/tmp/udhcpd.leases >> /var/tmp/udhcpd.conf

This creates a DHCP config file that instructs DHCP to issues the DNS servers I would like my PCs to use.

A good suggestion I hadn't thought of.

virtually non-existant.

I found the person I talked to, to be very helpful, at least to the limit of his resources. He even sent me other ISP configuration firmware files to try to see if they corrected the problem because they were newer. I have not tried them as yet as the script solved my problem with a minimum of fuss. What is disturbing however is I sensed from our conversation that Actiontec management knows of the problem but does not want to invest any time or money to correct it since so few use that feature. Not a very good attitude.

Thanks for responding.

Reply to
kenwood0622 Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.