WRT54GS problem


My Linksys wrt54gs with DD-WRT acts really weird.

I have unplugged and plugged the power, and thinks I have fried something.

The ethernet ports work perfect. All computers can see each other.

I can also see the AP I connect to (I run it in client mode).

I get a signal about 68db below 98db noise - that is quite OK and used to work.

But it looks like something blown in the router. Even though I have wifi access, no IP packages passes through the wifi-link.

Any idea on what it can be, or how to diagnose it?

It is not the AP, I am writing this from another computer sitting on that AP.


Reply to
Loading thread data ...

On 7 Jul 2006 10:41:33 -0700, "jj92_2" wrote in :

How about wired? What are the *exact* failure symptoms? Are wireless clients getting DHCP addresses?

Wired or wireless?

Reply to
John Navas

Are you just plain thick! READ the message. I'm not going to explain it, if you don't understand or can't keep up - don't bother.

Reply to

On Fri, 07 Jul 2006 20:37:47 GMT, "Dave" wrote in :

I don't think I'm at all thick (though various ladies might disagree:), and I did read the message, and if I had thought it clear and complete, then I wouldn't have asked the questions. I've now read it again at your suggestion, and I still don't see the answer to those questions. If you're not going to explain it, then I'm going to assume you don't either.

Reply to
John Navas

"Dave" hath wroth:

Well, that makes two of us that are "thick". I can't understand your message either.

What do you mean by "wierd"? Diconnects? Range problems? Slow downloads? Makes noises? Flashing lights? Voices from the dead?

I think you were clear enough that it works as expected with a wired ethernet connection. However, it takes two to tango. What do you have for hardware and software on the other end of the wireless? Make, model, OS, wireless device, version, etc. While you're at it, which hardware version of the WRT54GS are you using and what exact version of DD-WRT? v23 SP1 or v24. small, tiny, vpn, generic, etc? Some of the pre-SP1 versions were fairly flakey.

Reply to
Jeff Liebermann


I'll try to describe a bit better.

I have entered the network manually.

In the GS54 V4 I get signal to the AP, I connect to the network (WEP code), wireless status shows packages sent and received.

But seems to be that the TCP/IP part doesnt work.

For me it looks like something weird is broken in hardware.

What happenend: I had DD-WRT#23 installed. It worked fine. I unplugged and plugged power, and lost the TCP/IP part. If I run DHCP - I do not get an address from the AP (Antoher Linksys). (If I connect with my laptop the the AP, it works great). If I run static IP on the GS54, I still dont get any connection. If I telnet to the 54GS and do ping to the AP, I get "host unreachable". If I do it from the laptop, I get OK ping.

Then I tried to setup my 54GS as AP, and connect to it from the laptop. It worked fine.

As I do not have my own internet backbone, I have not tried setting the

54 up as AP, with Internet connectivity, and check that that works.

broken, so it cannot create the connection to the WAN. This I still have to find a way to test.

Any ideas on how I can diagnosis this further with commandline commands inside the 54?

I have tried running a ifconfig - and it show me a lot of info I dont understand, but I cant see anything about errors in there.

Any ideas on how I can test this further - before I go out and buy another router (which is hard to find - especially the Linksys routers here in Denmark are all much newer than those that can run DD-WRT.)

Best regards and thank you all for helping out

Jens Jakob

Reply to

Your message is very confusing..

Why not try the Official DD-WRT forum maybe someone there might be able to help?

formatting link

Reply to

Did even more testing:

Reset my network. Plugged PC1 into wan-port of 54GS - to act as "internet".

Set up 54 as AP.

Set up PC2 on the LAN port.

Set up Laptop on wireless.

It works great.

PC2 can ping/tracert laptop and PC1. (Internet) Laptop can ping/tracert PC2 and PC1 (Internet)

So in normal AP mode, it seems to be that it works just fine.

Very weird.

I will reset again, try client mode once more, maybe upgrade to DD-WRT alpha (24) and see if that fixs it.

I have tried resetting to factory settings too.

Yes, I might try to reboot the main AP physically (not just via the web-interface), even though I cant see why that might help - since the laptop connects just fine to it.

Weird, very weird.


Reply to

"jj92_2" hath wroth:

You're doing very badly (seriously). I keep asking for exact version numbers. Instead, I get truncated descriptions. You are apparently doing an excellent job of troubleshooting (simulating the WAN connection with another PC) but the descriptions are very vague and confusing. I realize the English is not your native language. Your English is quite good, but the organization and descriptions are the problem. I'll try to illustrate the problem with my quesitions below. Do NOT answer my questions as there are too many of them. Try to use them as a guide for a new posting that describes the equipment and symptoms much better.

Does that mean a static IP address? LAN or WAN side? It's easy to do those wrong. Fill in the blanks below: LAN IP Address: LAN netmask: WAN IP Address: WAN IP Netmask: WAN Gateway Address: If DCHP on the WAN side, look on the status page for the IP's. If you have security concerns, do NOT post the exact WAN IP and Gateway Address.

Signal to what AP? I thought that the WRT54GS v4 is acting as an access point or wireless router and that you're using some unspecified client computer to connect to the WRT54GS v4. If there is more than one access point in your system, kindly describe it. To avoid confusion, especially when changing "modes", try describeing them as "box #1" and "box #2".

The first step to solving a problem is NOT to blame something. TCP/IP part not working is like saying "my car doesn't go". It tells us nothing. Does your car have a flat tire or dead engine? What part of TCP/IP is not working? What doesn't it do that you would expect it to do.

Again, please describe the symptoms, not your impression of the symptoms. What looks weird to you way be a common problem familiar to those with some experience.

Try again on the version number. It's a bit tricky to find. Go to the status page. It's in the upper right hand corner of the page. Include the version date. Mine is at:

formatting link
you click on the version number, you get some more detail. Mine says: DD-WRT v23 SP1-RC4 (05/12/06) std That's what I want from you.

I started and stopped the car and it still won't go. That doesn't tell me whether it's the engine or the flat tires. Try a better description that does NOT include your guess as to the cause. What part of TCP/IP does not work?

What other Linksys? Make, model, version, firmware? Is it acting as an access point, client, repeater, or what? Just what are you doing to "run DHCP"? DHCP is not a program. It's a service that is enabled or disabled and is run by the operating system. Better description of what you're doing.

What laptops? Wireless or wired? What AP? Which AP (there are apparently two)? How do you connect?

Don't use static IP's on the LAN side. Use DHCP. That will tell us if you have a connection.

Host unreachable means that the IP addresses are not set properly. It's difficult to tell without knowing the IP setup. See fill in the blanks on the IP's above and add the 2nd AP to the list of IP's. If you're using DHCP to set the IP addresses on the 2nd AP, then supply what IP's are returned, even if it's or 169.254.xxx.xxx.

What laptop? Maker, model, wireless client maker, model, version, operating system.

Do what from the laptop? What is "it"? What are you doing when you try "it"?

I thought it was acting as an AP all this time? An AP is nothing more than a wireless AP connected to an ethernet router. In this case, it's all in one box but can be in two seperate boxes. How are you using the WRT54GS v4 as an AP? How is the connection made via wireless? Do you get a valid IP address from the AP? If so, you've apparently still have the DHCP server enabled in the router section. That means that you may have two DHCP servers running at the same time. Bad idea. If you're going to convert the WRT54GS v4 into an AP only, please disable the DCHP server.

I don't think anyone in this newsgroup owns an internet backbone. They cost millions of dollars to build and tend to more than what the average user can afford. You could invest in an ISP, but that would still be overkill. What do you mean by your "own internet backbone"?

From my analysis, I have only partial clues as to what you're trying to accomplish and what you have to work with. There doesn't seem to be much of a problem with your troubleshooting abilities. What's lacking is your abilities to describe the problem, the equipment, the symptoms, and the testing. My questions above are to illustrate the questions I'm asking myself when I read you posting. I suggest you

*NOT* try to answer them. Instead, start over with a description of:
  1. What are you trying to accomplish. This is totally missing. A one sentence description will suffice.
  2. What do you have to work with? That means hardware, software, versions, etc. Numbers, not partial truncated descriptions.
  3. What have you done so far and what happened? That means describe your test setup and what actually happened, even if you know the results are "weird".

Pardon my warped sense of humor but I noticed that we started with WRT54GS, then shrank to 54GS, and now are down to 54. I don't really care what designations you use to describe a single box, but since you apparently have two access points, it would very handy if you would consistently use the same designation or abrev.

Wait. Let me check my crytal ball. Ah, I can almost see the results of ifconfig.... drats, you cleared the screen.

I still can't determine what you're using for equipment and software. I also can't determine what is not working.

It might be helpful if I recommended the exact DD-WRT version. Try: |

formatting link
is v23 SP1 standard for the WRT54GS May 16, 2006.

Reply to
Jeff Liebermann

"jj92_2" hath wroth:

This is a good test for simulating internet access. I presume this means that you cannot connect to the internet with your WRT54GS?

Wrong. Stop. That disables the router section which you need to access the internet from the WRT54GS.

Good. I'll assume you did this via wireless, not wired. That proves that the wireless part of the WRT54GS v4 works. However, you completely disabled the router section, which is probably where you're having problems.

AP mode is NOT normal. An access point (AP) is where the router is disabled. If you plugged PC1 into one of the LAN ports, you have an access point. However, if you plugged PC1 into the WAN port, the router is still enabled and functional. What did you do?

Very bad description again.

Don't try alpha at this point. Go with a stable version as described in my previous message.

I've found this to be necessary only when going between radically different versions. Still, it's a good thing to do in case some obscure setting was set incorrectly. The defaults usually work well.

Reply to
Jeff Liebermann

Hi Jeff

Thank you for the input.

I ended up flashing with 23-mini version of DD-WRT, and reboot the central AP (which isnt the GS54.

I'll describe:

Location A: Internet Backbone. Linksys BEFW11S4 V4

Location B: Linksys 54GS in client mode connect to BEFW11S4 PC1 - local lan PC2 - local lan Laptop. Wireless direct to BEFW11S4

I lost the connectivity of the 54GS as client to the BEFW11S4. While at the same time, I could connect wireless with the laptop to the BEFW11S4

So I did some testing. Setup the 54GS as AP. Plugged PC1 into the WAN port (to simulate internet backbone). PC2 plugged into LAN port. Laptop connects wireless to 54GS. This worked fine - showed me that all electronics in the GS54 worked.

Reset configuration: PC1+PC2 connected toi lan on 54GS.

54GS setup in client mode, name of central AP network setup again.

The 54GS got the wireless connection, and a fine signal. But the 54GS never got a DHCP connection to the central AP.

Just kept on logging : udhcpc[1264]: Sending discover...

So finally I rebooted the central AP, and now it works. What weirds me, is that at all times, the laptop could connect to the central AP and get an IP address via DHCP.

So I think there is an elusive bug in the DD-WRT somewhere.


Reply to

What *EXACT* version of the DD-WRT firmware. See my previous message for how to find the exact version.

I would prefer if you would itemize, but I guess describe will work.

Yech. I have one of those router. It hang at irregular intervals.

OK, other than the lack of detail, I now understand your setup.

Any encryption? BEFW11S4 v4 only supports WEP. Be sure to use the Hex key, not the ASCII key.

Not a good assumption. I have a neighborhood LAN with about 5 wireless connections. It's not unusual for one of these connections to go dead, while the others remain working. I have no idea what is the cause of that problem but I do know that it's related to the BEFW11S4 router, as my other routers (WRT54G v1.1, Motorola MR840?, DLink DI-614+) do not have this problem.

Yep. An excellent test of everything except the DHCP client in the WRT54GS. However, as the other clients computers were apparently able to access the internet through the WRT54GS, this is not much of a test.

A better test would be if your WRT54GS in client mode can "see" other wireless networks using the built in site survey. See: Status -> Wireless -> Site Survey button

How did you setup the "name" (SSID???)? Did you use the site survey tool? There's nothing to type if that's the case. Just click on the SSID and be sure you save the settings.

That's the same thing I get with my BEFW11S4. Actually, even if you had a valid IP address, it just sometimes decides to drop one or more wireless connections. Interestingly, it also does the same thing on wired connections.

Yep. I use the same fix with an AC lamp timer to reboot the BEFW11S4 every night.

Nope. It's in the BEFW11S4. Try it with a different wireless router and see for yourself.

Reply to
Jeff Liebermann

Hi Jeff

Thank you for that final comment.

I rebooted the BEFW11S4 and it solved the problem.

What weirds me - is that at the same time that I couldnt get the connection to the BEFW11S4 working with the 54GS, I could eaily connect from my laptop to the BEFW11S4.

That is weird.


Reply to

"jj92_2" hath wroth:

I hate to tell you this, but it will be back. It seems to happen all the time with my BEFW11S4 v4. It really is a piece of junk.

I've never really spent much time trying to figure out the exact mechanism. I typically have about 5 machines connected to the BEFW11S4 at a time. 4 via wireless and 1 via ethernet. For no obvious reason, one or more of them will lose connectivity. When this happens, the others are NOT affected. No amount of rebooting of the client computers will restore connectivity. It also happens to my desktop. Rebooting the router is the only solution.

Wireless is magic.

Reply to
Jeff Liebermann

I agree, the one I used several years ago was junk. Didn't realize how BAD it was until I replaced it with a WRT54G. Besides, the BEFW11S4 is 802.11b only (11mb) and doesn't have very good range. The dropped in replacement WRT54G immediately offered twice the coverage area and none of the intermittent hanging. Pitch the BEFW11S4 or use it soley as a wired switch, just ignore it's wireless "features".

-Bill Kearney

Reply to
Bill Kearney

"Bill Kearney" hath wroth:

I'm not so sure. The only reason (other than me being cheap) that the BEFW11S4 v4 is still in use at my house is because it has excellent range (with an external antenna). I need it to deal with the dense redwood forest. I tried replacing it with a WRT54G v1.1 and found that I had lost some range. I may try again with a better antenna. I guess I should check the WRT54G v1.1 for RF problems as I did salvage it from the local dump.

There is also the problem with the BEFW11S4 hanging on various router exploits tests:

formatting link
possibly hanging on sustainted screaming media.

It certainly wasn't a 2:1 difference for me. My guess(tm) was that the BEFW11S4 went about 20% farther than the WRT54G v1.1.

Incidentally, it was hung this morning when I tried to use it. Grrr...

Reply to
Jeff Liebermann

As the saying goes "your mileage may vary". I had a set of parabolic shrouds on my BEFW11S4 and those did help improve the range. But when I put the WRTG54G (v3 I think) in it's place WITHOUT the parabolics the range was STILL better. I didn't even bother with the parabolics on the WRT54G because it.

I think my point is the BEWF11S4, being a relatively early player in the game, isn't as reliable or consistently performing as some of the more recently shipping devices. There's always the chance of a select few units being bad but popular consensus seems to show the BEFW11S4 in a less-than-complimentary light.

-Bill Kearney

Reply to
Bill Kearney

I'm make sure I had the latest v23 (the multi-language version in the untested alpha directory).

What type of encryption are you using? In client bridged mode, I don't think WPA2 is supported (WPA is).

Reply to
Jerry Park

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.