WRT54G setup page

I can't be sure, but... it's probably a matter of routing on the WRT54G.
With DHCP enabled you get (using the defaults) an address range of something like 50 or 100 addresses starting at 192.168.1.100. It happens that the WRT54G by default will *only* route to that set of addresses. Hence if you come along and try accessing it from a host with an address in the 192.168.0.n range, as an example, the WRT54G has no route back to your host. (You can watch the lights an see that ping or attempts to access the web page do cause activity, but you get no response because the WRT54G has no route to your address.)
There are two ways to get around that. Change the WRT54G routing or access it from a host with an address in the range it will route to.
You need a way to access it to begin with, even if what you eventually do is set a specific route in the WRT54G route tables, so for now the only way to access it (short of doing a reset and starting over) is via a host using an IP address it will route to.
Use an address like 192.168.1.101 on the host you access the WRT54G from. Most OS's will allow multiple IP address assignments to an interface, so the easy way is to just add a new IP to your existing interface configuration. If you can't do that, you'll have to temporarily change from whatever it is to an address in the range that works.
Reply to
Floyd L. Davidson
Loading thread data ...

I just replaced a Netgear WGR614 router with a Linksys WRT54G. No problems
setting it up via a hardwire to my laptop. I can also connect to the internet.
However after the setup I cannot access the setup page again either with my
wireless laptop or other computers on my network. I left the routers IP address
as default (192.168.1.1) and I disabled DHCP (I'm using it as an access point).
Do I have to wire directly to the Linksys to access the setup page again? Thanks
mike
Reply to
Mike A.
Done that. Doesn't work. The only way I can connect to the router is if I wired directly to it and reset it. I've tried using IE and Firefox and I've even messed around with various lan settings. Everytime I do I get a timed out message. I'm using the latest firmware (jan/05). Weird eh? I suppose I could live with it since my connection seems okay.
mike
Reply to
Mike A.
My point was *precisely* why it won't connect to the default IP. It has no route back to you if *your* IP is not within the range it knows about.
Don't change the WRT54G's IP, change the IP of the machine running the web browser.
Of course, your host also has to have a route to the default IP of the WRT54G, and you might want to check to make sure it does. You can verify this fairly easily, by simply running ping and watching the lights on the WRT54G. If you don't get any flashing activity lights, then your host is not routing 192.168.1.1 to the ethernet interface. If you do get flashing activity lights, then use a web browser to access the WRT54G, and watch the lights again. If you see a little activity when you hit enter on the web browser, but not big blast of activity coming back as it sends a web page to you, then the WRT54G is not routing packets to the address of your host.
You can change either the host's IP to be within the range the WRT54G can handle, or set the route tables in the WRT54G to handle whatever IP address your host uses.
Reply to
Floyd L. Davidson
Suggest you use the hardwire connection to get back into the setup for the WRT54G, and go to the Administration tab, verify that you you have web access checked for HTTP or HTTPS (whichever you intend to use) and wireless access web is enabled. Don't forget to save settings.
GZ
Reply to
gz
Just link to the routers IP address with you desktop and put in a password. It's "admin" to start until you change it. I believe you have to change a setup parameter to access remotely.
Dave G
Reply to
Dave G
Thanks for your suggestions Floyd. That's actually a good idea. I'll enable DHCP and configure an IP addy within range. That *should* work. I'm still working on why it won't connect to the default IP. If I find an answer I'll let you know.
mike
Reply to
Mike A.
i thought remote access was the ability to configure the router from anywhere on the internet, not just the local network?
Reply to
bryan
Wrong. There is no "remote access" configuration. There's a "remote administration" which allows you to connect to the web based config from the WAN port, usually on port 8080. This has nothing to do with the problem.
Let's attack this systematically. 1. Since you can surf the net, what does your computah think is the IP address of the router? Run: Start -> Run -> cmd IPCONFIG The "gateway" address is the address of the router. Is it 192.168.1.1? If different, try to connect to it?
2. There's a small chance that your client computah is setup with a static IP address, gateway, and DNS server configuration. If so, kindly dive into the Network control panel setup and change the configuration to let the routers DHCP server set your IP address.
3. If you're juggling routers (a likely senario) and both routers are on 192.168.1.1, you will have problems with the ARP (address resolution protocol) cache. To clear the cache and start over, run: Start -> Run -> cmd arp -a (display arp cache) arp -d 192.168.1.1 (delete entry for 192.168.1.1) ping 192.168.1.1 (reload the arp cache for 192.168.1.1) apr -a (display arp cache to see if it changed). The MAC address displayed should be that of the router's LAN port.
4. You should be able to ping the router. Try: ping 192.168.1.1 The WRT54G can be configured to block pings on the WAN port, but pings on the LAN port will always work.
5. Some built in web servers insist on a trailing "/". Try: http://192.168.1.1/and see if that helps.
6. I'll assume that you don't have a personal firewall such as XP SP2 firewall, ZoneAlarm, Norton Firewall, or Kerio configured to block access to local devices. You really have to try hard to do that but it can be done. If you're not sure, try temporarily disabling any personal firewall.
7. Since you're doing all your testing via wireless connections, it might be interesting to see what a direct CAT5 LAN connection will do.
8. Any chance you configured your internal web server for a port number other than 80? Also, some routers get really confused if you redirect port 80 on the WAN port to a local machine. It's an old bug, but I keep finding it.
Reply to
Jeff Liebermann
That option only affects the WAN port. It isn't wireless access that is restricted, but "remote access".
The reason he can't access it via the LAN ports is because he's using an IP address on the host running the web browser that by default the WRT54G simply will not route to.
Reply to
Floyd L. Davidson
That refers to the WAN port, and what they mean by "remote" is anything coming from the Internet (through the WAN port).
It does not affect the 4 LAN ports or wireless.
Reply to
Floyd L. Davidson
I finally got it going. After I changed and saved the WRT's new IP address, I disconnected the laptop I used to set it up (ignoring any error messages). I then rebooted the WRT and after that the wired router. I then was able to connect to the WRT from another computer connected to the wired router. I did this without having to reset the WRT. Seemed like a bit of a dance, but it worked. Thank you all.
mike
Reply to
Mike A.
Hoi,
I had simmilar prob with WRT54G, answer is that somewhere in the setup page you have option to enable or disableWireless access to the router.. check it, maybe in your setup wireless access is dissabled?
Jane
Reply to
zzz
"Mike A." wrote in news:z72dnTgSrMAJf snipped-for-privacy@rogers.com:
You did enable "Remote Access", didn't you? It won't be accessable by wireless connection otherwise.
Ed
Reply to
Ed
Some routers require that you plug into wired port #1 on the internal lan side before they will accept a connection to their management web-pageset. As I don't have a WRT54G, I can't say if it requires this, but you may as well try.
Reply to
D. Stussy
I still think you need to change the following setting: Click on the administration tab, then go to Web Access, and enable Wireless Access Web, and this will enable you to manage the WRT54G via a web page.
There may have been multiple problems, and the above may fix one of them.
GZ
Reply to
gz

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.