Wpa disconnecting when neighbour connects

Really shouldn't be a problem, but since it is ....

Right click on your connection, and select Properties. Select the Wireless Networks tab. Insure that your neighbors network is not listed in your Prreferred Networks list. Click the Advanced button and uncheck the 'Automatically connect to non-preferred networks' box if it is checked.

If that doesn't fix the problem, I suppose I'd try changing my network address. That is, if your network is using 192.168.1.x, your neighbor may be using the same address range. Try using 10.18.86.x or some such.

Reply to
Jerry Park
Loading thread data ...

Hi you all,

I´m using a wireless router (Sitecom WL122) to connect to the internet. Recently I changed to XP Service SP2, but the problem I´m encountering already existed under SP1.

One of my neigbours is using WPA like me and the moment this neighbour of mine connects to the internet my connection drops. The result is I reconnect my modem and router (1 minut for the modem, 1 minut for the router, 1 minut for Windows) and of course the connection of my neighbour drops. So he reconnects and my connection drops. Etcetera, etcetera.

I´ve tried all things I read somewhere: shorter password deleting all preferred networks except my own changing channels making a home network and telling windows my SSID making a bat-file to stop the service "Wireless Zero Connection" after connecting (SC.EXE STOP WZCSVC)

Nothing seems to solve this problem permanently. Can´t these guys of Microsoft ever write a program without bugs? Why should Windows want to drop my connection even when the other signal is stronger (but it isn´t). I´ve told it the SSID of my own network. The other networks don´t interest me.

When this neighbour of mine isn´t connected my wireless network works perfectly (no disconnections all day) even when an unprotected network of another neighbour is online, but the moment my neighbour with WPA connects I have problems.

I´ve tried changing to WEP. This didn´t help much. Some other peculiar things happened: My connection showed "not connected" while I was serving the internet or showed "connected" while my connection didn´t work.

The change to SP2 had other side-effects. While under SP1 I could connect within less then 10 seconds the change to SP2 had as side-effect that connecting takes a minute or so. Maybe Windows needs all this time trying all networks I don´t want to connect with:)

Sometimes when I try to reconnect with the adapter of windows I get the error 651, so it seems the connection with my provider is in use, but maybe I can´t use it because something did go wrong with the exchange of the encrypted keys. Sometimes I can connect this way, but this is not the way I want to connect, because I want my router to connect. The only way seems to restart modem, router, windows wireless connection, but this takes three minutes!

Curious whether this is a well-known issue.


Reply to

Uncheck the box (Windows Wireless Zero Config) that states connect to

nonpreferred networks. Uncheck the box that states "connect to ANY"

networks. Try changing channels in your AP's menu and by all means,

make sure your SSID is not the same as your neighbors.

Reply to
doug Jamal

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.