Needing direction

I have a wireless network in my house that is served up by a Linksys WRT54G router. I live in a rural area without DSL or cable, so the internet connection to my house is served up by an ISDN line and a Netopia R3100 series router which feeds the WRT54G.

Our two wireless enabled laptops see the wireless network OK, and I can ping/telnet/ftp/tracert out to destinations on the web such as

formatting link
formatting link
etc. However, when I open a browser session (either Internet Explorer or Firefox) to
formatting link
the browser churns away for a while and then throws up a page not found error. I try this for
formatting link
and any other common web address and I get the same result.

While the browser is trying to materialize the page, I do a netstat and I see an entry with Google's IP address like so: ESTABLISHED

However, the browser never presents the web page.

Other oddities:

I can update my Ad-Aware software from the web, but Spy-bot will not update. Also, I can try for 30-40 minutes to get out with the browser with no luck, then leave my PC for a day or so (no reboot), and try again and the browser works, leave for a couple of hours, and the browser doesn't work. When the browser is down, my Cisco VPN client does not work, but if the browser works, I can VPN to my office.

Sometimes, I *THINK* I can kickstart the browser by going in and changing the subnet mask on the ISDN router to any value in the range

255.x.x.x and that may work for a while, but then again, the browser stops working at some later point.

I have tried using IE browsers on two wireless laptops: a Dell running Win XP Pro, and an older Compaq Presario running XP Home. Both have the same problem

I have also tried this on my home brew desktop running XP Pro with IE and Firefox, and tried it with the machine both physically plugged into the wireless router and/or the Netopia ISDN router, but the results are the same.

I thought maybe my browser or port may have been hijacked, so, I have run virus scans, ad-aware scans, spy-bot scans, cwshredder, you name it, but nothing seems to work.

I have been running the ISDN/WRT54G scenario for about 3 years now, but the Netopia has ony been in the mix for about the last 6 months, and this problem started about 2 months ago.

Has anybody had a similar situation where their browser just stopped working, but every other port connection to the internet still seemed to work?

Reply to
Loading thread data ... Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.