Linux: Norm N


I can use the following linux commands to launch a wireless connection:

modprobe ... ifconfig wlan0 up iwconfig wlan0 essid ... wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -B route add default gw

I have a Norm N router and adapter. Using iwconfig I can see: Bit Rate=54 Mb/s

This does not seem to be N Norm! How do I do to force the use of Norm N?


Reply to
Paulo da Silva
Loading thread data ...

I believe it depends on the driver. My Ralink does not have iwpriv options when using the native kernel drivers, but does when I use third party drivers. try: iwpriv and: iwlist wlan0 rate []'s

__ Boa sorte

Reply to

Em 23-04-2011 16:15, Shadow escreveu:


Yes. I have also a ralink (Driver RT2800/RT3070- from stage drivers from the kernel). It does not have any iwpriv options. I also found a driver at the ralink site that has lots of iwpriv options including setting the bgn combinations. If this is not included in 2.6.38 kernel (my current k is 2.6.37), I'll compile it. I am just waiting for stability in k 2.6.38 to change.

Obrigado e um abraço para você.

Reply to
Paulo da Silva Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.