Soho77: static nat with dynamic public ip

Hi everyone.

I'm playing around with an old Soho77, bought used on Ebay :-)

I'm trying to configure a static nat with my adsl, and i have found this configuration line that works flawlessly:

ip nat inside source static

Unfortunately my IP address is dynamic, and this configuration works until atm interface is reset: if my public ip change, i lost connection with internet. I've tried this:

ip nat inside source list 101 interface Dialer0 overload access-list 101 permit ip any

but this works only for outgoing connection... incoming connections are not forwarded to

I really need a static nat, with 1 to 1 IP mapping... PAT or DNAT don't work for me.

Any hint?

Thanks a lot. (my show r attached...)

Current configuration : 1767 bytes ! ! Last configuration change at 22:28:50 UTC Wed Nov 15 2006 ! NVRAM config last updated at 22:29:10 UTC Wed Nov 15 2006 ! version 12.1 no service single-slot-reload-enable no service pad service timestamps debug uptime service timestamps log uptime service password-encryption ! hostname sandrouter ! logging rate-limit console 10 except errors enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx ! ip subnet-zero no ip finger ip domain-name ip name-server ip name-server ip dhcp excluded-address ! ip dhcp pool LOCAL network default-router dns-server lease 0 0 1 ! no ip dhcp-client network-discovery ! ! ! interface Ethernet0 ip address ip broadcast-address ip nat inside no ip mroute-cache no cdp enable ! interface ATM0 no ip address no ip mroute-cache no atm ilmi-keepalive pvc 8/35 encapsulation aal5snap protocol ppp dialer dialer pool-member 1 ! dsl operating-mode auto hold-queue 224 in ! interface Dialer0 ip address negotiated ip nat outside encapsulation ppp dialer pool 1 dialer-group 1 no cdp enable ppp pap sent-username xxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxx ! ip classless ip route Dialer0 no ip http server ! ip nat inside source static access-list 101 permit ip any access-list 102 permit ip host any dialer-list 1 protocol ip permit no cdp run ! line con 0 exec-timeout 120 0 transport input none stopbits 1 line vty 0 4 access-class 23 in exec-timeout 120 0 password 7 xxxxxxxxxxxxxxxxxxxx login local ! scheduler max-task-time 5000 sntp server end

Reply to
Loading thread data ...

try something like : ip nat inside source static interface Dialer0 extendable

HTH Martin

Reply to
Martin Bilgrav

Yes, i've tried that syntax but it's not supported by my ios: 12.1(5)YB5

Trying to update..

Thanks a lot.

Reply to
Sandrinho Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.