Problem with interface counters. (long)

Hello.

I have a problem with counters on vlan and fastethernet interfaces. They very often display inexact values.

Test network draft below.

Network has three Cisco 1812 V03 routers. At laboratory i use IOS:

Cisco IOS Software, C181X Software (C181X-ADVENTERPRISEK9-M), Version

12.4(6)T2, RELEASE SOFTWARE (fc1)

Test network scheme.

R1 R2 R3 FE0 192.168.5.1 192.168.5.2 - FE1 - 192.168.6.2 192.168.6.1 TUN10 192.168.10.1 - 192.168.10.2 VLAN100 192.168.100.1 - 192.168.200.1

Error description

When the network load is low, information about 5 minute input/output rate on interfaces are strange.

After high transfer between host, and after stop transmission, I see information like this below.

R3#sh interfaces vlan 100

Vlan100 is up, line protocol is up

Hardware is EtherSVI, address is 001b.5352.b702 (bia 001b.5352.b702)

Internet address is 192.168.200.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:15, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 68000 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 146885 packets input, 81350484 bytes, 0 no buffer

Received 114 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 146792 packets output, 6790236 bytes, 0 underruns 0 output errors, 1 interface resets 0 output buffer failures, 0 output buffers swapped out

R3#sh interfaces fastEthernet 1

FastEthernet1 is up, line protocol is up

Hardware is PQ3_TSEC, address is 001b.5352.b703 (bia 001b.5352.b703)

Internet address is 192.168.6.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:04, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 56000 bits/sec, 0 packets/sec 175413 packets input, 18108992 bytes

Received 19143 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 0 watchdog 0 input packets with dribble condition detected 184109 packets output, 93094988 bytes, 0 underruns 0 output errors, 0 collisions, 3 interface resets

After low transfer between hosts, like ping between host I see information like this below.

R3#sh int vlan 100

Vlan100 is up, line protocol is up

Hardware is EtherSVI, address is 001b.5352.b702 (bia 001b.5352.b702)

Internet address is 192.168.200.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:10, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 1 packets/sec 5 minute output rate 0 bits/sec, 1 packets/sec 147027 packets input, 81367271 bytes, 0 no buffer

Received 209 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 146851 packets output, 6795538 bytes, 0 underruns 0 output errors, 1 interface resets 0 output buffer failures, 0 output buffers swapped out

R1#sh int vlan 100

Vlan100 is up, line protocol is up

Hardware is EtherSVI, address is 001b.5352.b672 (bia 001b.5352.b672)

Internet address is 192.168.100.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:01:10, output never, output hang never

Last clearing of "show interface" counters 04:14:02

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 1 packets/sec 5 minute output rate 0 bits/sec, 1 packets/sec 963 packets input, 94935 bytes, 0 no buffer

Received 129 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 856 packets output, 61446 bytes, 0 underruns 0 output errors, 0 interface resets 0 output buffer failures, 0 output buffers swapped out

Configuration of test routers

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$dpdo$q6V4fLGEHI58Av2sOVhGl1

!

no aaa new-model

!

resource policy

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool CIBOR

network 192.168.100.0 255.255.255.0

default-router 192.168.100.1

! !

interface Tunnel10

ip address 192.168.10.1 255.255.255.0

tunnel source FastEthernet0

tunnel destination 192.168.6.1

!

interface FastEthernet0

ip address 192.168.5.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

switchport access vlan 100

!

interface FastEthernet3

switchport access vlan 100

!

interface FastEthernet4

switchport access vlan 100

!

interface FastEthernet5

switchport access vlan 100

!

interface FastEthernet6

switchport access vlan 100

!

interface FastEthernet7

switchport access vlan 100

!

interface FastEthernet8

switchport access vlan 100

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

interface Vlan100

ip address 192.168.100.1 255.255.255.0

!

router eigrp 100

passive-interface Vlan100

network 192.168.5.0

network 192.168.10.0

auto-summary

!

ip route 192.168.200.0 255.255.255.0 192.168.10.2

! !

no ip http server

no ip http secure-server

!

control-plane

!

banner motd _ *** R1 *** _

!

line con 0

line aux 0

line vty 0 5

password qaz123

login

! !

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

================================================= !

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$oHFJ$dvCocwbHro.cfW8wGo/g7/

!

no aaa new-model

!

resource policy

!

ip cef

!

interface FastEthernet0

ip address 192.168.5.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1

ip address 192.168.6.2 255.255.255.0

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

switchport access vlan 50

!

interface FastEthernet3

switchport access vlan 50

!

interface FastEthernet4

switchport access vlan 50

!

interface FastEthernet5

switchport access vlan 50

!

interface FastEthernet6

switchport access vlan 50

!

interface FastEthernet7

switchport access vlan 50

!

interface FastEthernet8

switchport access vlan 50

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

interface Vlan100

no ip address

!

router eigrp 100

network 192.168.5.0

network 192.168.6.0

auto-summary

!

no ip http server

no ip http secure-server

!

control-plane

!

banner motd _ *** R2 *** _

!

line con 0

line aux 0

line vty 0 5

password qaz123

login

! !

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

================================================= !

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$Y4Jx$gB716CqmQreeUzWMbYXfI1

enable password line

!

no aaa new-model

!

resource policy

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool CIBOR

network 192.168.200.0 255.255.255.0

default-router 192.168.200.1

!

interface Tunnel10

ip address 192.168.10.2 255.255.255.0

tunnel source FastEthernet1

tunnel destination 192.168.5.1

!

interface FastEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1

ip address 192.168.6.1 255.255.255.0

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

switchport access vlan 100

!

interface FastEthernet3

switchport access vlan 100

!

interface FastEthernet4

switchport access vlan 100

!

interface FastEthernet5

switchport access vlan 100

!

interface FastEthernet6

switchport access vlan 100

!

interface FastEthernet7

switchport access vlan 100

!

interface FastEthernet8

switchport access vlan 100

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

interface Vlan100

ip address 192.168.200.1 255.255.255.0

!

router eigrp 100

passive-interface Vlan100

network 192.168.6.0

network 192.168.10.0

auto-summary

!

ip route 192.168.100.0 255.255.255.0 192.168.10.1

! !

no ip http server

no ip http secure-server

!

control-plane

!

banner motd _ *** R3 *** _

!

line con 0

line aux 0

line vty 0 5

password qaz123

login

! !

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

Please help me to solve my problem

Regards

Przemek Ciborowski.

Reply to
ciborro
Loading thread data ...

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.