PPPOE for DSL

I have at Cisco 2620 running 12.1 with a 4 port IMA card. I have an ATM link to my DSLAM and am trying to get PPPOE workng but am having no luck. Any help would be appreciated. I would consider paying a consultant.

Thanks

Reply to
Bill
Loading thread data ...

here are two sample configs, one with atm interface and ppoe, and one with an ethernet interface and ppoe. search the cisco site for 800 series router configs for atm and ppoe information.

cisco atm ppoe vpdn enable

no vpdn logging

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface Ethernet0

ip address 192.168.100.1 255.255.255.0

ip tcp adjust-mss 1452

ip nat inside

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username sohodyn password 7 141B1309000528

!

ip nat inside source list 101 interface Dialer1 overload

ip route 0.0.0.0.0.0.0.0 Dialer1

access-list 101 permit ip 192.168.100.0.0.0.0.255 any

------------ ethernet config with ppoe configuration for Spoke1 router using PPPOE

Spoke1#sh run Building configuration...

Current configuration : 2829 bytes ! version 12.3 no service pad service timestamps debug datetime localtime service timestamps log datetime localtime service password-encryption ! hostname spoke1 ! boot-start-marker boot-end-marker ! enable password xxxxxxxx ! !-create username for administration

username user password passwd no aaa new-model ip subnet-zero ! !-set IP addresses not to be used for DHCP

ip dhcp excluded-address 192.168.6.1 192.168.6.99 ! !-define DHCP scope and parameters

ip dhcp pool spoke1 import all network 192.168.6.0 255.255.255.0 default-router 192.168.6.1 dns-server 4.2.2.2 lease 0 2 ! ! ip name-server 151.164.1.8 ip audit notify log ip audit po max-events 100 ip ssh break-string ! !-enable vpdn to allow creation of dialer interface to support pppoe

vpdn enable ! ! !-create vpdn group for pppoe encapsulation

vpdn-group office request-dialin protocol pppoe ! no ftp-server write-enable no scripting tcl init no scripting tcl encdir ! !----configuure IKE police and pre-shared key for each peer.

crypto isakmp policy 10 hash md5 authentication pre-share ! !---- Preshared key for hub peer

crypto isakmp key 1cisco address 10.1.1.1

!----Keepalive added to help resolve problem of tunnel timing out and not restarting

crypto isakmp keepalive 30 ! !-----lifetime added to help resolve problem of tunnel timing out and not restarting

crypto ipsec security-association lifetime seconds 28800 ! !--configure ipsec parameters for transform set crypto ipsec transform-set spoke1 esp-des esp-md5-hmac crypto ipsec df-bit clear ! !---create map to define tunnel traffic ! !-tunnel to hub, specify number sequence, peer, transform set, and acl to include the !---private network to private network traffic in the encryption process

crypto map spoke1 10 ipsec-isakmp set peer 10.1.1.1 set transform-set spoke1 match address 110 ! ! ! !-apply NAT inside to LAN interface, add ip tcp adjust-mss 1400 to reduce packets !--using pppoe encapsulation

interface Ethernet0 ip address 192.168.6.1 255.255.255.0 ip nat inside ip tcp adjust-mss 1400 hold-queue 32 in ! !-set pppoe enable, and pppoe clienet dial pool acl to match LAN

interface Ethernet1 description ppoe to vendor Inet no ip address ip nat outside no ip route-cache no ip mroute-cache duplex auto pppoe enable pppoe-client dial-pool-number 1 no cdp enable ! interface FastEthernet1 no ip address duplex full speed 100 ! interface FastEthernet2 no ip address duplex auto speed auto ! interface FastEthernet3 no ip address duplex auto speed auto ! interface FastEthernet4 no ip address duplex auto speed auto ! !---Create dialer interface for PPPOE connection, apply crypto map on dialer interface, !-- lower mtu due to pppoe restrictions, apply encap ppp, set dialer pool and dialer group, !--- configure authentication, pap or chap, if not sure configure both

interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 dialer-group 1 no cdp enable ppp authentication pap callin ppp chap hostname spoke1 ppp chap password 111cisco ppp pap sent-username spoke1 password 111cisco crypto map mymap ! !-set NAT for LAN traffic using overload

ip nat inside source list 102 interface Dialer1 overload ip classless ip route 0.0.0.0 0.0.0.0 Dialer1 ! !---specify route for LAN to LAN private network traffic to each peer

ip route 192.168.5.0 255.255.255.0 Dialer1 ip http server no ip http secure-server ! !-acl 1 -set LAN traffic to be allowed on your dialer interface access-list 1 permit 192.168.5.0 0.0.0.255 ! !---acl 102 exclude LAN to LAN traffic from being included in NAT

access-list 102 deny ip 192.168.6.0 0.0.0.255 192.168.5.0 0.0.0.255 access-list 102 permit ip 192.168.6.0 0.0.0.255 any ! !-acl 110 define interesting traffic form spoke1to hub

access-list 110 permit ip 192.168.6.0 0.0.0.255 192.168.5.0 0.0.0.255 ! control-plane ! ! line con 0 exec-timeout 120 0 no modem enable transport preferred all transport output all stopbits 1 line aux 0 transport preferred all transport output all ! !-set login via telnet using local information

line vty 0 4 exec-timeout 30 0 login local transport preferred all transport input all transport output all ! scheduler max-task-time 5000 ! end

Reply to
datakazam

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.