No ipv6 in IPSec config ?

Hello !

I tried to configure a IPSec tunnel on a router but it seems ipv6 is not supported in IPSEC on my comp.

When I need to type this ligne : crypto isakmp key password-type keystring {address peer-address [mask] | ipv6 {ipv6-address/ipv6-prefix} | hostname hostname} [no-xauth]

there's no ipv6 option, only address appears on the command line.

I tried on many different IOS on many routers but always the same !

Here's the current IOS I'm working on : Cisco IOS Software, 3600 Software (C3640-IK9O3S-M), Version 12.4(10), RELEASE SOFTWARE (fc1)


Any idea ?

Thank you !

Reply to
Loading thread data ...

formatting link

I am not familiar with IPSEC for IPv6 however it appears that you may need

Feature - "IPSec v6 Phase 2 Support" Description - "IPSec site-site support is extended for v6 traffic."

From the Feature Navigator, this is not available on the 3640.

These seem to be supported among many others.

3631, 3660 2800, 3800, 1800, 870 also obviously 7200.

You also seem to need 12.4T (or one of the weird specials).

Check for yourself on the feature navigator.

Reply to

An 877 here seems to support it anyway.

router(config)#cry isa key 0 fred address ipv6 1:1:1::1/128 ? no-xauth Bypasses XAuth for this peer


This is: release 12.4, T train, sub-version 15, emergency rebuild 7 (of the T train). Advanced IP Services [with crypto - k9] feature set.

mz m - run from RAM - almost all do - (not 2500 - runs from flash). z - compressed

I think it is gzip compression and that you can uncompress the images with gzip/gunzip. (handy for dynamips)

Reply to
bod43 Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.