cdp enable/disable?


I have a Cisco 2610 (I think) router connected to a switch connected to my network. We recently received a couple of VOIP phones (Cisco IP-Phone 7940 series). When I plug these into the network, my syslog receives the following error from the router once a minute:

05-15-2007 16:39:39 Local7.Warning 387: 10w3d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on Ethernet0/0 (not full duplex), with SEP001AE22A943D Port 1 (full duplex).

I googled it and found some suggestions to just turn cdp off on the Ethernet0/0 interface of the router.

This would get rid of the messages I'm receiving, but do I really want to do that? Are the messages I'm seeing real error messages indicating a problem I should resolve, or are they just informational, letting me know of something that is harmless?


Lisa Casey

Reply to
Lisa Casey
Loading thread data ...

No, you probably don't want to do that. You do have a duplex mismatch between the VOIP phone and the switch. The CDP messages are coming from the phone. The router is displaying them, even though its not the culpret (if the HP switch knew what CDP was, it'll stop them there).

You probably have the phone force set to Full Duplex, which means that auto-negotiation is turned off, which the ethernet spec requires the side that is set to auto-negotiate (the switch) to fallback to half-duplex. Ie. standard duplex mismatch.

Make sure the point where your phone is getting its network info is set to do auto-negoation rather than force duplex. Most likely its TFTP'ing its setup info from the callmanager, although its possible to manually setup the network info in them. Fixup the network settings there, and the messages should go away.

Reply to
Doug McIntyre

Probably not. I'd guess there's a non-Cisco switch between the phone and the router. The router sees a CDP neighbour reporting a full duplex connection (to the switch) but receives the messages on an interface which is running half duplex. It therefore complains. If there were a CDP-speaking switch between them those particular messages wouldn't get through.


Reply to
Sam Wilson


Most likely you have your Cisco IP Phones connected to non-Cisco switch. CDP protocol usually doesn't cross Cisco switches - it works between two adjacent Cisco devices.

You may be able to shut down these messages - go to the router, go to configuration mode, enter into the E0/0 interface, and issue the command "no cdp log mismatch". Something like:

Router# config t

Router(config)# int e0/0

Router(config-if)# no cdp log mismatch

I don't know what IOS version you are, however it should work.

Good luck,

Mike CCNP, CCDP, CCSP, Cisco Voice, MCSE W2K, MCSE+I, Security+, etc. CCIE R&S (in progress), CCIE Voice (in progress)

------ PC Headset Adapters for Cisco IP Phones

formatting link
formatting link

Reply to Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.