BGP

hi

i should announce my hosts and not my networks

this is not a problem with hosts whose are outside router, but i dont know how to announce ip on local interface

for example

router bgp 100 no synchronization bgp log-neighbor-changes network 172.172.172.168 mask 255.255.255.255 network 172.172.172.169 mask 255.255.255.255 network 172.172.172.170 mask 255.255.255.255 network 172.172.172.171 mask 255.255.255.255 network 172.172.172.172 mask 255.255.255.255 neighbor 212.103.2.36 remote-as 200 neighbor 212.103.2.36 description Tests neighbor 212.103.2.36 prefix-list BGP-TEST-OUT out no auto-summary

ip route 172.172.172.168 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.168 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.168 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.168 255.255.255.255 GigabitEthernet 3/8

Reply to
pierre
Loading thread data ...

sorry for one more return !

i should announce my hosts and not my networks

this is not a problem with hosts whose are outside router, but i dont know how to announce ip on local interface

for example :

router bgp 100 no synchronization bgp log-neighbor-changes network 172.172.172.168 mask 255.255.255.255 network 172.172.172.169 mask 255.255.255.255 network 172.172.172.170 mask 255.255.255.255 network 172.172.172.171 mask 255.255.255.255 network 172.172.172.172 mask 255.255.255.255 neighbor 212.103.2.36 remote-as 200 neighbor 212.103.2.36 description Tests neighbor 212.103.2.36 prefix-list BGP-TEST-OUT out no auto-summary

ip route 172.172.172.168 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.169 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.170 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.171 255.255.255.255 GigabitEthernet 3/8 ip route 172.172.172.172 255.255.255.255 Null0 254

ip prefix-list BGP-TEST-OUT seq 5 permit 172.172.172.168/32 ip prefix-list BGP-TEST-OUT seq 10 permit 172.172.172.169/32 ip prefix-list BGP-TEST-OUT seq 15 permit 172.172.172.170/32 ip prefix-list BGP-TEST-OUT seq 20 permit 172.172.172.171/32 ip prefix-list BGP-TEST-OUT seq 25 permit 172.172.172.172/32

interface GigabitEthernet3/8 ip address 172.172.172.172 255.255.255.0 end

does anybody knows how should i configure my bgp router for announce

172.172.172.172/32 ?

thanks for all and sorry for my previous post

regards,

pierre

Reply to
pierre

Why are you advertising your hosts and not your networks? Put a network 172.172.172.0 mask 255.255.255.0 and be done with it. Are you doing this because of the prefix lists?

Reply to
Trendkill

i need advertising host because my neigboor filter take only /32 .....

"Trendkill" a écrit dans le message de news: snipped-for-privacy@x41g2000hsb.googlegroups.com...

Reply to
pierre

Can you explain the reasoning behind this? Is it for some particular application? The only time I've seen /32 host routes advertised in BGP is for blackholing.

In order to advertise this /32 address on your connected interface ...

router bgp xxxxx redistribute connected

Chris.

Reply to
Chris

thank you for your response, but redistribute connected advertise 'networks' conncted (whith tag 0) if my ip address is /24, only my /24 is announced

is there a possibility to not announcing my interface 'Connected' in order to put my route to my host and my network manually ?

regarding the /32, we are not enable to change it because it is a policy of our peer

"Chris" a écrit dans le message de news:

17w01mg63s37b$. snipped-for-privacy@40tude.net...
Reply to
pierre

This should work, except the null route

follow these steps to troubleshoot

source router, where you advertise the static

router bgp 1 no synchronization bgp log-neighbor-changes network 172.172.172.168 mask 255.255.255.255 network 172.172.172.169 mask 255.255.255.255 network 172.172.172.170 mask 255.255.255.255 network 172.172.172.171 mask 255.255.255.255 network 172.172.172.172 mask 255.255.255.255

you can configure "redis static" in here

neighbor 12.1.1.2 remote-as 2 neighbor 12.1.1.2 prefix-list BGP-TEST-OUT out no auto-summary ! ip classless ip route 172.172.172.168 255.255.255.255 Ethernet0/0 ip route 172.172.172.169 255.255.255.255 Ethernet0/0 ip route 172.172.172.170 255.255.255.255 Ethernet0/0 ip route 172.172.172.171 255.255.255.255 Ethernet0/0 ip route 172.172.172.172 255.255.255.255 Null0 254 ! ! ! ip prefix-list BGP-TEST-OUT seq 5 permit 172.172.172.168/32 ip prefix-list BGP-TEST-OUT seq 10 permit 172.172.172.169/32 ip prefix-list BGP-TEST-OUT seq 15 permit 172.172.172.170/32 ip prefix-list BGP-TEST-OUT seq 20 permit 172.172.172.171/32 ip prefix-list BGP-TEST-OUT seq 25 permit 172.172.172.172/32 !

check for the route in the rib, otherwise it will not make it to the bgp table

Gateway of last resort is not set

172.172.0.0/16 is variably subnetted, 5 subnets, 2 masks S 172.172.172.168/32 is directly connected, Ethernet0/0 S 172.172.172.169/32 is directly connected, Ethernet0/0 S 172.172.172.170/32 is directly connected, Ethernet0/0 S 172.172.172.171/32 is directly connected, Ethernet0/0 C 172.172.172.0/24 is directly connected, Ethernet0/0 12.0.0.0/24 is subnetted, 1 subnets C 12.1.1.0 is directly connected, Serial2/0 Router#

now check the the bgp table

Router#sh ip bgp BGP table version is 5, local router ID is 172.172.172.172 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 172.172.172.168/32 0.0.0.0 0 32768 i *> 172.172.172.169/32 0.0.0.0 0 32768 i *> 172.172.172.170/32 0.0.0.0 0 32768 i *> 172.172.172.171/32 0.0.0.0 0 32768 i

now check whether neighbour is up and then check advertised routes

Router#show ip bgp nei 12.1.1.2 ad Router#show ip bgp nei 12.1.1.2 advertised-routes BGP table version is 5, local router ID is 172.172.172.172 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 172.172.172.168/32 0.0.0.0 0 32768 i *> 172.172.172.169/32 0.0.0.0 0 32768 i *> 172.172.172.170/32 0.0.0.0 0 32768 i *> 172.172.172.171/32 0.0.0.0 0 32768 i

Total number of prefixes 4 Router#

in the other router =====================

check the bgp neighbour

Router#sh ip bgp summ BGP router identifier 12.1.1.2, local AS number 2 BGP table version is 23, main routing table version 23

4 network entries using 468 bytes of memory 4 path entries using 208 bytes of memory 2/1 BGP path/bestpath attribute entries using 264 bytes of memory 1 BGP AS-PATH entries using 24 bytes of memory 0 BGP route-map cache entries using 0 bytes of memory 0 BGP filter-list cache entries using 0 bytes of memory BGP using 964 total bytes of memory BGP activity 9/5 prefixes, 13/9 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

12.1.1.1 4 1 78 74 23 0 0 00:56:12 4 best, i - internal, r RIB-failure, S Stale Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 172.172.172.168/32 12.1.1.1 0 0 1 i *> 172.172.172.169/32 12.1.1.1 0 0 1 i *> 172.172.172.170/32 12.1.1.1 0 0 1 i *> 172.172.172.171/32 12.1.1.1 0 0 1 i

Total number of prefixes 4 Router#

check whether it is made to bgp table

Router#sh ip bgp BGP table version is 23, local router ID is 12.1.1.2 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 172.172.172.168/32 12.1.1.1 0 0 1 i *> 172.172.172.169/32 12.1.1.1 0 0 1 i *> 172.172.172.170/32 12.1.1.1 0 0 1 i *> 172.172.172.171/32 12.1.1.1 0 0 1 i Router#

from that to the rib

Router#sh ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR

Gateway of last resort is not set

172.172.0.0/32 is subnetted, 4 subnets B 172.172.172.168 [20/0] via 12.1.1.1, 00:57:36 B 172.172.172.169 [20/0] via 12.1.1.1, 00:57:36 B 172.172.172.170 [20/0] via 12.1.1.1, 00:57:36 B 172.172.172.171 [20/0] via 12.1.1.1, 00:57:36 12.0.0.0/24 is subnetted, 1 subnets C 12.1.1.0 is directly connected, Serial2/0

if the route flapping check for the time stamp or repeat the following many times more than 60 seconds

Router#sh ip route 172.172.172.171 Routing entry for 172.172.172.171/32 Known via "bgp 2", distance 20, metric 0 Tag 1, type external Last update from 12.1.1.1 00:57:59 ago Routing Descriptor Blocks: * 12.1.1.1, from 12.1.1.1, 00:57:59 ago Route metric is 0, traffic share count is 1 AS Hops 1, BGP network version 0 Route tag 1

Hope this helps good luck

Sanjeewa Alahakone

Reply to
sanjeewa.alahakone

the OP is stilling left with his original issue - he cannot advertise the local route 172.172.172.172/32 via BGP

the static route "ip route 172.172.172.172 255.255.255.255 Null0 254 " will not succeed as long as the interface GigabitEthernet3/8 is up

AFAIK there is no way in IOS to announce a local route having a /24 mask as a /32 host route via BGP

the thought of changing the primary address to be something else and then rying to configure 172.172.172.172/32 as a secondary did occur to me but IOS will not accept:

(config)#int gi 6/2 (config-if)#ip address 172.172.172.172 255.255.255.255 sec Bad mask /32 for address 172.172.172.172

Reply to
Merv

Interesting. That's behavior I had never stumbled over.

Getting out a bigger hammer...

interface loopback38 description Loopback interface carrying IP address for Gig3/8 ip address 172.172.172.172 255.255.255.255

interface Gig3/8 description This interface actually feeds the 172.172.172.0/24 subnet ip address 255.255.255.252

ip route 172.172.172.0 255.255.255.0 Gig3/8 arp arpa 172.172.172.172 alias

Now the router still handles and responds to traffic addressed to its own address at 172.172.172.172

And it still routes traffic for the rest of 172.172.172.0/24 through the connected interface.

And it still responds to ARP on Gig3/8 as if its IP address were still

172.172.172.172 on that interface.

But now it has a route for 172.172.172.172/32

Be aware that if you want to source router-originated traffic from

172.172.172.172, it's no longer good enough to simply route the traffic out Gig3/8. You'll need to control the source IP address by other means.

Among other things, that means that an ICMP-based traceroute from the

172.172.172.0/24 segment will see the IP address.
Reply to
briggs

Sorry, I missed the point you infact need to advertise the

172.172.172.172 /32 :), may be I was bit sleepy at that time

Ok, some thoughts but may not work or not really advised for a production network

1) get the gig to act as a p2p, (like a peer neighbour route) 2) conditional bgp advertisement

I will check and let you know about this

Regards Sanjeewa

ocPrf Weight Path

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

ocPrf Weight Path

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 =A0 =A00 =A0 =A0 =A0 =A0 32768 i

=A0 23 =A0 =A00 =A0 =A00

ocPrf Weight Path

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

ocPrf Weight Path

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

=A0 =A0 0 =A0 =A0 =A0 =A0 =A0 =A0 0 1 i

Reply to
sanjeewa.alahakone

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.