A home media server problem (port forwarding?)

Here is a problem that takes a lot of words to explain. I don't think it is that tricky though. My ignorance is the main issue.

I have a cable modem connected to a Sonicwall TZ-150 wireless appliance. The TZ-150 has three interfaces:

WAN: Goes to cable modem. Wired LAN: Gateway, subnet mask Wireless LAN: Gateway, subnet mask

On the wired LAN, I have my main PC. It appears to be playing well with the TZ-150.

On the wireless LAN, I have a Netgear EVA700 media extender. This is a gadget that sends analog audio and video to my living room TV via the usual RCA type cables. It also has an 802.11g radio.

After very much fiddling around, I finally got the EVA700 to communicate with the TZ-150!!! It even does WPA. I am so happy.

For my next act, I am trying to bring up a feature which is the main purpose of the EVA700: serving media (audio and video). Microsoft calls this upnp, or universal plug and play.

The upnp feature consists of a piece of software on a PC sending audio and video to a media extender, like the EVA700. The media extender then displays movies and music on my TV set. In theory. Not in practice.

The EVA700 has no user interface for specifying which server to connect to. None of the PC software I have tried has a user interface for specifying what media extender to connect with, UNTIL the connection is acutually achieved. For example, after the connection is achieved, the PC software I have allows me to restrict access to certain types of movies, music, and photos.

Because of these observations (previous paragraph) I believe that the EVA700 media extender is sending some kind of broadcast request over

802.11g, and waiting for a suitable reply.

I observe that over on my PC, there is a Windows service "Windows Media Player Network Sharing Service" that is listening on TCP port 10243. This is one of the ports mentioned in my EVA700 user documentation. There are other ports, but no process on my PC appears to be listening to them. The other ports in the documentation are TCP: 2869, 10243 UDP: 1900, 10280, 10281, 10282, 10283, 10284

So my speculation is that the EVA700 is sending a broadcast request on port TCP 10243, but it is not being relayed to the main PC. Recall that the EVA700 is connected to the wireless gateway, while the PC is connected to the wired gateway

I have tried various "firewall" rules on the TZ-150, but I have found nothing that works. As far as I can tell, the "firewall" is where NAT is configured on the TZ-150.

If you have read all the way to here, I thank you! I'd love to hear any suggestions you have.

Reply to
David Arnstein
Loading thread data ...

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.