Poor performance with a 3640

I have a 3640 with 3 FastEthernet interfaces and 128M of memory.

Our primary ISP provides us with a 25Mb ethernet feed. If I bypass the router and plug a laptop directly into their switch, I can easily saturate the 25Mb link while downloading large test files from one of their servers. If I move my laptop to one of the interfaces on the router, I max out at around 200 kbps. In a lab environment (PC1 Fa0/0 Fa1/0 PC2) I can sometimes push that up to a full 1Mbps.

I know the 3640 was designed to be able to handle a full DS3, so our

25Mb + 8Mb links should be no problem. BGP isn't loading it down, as we get a default route from one ISP and a few ( 7, last time I checked ) local routes from the second.

Basically this is a vanilla config of IOS 12.2(31). I enabled CEF, which seems to have improved things slightly.

If I'm reading this correctly, we're not running low on memory:

Border#sh mem sum Head Total(b) Used(b) Free(b) Lowest(b) Largest(b) Processor 61FC14C0 96725824 5888480 90837344 89298640

89243144 I/O 7C00000 4194312 2321752 1872560 1872560 1872508

What else should I be looking at? I can't believe this router is actually choking on our (relatively) minimal amount of throughput...



Reply to
Loading thread data ...

Check your duplex settings on your FastE links. Match what the ISP is doing.

Duplex mismatch can give pittiful throughput like this.

Yes, the 3640 should easily be able to handle 20Mbps. I haven't pushed them much beyond that, but had no problems at that level.

Reply to
Doug McIntyre

I have both interfaces set to 100-full. I'm pretty sure it's not a duplex issue, as I see the same problem when connecting directly to a pair of PCs. I will double-check with the ISPs, though.


Reply to

Ideally reload router to clear out all counters and stats.

Create the problem,

During traffic forwarding gather:-

sh proc cpu

Afterwards gather

sh int sh int switching sh int stats sh buff

this is not meant to be other than helpful, your description does not suggest that you understand what to do with duplex settings, There are many good posts on this group about it and I wont repeat here.

In fact rather than the above you could just try all 4 possible combinations of full/auto on both interfaces.

Dont bother with half or speed settings.

Reply to

If you set one side to full duplex, you MUST set the other side (your PC or the switch of your ISP) too! If the other side does auto negotiation, it gets no answer to the negotiation request and must set to half duplex...

greetings Mathias

Reply to
Mathias Mistrik

And, of course, you (and Doug) were right. I actually do understand the implications of duplex mismatches, learned the hard way. But for some reason it's an ongoing blind spot for me... I frequently don't think to consider duplex until after beating my head against the wall for a few hours/days.

In this case the first internal switch was set to 'auto' and was showing a ton of collisions. I moved it to 'full' and everything was goodness and light.

This also explains the weird performance I saw with my lab tests, as the PCs were set to auto.



Reply to

Hi Ben,

One golden rule that helps is - If one end of an Ethernet link is set to AUTO then the other end should also be AUTO.

AUTO AUTO usually works fine, but it may require a BREAK/RECONNECT of the physical cable to ensure neotiation takes place correctly.

AUTO MANUAL will ALWAYS fail, unless the MANUAL side is set to

10/Half (the "default" fall-back for AUTO).


Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.