IOS 12.2 FW - Talk to cable modem

So I've seen many configs out there to get routers to talk to comcast cable, and I dont seem to be getting it to work.

This router was originally configured for DSL and PPPoE, then had VPN connection to Office. Now I want the External NIC to be DHCP and not PPPoE, Though I'd rip out the PPPoE and Add in the DHCP and I would be set, though no go.

Here is the DSL PPPoE config, what do I need to CHange to make Ethernet0 DHCP.

Thanks,

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname comet.olivet

!

no logging console

enable secret 5

enable password 7

!

clock timezone PST -8

clock summer-time PST recurring

ip subnet-zero

no ip source-route

! !

ip tftp source-interface FastEthernet0

no ip domain lookup

ip name-server 10.1.0.11

ip name-server 10.1.0.8

ip dhcp excluded-address 10.11.0.0 10.11.2.255

!

ip dhcp pool oliver-pool

network 10.11.0.0 255.255.0.0

dns-server 10.11.0.5 10.1.0.8 10.1.0.11

default-router 10.11.0.1

domain-name olivet.haydon-mill.com

!

no ip bootp server

!

ip vrf ENM

description ENM HQ Route

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group office

!

vpdn-group pppoe

request-dialin

protocol pppoe

! ! !

crypto isakmp policy 1

hash md5

authentication pre-share

crypto isakmp key keypw address xx.yy.ww.zz

crypto isakmp keepalive 300 10

! !

crypto ipsec transform-set charlie-set esp-des esp-md5-hmac

!

crypto map charlie 10 ipsec-isakmp

set peer xx.yy.ww.zz

set transform-set charlie-set

match address 101

! ! ! !

interface Ethernet0

no ip address

ip nat outside

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface FastEthernet0

ip address 10.11.0.1 255.255.0.0

ip nat inside

ip tcp adjust-mss 1452

speed auto

no cdp enable

hold-queue 32 in

hold-queue 100 out

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname UserName

ppp chap password 7

ppp pap sent-username User Name password 7

crypto map charlie

!

router eigrp 2

network 10.0.0.0

default-metric 1000 100 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

!

ip nat inside source route-map nonat interface Dialer1 overload

ip classless

ip route profile

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

! !

logging trap warnings

logging source-interface FastEthernet0

logging 10.1.0.17

access-list 1 permit 10.11.0.0 0.0.255.255

access-list 101 permit ip 10.11.0.0 0.0.255.255 10.1.0.0 0.0.255.255

access-list 101 permit ip 10.11.0.0 0.0.255.255 10.2.0.0 0.0.255.255

access-list 102 permit ip 10.11.0.0 0.0.255.255 any

access-list 110 deny ip 10.11.0.0 0.0.255.255 10.1.0.0 0.0.255.255

access-list 110 deny ip 10.11.0.0 0.0.255.255 10.2.0.0 0.0.255.255

access-list 110 deny ip 10.1.0.0 0.0.255.255 10.11.0.0 0.0.255.255

access-list 110 deny ip 10.2.0.0 0.0.255.255 10.11.0.0 0.0.255.255

access-list 110 permit ip 10.11.0.0 0.0.255.255 any

dialer-list 1 protocol ip permit

no cdp run

!

route-map nonat permit 10

match ip address 110

!

snmp-server community public RO

snmp-server enable traps tty

banner motd 

This is a private system operated for and by Company and

Authorization from company, management is required to use this system.

Use by unauthorized persons is prohibited.

 !

line con 0

exec-timeout 20 0

password 7

login

length 54

width 132

line aux 0

transport output none

line vty 0 4

exec-timeout 20 0

password 7

login

length 54

width 132

!

no scheduler allocate

ntp server x.y.z.w prefer

end

Reply to
Scott Townsend
Loading thread data ...

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.