Help -> Cisco BGP as-path prepend not working

Any / all help / suggestions greatly appreciated.

I'm trying to do something that I assume is a very standard basic setup with BGP. Yet something is not working.

I have 2 upstream 100Meg ethernet connections. I am contracted for 20 meg on one connection, and 50 meg on the other. Thus I'd like most of my traffic to come in the connection that I have commited to purchase at least 50 meg on.

With a normal / minimal bgp setup I get approx 25 meg on each connection.

So I thought I'd use the as-path prepend command to prepend the 20meg commit connection to swing some of that traffic to the other connection.

I've tried prepending with 1 as 3, 7 and even 10 copies of our as number. Also made sure I did "clear ip bgp b.b.b.b soft" on the bgp peers

Yet, I still get approx 25 meg coming in to us on both connections. It looks like my prepends are not taking affect at all.

Checking a few of the online looking glass sites, I do see my prepends showing up in the as list.

I see similar questions being asked over the years Lots of exmples online, even several text-book examples of doing this, yet it does not seem to be working for me.

This is my current BGP setup:

router bgp xxxxx no synchronization bgp log-neighbor-changes network a.a.a.a mask network a.a.a.a mask neighbor b.b.b.b remote-as 6539 neighbor b.b.b.b description GT neighbor b.b.b.b route-map prepend_path out neighbor b.b.b.b filter-list 1 out neighbor a.a.a.a remote-as 701 neighbor a.a.a.a description UUNet neighbor a.a.a.a filter-list 1 out no auto-summary

ip as-path access-list 1 permit ^$

route-map prepend_path permit 10 set as-path prepend xxxxx xxxxx xxxxx xxxxx xxxxx xxxxx xxxxx

Like I said above, if anybody has any comments or suggestions, I'd greatly appreciate hearing them.

Reply to
Loading thread data ... Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.