duplex negotiation

I have a link between a baystack switch and a cisco 1841 router, I have the same setup and same configuration at 70 other sites and have not seen this problem before.. when each device is manually set to 100/full the link goes down and I get no lights on either end, when one end is set to auto/auto and the other manually to 100/full the link comes up as

100/full for anywhere between 10secs and several hours then drops back to half duplex. when both ends were auto auto they came up 100/half, I set the duplex on the switch only to full then the link was running 100/ full, I tried manually setting the speed/duplex when the link was running correctly but that killed the link again and I couldn't get it running back at 100/full again.

I have tried different switchports and it has the same problem, is it possible for a device to mis-report what duplex its running at? we are going to replace the cabling to ensure its not faulty but because it was able to run at full duplex it rules out a dodgy pair in the cable.

at all the other sites we have 100/full statically set on the interfaces at each end.


Reply to
Loading thread data ...

In article , "flamer snipped-for-privacy@hotmail.com" writes: [...]

Yes, it is although this shouldn't be.

Not only the cable but as well the plugs could be the problem.

This should work. But I remember cases where devices from different brands or even different models from the same brand couldn't cope with each other. In addition, do your switches have the lastest software updates?

Regards, Christoph Gartmann

Reply to
Christoph Gartmann

If one side of a connection is set to auto-negotiate and the other side to full duplex the auto-negotiate side will default to half duplex. Cisco recommends both sides of the link be set to auto-negotiation -

Configuring and Troubleshooting Ethernet 10/100/1000Mb Half/Full Duplex Auto-Negotiation

formatting link
If you manually set both sides to 100/full you need to watch the errors. If the wiring is inadequate your error rate can get quite high.

- Jim

Reply to
Jim Allen

Thanks for the advice both of you, I am thinking now that perhaps the devices never really were running at full-duplex and the cable may need replacing, although on the cisco it was reporting full duplex and no errors for a while now it half duplex it has many errors and resets on the interface. I know there have always been auto neg issues with cisco in the past but all the routers and switches are running the same ios versions and have the same config and everything so its just one site that isn't working correctly. should i try set the port duplex/speed without the cable plugged in maybe?


Reply to

The article on the Cisco site you quoted says different...

"Both sides of a link should have auto-negotiation on, or both sides should have it off. Cisco recommends to leave auto-negotiation on for those devices compliant with 802.3u."

Reply to

Autonegotiation is almost always superior to any manual fiddling - as a general statement.

This issue feels like a bad cable. With FD there are greater demands on the cable since both ends may be transmitting at the same time. This means that the receiver has to be able to cope with its own transmitter blasting out with orders of magnitude more power than the expected received signal. To make this work you need a proper cable.

Bear this in mind - autonegotion is good.

More networking problems have been caused by misguided manual intervention in this area than have ever been fixed by it.

Read the current Cisco advice and believe it. If it's not working as advertised something is broken.

Until a few years ago I NEVER trusted the duplex setting reported. Trust ONLY the error counters on networking equipment that you trust. I you have old kit then suspect the settings reported.

Reply to

the work we did yesterday seemed to go well, we had to use a straight through cable (cat5e which is more than adequate for 100mb/fd) and strapped both sides manually o 100/full the link stayed stable and had no errors or collisions reported.. I kept a watch on the counters for 25mins and stayed running fine I have to check again today to see if its still running fd with no errors.. I can't see why it wouldn't.. cross-over cable still immediately killed the link..


Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.