Cisco as NAT client - configuration


Can anybody let me know the procedure to configure a Cisco Router (2501, 2522) to act as a NAT client?

I have a Cable modem from my ISP connected to a D-Link Broadband router (DI-714P+) that acts as the NAT server. This device (D-Link) has both the Public IP (203.109.93.x) as well as Private IP ( and acts as the Internet Gateway. It has four Ethernet ports to which I connect my Windows workstations - all of which are configured to use DHCP (Automatically assign IP Information by DHCP) and so NAT.

If the workstations are manually configured for IP, Gateway and DNS information, they successfully can access the Internet.

Now, when I manually configured my Cisco router for IP, Gateway and DNS information, it couldn't access the net anyway. I tried pinging the D-Link gateway - it succeeded. Then I tried to ping my public IP - it failed!!

Now thinking that the problem would be with the default gateway configured (ip default-gateway or ip default-gateway e0), I tried setting a default-route (ip route e0) to the e0 interface. Still it didn't work.

Now, I thought of setting the Cisco Router to use DHCP for addressing information - so I removed all existing addressing information and configured the e0 interface to use dhcp by using "(config-if)#ip address dhcp". This is something which really isn't working at all. When I use "show interface e0", I get the status as "Internet address will be configured using DHCP". But even after waiting for a long time no addressing is automatically configured. I could see some link activity but rarely.

I am unable to understand why this is happening so. If the same configuration works on PCs, why its not working for the Router. The worst part of all these is that the Router is able to ping the Gateway, but unable to get Internet access from it neither DHCP info too. I tried to startup from fresh by removing startup-config too, that too on both the routers, but all in vain!

Do Cisco Routers need to be differently configured to act as NAT client? Or is it some compatibility problem with D-Link Router?

Any Help would be appreciated,

Regards, Uday

Reply to
Loading thread data ...

Send us a "show run"

What is the status of the interfaces? UP/UP or DOWN/DOWN?

Did you make sure the interfaces are not shutdown?


Reply to

sounds like a routing problem to me show us the running-config pls

Reply to
polleke Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.