2620, 1721 and T1 - routing issue

I recently had to replace some routers and have the following problem.

I have a 2620 with the T1 card at a colo site and a 1721 with the same T1 card at the office. The 2620 T1 card is configured with a .73/29 address and the 1721 with .74. The T1 is up and running fine. On the FastEthernet0 in the 1721 I have the .80/28 address.

The machines on my local network can ping the .80 and the .74 on the1721 and each other, but nothing beyond that.

The 1721 router can ping anything on the internet, the 2620, and the local network.

I can ping from the internet to the 2620 and the .74 on the 1721 but not the .80 or my local network.

I presume the is just a routing issue, but the things I have tried so far fail.

Any ideas? I tried calling Cisco, but they seem not be interested on the weekend.


Reply to
"Steve Christensen"
Loading thread data ...
  • "Steve Christensen" hackte in den Rechenknecht:

If you presume that, you already had a look into the routing tables of both routers. Share it and possibly someone can point you to an answer.


Reply to
Lukas Schratz

Maybe you don't have an appropriate level of $upport with them?

Perhaps you could post more information. The outputs of #show ip route #show ip interface brief #show access-lists would be most useful.

Reply to
A. non Eyemouse

Do I get you right - you have e.g. on your T1 (6 addresses - 4 of them are wasted!) and e.g. NETWORK on your 1721 LAN side, I assume you have chosen .1.81 for your fastethernet0/0 interface.

The behaviour you describe occurs when no routing protocol is active / static routing is configured wrong, or when access-lists block some traffic. As others have already written, show your routing table, interface config and access lists if available.



Am 27.03.2011 10:48, schrieb "Steve Christensen":

Reply to
Thomas Caspari

Thanks for the comments. Here are the details I have. (The colo with the 2620 is miles away so I am using info I wrote down from there for now)

FastEthernet0/0 (connected to ISP's systems)


Ethernet1/0 (connected to a switch at colo then to servers there)


Serial0/0 (T-1 card to connect to T-1 card on 1721 in office)

xxx.xxx.208.73 (xxx's are numbers of course)

On the 2620

ip route xxx.xxx.140.213

The Ethernet1/0 to the servers is working fine and servers are visible to the world. The T-1 is the problem though is seems to be communicating but as you all say the routing is in bad shape. This was the setup the support guy at my ISP suggested for the IP addresses and netmasks. He had no idea how to set up the T-1 and clearly neither do I. My previous set up was running fine for 8 years so I "lost" what knowledge I had about all of this back then.

Here on the 1721 I get

#show ip route

Default gateway is not set

Host Gateway Last Use Total Uses Interface ICMP redirect cache is empty

# show ip interface brief

Interface IP-Address OK? Method Status Protocol FastEthernet0 xxx.xxx.208.80 Yes manual uo up Serial0 xxx.xxx.208.74 Yes manual up up

#show access-lists gives no output

#show run on the 1721 contains ip related lines

no ip routing ip subnet-zero ip classless

Under Seril0

ip route xxx.xxx.208.74

if any of this is useful.

Reply to
"Steve Christensen"
  • "Steve Christensen" hackte in den Rechenknecht:

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ That is the part, why you have problems

and this why it is failing. You can't set your default gateway to your own interface address. Either you set it to the interface or you set it to the next hop. Preferably the latter or a combination like: ip route Serial 0 xxx.xxx.208.73


Reply to
Lukas Schratz

Thanks for the suggestions. I tried them and this is now the status of the 1721.

#show run

interface FastEthernet0 ip address xx.xxx.208.80 speed auto full-duplex ! interface Serial0 ip address xx.xxx.208.74 service-module t1 timeslots 1-24 speed 56 ! ip classless ip route Serial0 xx.xxx.208.73 no ip http server !

Router#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route

Gateway of last resort is xx.xxx.208.73 to network

xx.0.0.0/24 is subnetted, 1 subnets C xx.xxx.208.0 is directly connected, FastEthernet0 is directly connected, Serial0 S* [1/0] via xx.xxx.208.73, Serial0

Router#show ip interface brief Interface IP-Address OK? Method Status Prot ocol FastEthernet0 xx.xxx..208.80 YES manual up up

Serial0 xx.xxx.208.74 YES manual up up

Router#show access-lists


Router#ping xx.xxx.208.66

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to xx.xxx.208.66, timeout is 2 seconds: .!!!! Success rate is 80 percent (4/5), round-trip min/avg/max =3D 4/5/8 ms Router#ping xx.xxx3.208.73

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to xx.xxx.3.208.73, timeout is 2 seconds: !.... Success rate is 20 percent (1/5), round-trip min/avg/max =3D 8/8/8 ms Router#ping xx.xxx.208.85

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to xx.xxx.208.85, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max =3D 1/1/4 ms Router#

Router#ping xx.xxx.208.80

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to xx.xxx.208.80, timeout is 2 seconds: ..... Success rate is 0 percent (0/5) Router#,

I can ping from my local network to the .80, but not out anywhere.

Steve C.

Lukas Schratz wrote:

OK? =A0 =A0 =A0 =A0 Method

Reply to
"Steve Christensen"
  • "Steve Christensen" hackte in den Rechenknecht:

Really? Is this the same subnet as below 208.73? Then it is bound to fail. If you could refrain from using fake xxx-addresses one could tell more easily.

That's not the whole truth, according to your ping tests.


Reply to
Lukas Schratz

Reply to
"Steve Christensen"

no hint what you did? This newsgroup lives from user contribution...

Am 29.03.2011 09:48, schrieb "Steve Christensen":

Reply to
Thomas Caspari

That may be help me a lot, Thanks for the comments that you told above.

Reply to

Thanks a lot, I think the comments above may help me to solve my problem!

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.