Cisco ip helper-address


I had pass the 4 CCNA curriculum sessions successfully and i'm not able to do something I think is basic.

I have to forward PPPoE Broadcast packets to my PPPoE server at over my Cisco router.

I use the Cisco 851-K9 router and read on Cisco session 4 that the ip helper-address command forward the Broadcast packets to Unicast IP address.

So I've put in the int Vlan1 the command

ip helper-address

and that doesn't work.

I see something about the ip forward-protocol command but I think I missed something.

If someone can help me, It's will be appreciated.

Best Regards


Reply to
Martin Leduc
Loading thread data ...

If a helper address is specified and UDP forwarding is enabled, broadcast packets destined to the following port numbers are forwarded by default:

.Trivial File Transfer Protocol (TFTP) (port 69)

.Domain Naming System (port 53)

.Time service (port 37)

.NetBIOS Name Server (port 137)

.NetBIOS Datagram Server (port 138)

.Boot Protocol (BOOTP) client and server packets (ports 67 and 68)

.TACACS service (port 49)

.IEN-116 Name Service (port 42)

Combined with the ip forward-protocol global configuration command, the ip helper-address command allows you to control which broadcast packets and which protocols are forwarded.

begin 666 blank.gif K1TE&.#EA`@`"`( ``/___P```"'Y! $`````+ `````"``(```("A%$`.P`` ` end

Reply to

Hi and thanks for your answer.

You're right and I check on Cisco FAQ and Help the ip forward-protocol command.

After that I read severals PPPoE documentation:

formatting link
and the RFC

formatting link
I read on the page #2 in the RFC that the Ether_Type for the discovery stage is 0x8863 and the PPP session stage is 0x8864.

Nowhere they talk about the UDP Protocol and the PPPoE Broadcast.

I'm confuse

So I had try with ip forward-protocol any-local-broadcast, doesn't work.

I had enable the debug on the udp query, I dont see anything

I had enable the debug on all the query, very big mess to check

I'm sure that all ISP using the PPPoE user control use a complete routed network behind the PPPoE users sessions.

Otherwise, it's doesn't make sens.

Can you help me please?



"BernieM" a écrit dans le message de news:

Reply to
Martin Leduc Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.