TCP/IP not working on one of two computers -> 1 router

Okay so my desktop with a refurb D-Link DWL-G510 all of a sudden won't talk to the Linksys WCG200 wireless router we have here. This is the weird thing. The WCG200 has always had the problem of random 10-minute interval dropouts, but yesterday, the desktop completely bit the dust concerning connectivity.

This is the weird thing. The laptop I'm using has a Ralink 802.11g MiniPCI built into it, and it gets its IP/DHCP/Subnet through the Linksys router all resolved nice and dandy to something like 66.250.204.x but the desktop keeps resorting to the local Aren't wireless routers by default supposed to reserve the pool of 192.168 addresses for its internal WLAN and use one internet IP for the other side?

There are up to 5 of us using the internet at the same time, and with no real problems except for my desktop. The thing is, the 'connected clients' listing in the router setup shows ONLY the WLAN-only desktop, not the WAN-connected clients. Why would this be?

When the connection died, the desktop simply stopped working right all of a sudden... I made no network changes of any kind. I've selected DHCP to try to manually assign, then revert to automatically select address... both of them are no go.

Why would a router assign one network adapter an internal address and keep it on the internal network, while letting everyone else access the outside? Is there a TCP/IP setting that could "let it out" like everyone else?


Reply to
Phil, Non-Squid
Loading thread data ...

I had a similar with two HP refubs (same model). One of them would never work with the PCI D-Link wireless to either a US Robotics or 2Wire router. Worked ok from a D-Link USB wireless though for like 4 months. Then it quit.

I swapped drives and cards from the same HP model and then that one quit working too. Now neither one would work with any router. Although they weren't getting an IP address. All other computers were working fine. And the 2 HP computers only worked from dialup and nothing else. Did a dualboot install with a fresh copy of Windows and still a no go. Tried 2 D-Link PCI wireless, 2 D-Link USB wireless (refubs), and 1 USB Belkin wireless. And even wired directly to the router.

Months later I bought some 2Wire HomePNA. I just tried one of them and that works great on one of the HP computers. The other one is still in pieces. And I have no idea why HomePNA is working while other methods are not. I am convinced it isn't the software, but something in the hardware.

Reply to
BillW50 Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.