LAN but no Internet

One of my son's roommates contributed a Linksys WRT54G from her parent's home to their apartment but they couldn't get it to work. Trying to help them, I reset the router, configured WEP 128-bit encryption, and got two of their laptops to access the router just fine. However, while they could ping the router just fine, they can't get to the Internet. I've confirmed that the internet is available directly from the modem.

Any ideas why they can't get out to the open Internet?

TIA, David

Reply to
David Schwartz
Loading thread data ...

BTW, it's a version 8 of the Linksys model.

David

Reply to
David Schwartz

  1. Can you ping the router? Try: start -> run -> cmd ping 192.168.1.1 If not, see solution to step #2.
  2. Plug one of their computahs directly into the router with a CAT5 cable. If you can get to the internet, please forget about using WEP and switch to WPA-PSK or WPA2-PSK.
  3. If the router is connected to a DSL modem, it may require a PPPoE login and password be configured in the WAN settings.
  4. If the router is connected to a cable modem, some ISP's require that the MAC address is "registered" with them in order to "authenticate" the client. Check the ISP's help file on the web.
  5. If the router is connected to an existing router, kindly disclose the setup and hardware list so we can untangle this mess. If so, you probably want to use the WRT54G as an access point and not a router. For instructions, see:
  6. When you connect to the internet, download the latest firmware for the WRT54G v8 router. The off the shelf variety never seem to have the latest bug fixes.
Reply to
Jeff Liebermann

Yes we can

We could not reach the internet by using a wired connection to the router.

It's a cable modem.

The router is connected directly to the modem.

I've already updated the firmware.

Thanks, David

Reply to
David Schwartz

If it is like the cable modems we use in the UK, they have to be power cycled when you connect a different device into them - have you tried this?

Reply to
Toby

Two things - first, power-cycle the modem and router; second, call your ISP to see if they need to register a new MAC address.

Reply to
Mark McIntyre

Problem. Your IP address in your header resolves to c-24-18-206-138.hsd1.wa.comcast.net. Comcast does NOT authenticate by MAC address, so something else is going wrong here. Try turning off the cable modem for about 30 minutes to reset the ARP table at the COmcast end. If you have an Arris or SA VoIP modem (or similar device), it has a backup battery which will hold its setting as long as the battery lasts. Either punch the reset button, or extract the battery for about 30 seconds.

You might find this interesting (or disgusting):

You might also try logging into the cable modem (192.168.100.1) and if the diagnostics display anything useful.

Reply to
Jeff Liebermann

Or change the MAC address on the router. Most support doing this.

Reply to
Bill Kearney

Not required. A modem reboot would still be needed (max CPE reached), but beyond that, as Jeff pointed out, Comcast doesn't register the MAC address of the device attached to the modem, so changing it won't do anything except get you a different IP.

Reply to
Char Jackson

Cycling the modem power did it!

Thanks for all who helped!!

David

Reply to
David Schwartz

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.