Dell Latitude 2100 netbook with 1510-N WLAN Mini-Card won't acquite IP

I've got a Dell Latitude 2100 netbook with 1510-N WLAN Mini-Card. The router is a Netgear CVG824G v3 which works fine with 4 other wireless devices around the house. We are using WPA PSK with TKIP encryption. I have entered and re-entered the passphrase a number of times. It is correct.

But this Dell thing just sits there with status of "acquiring network address" forever. I have tried sitting in the same room, less than a metre from the router, the Dell shows 5 bars of signal strength but it won't get itself an IP.

The netbook was issued by child's school for use in the classroom and at home. It seems to work fine at school so I can't go changing things too much.

And because the router has worked fine for more than a year with every other wireless device we can throw at it I don't want to change anything there either.

An ideas or magical incantations will be appreciated.

regards, Merc

Reply to
Loading thread data ...

can you define a static IP, GW, DNS - just to see if it all works ?

Reply to

Try changing the authentication & even try it without authentication. See if that works in your home.

Reply to

Are you running Ubuntu, Vista, or one of the Windoze 7 mutations?

Assumption, the mother of all screwups. I had a similar problem until I discovered I had a leading space in the WPA key.

That means it didn't like your WPA key. Have you tried temporarily disabling the wireless encryption and see if it works that way? That will eliminate any driver or compatibility issues. However, it doesn't hurt to be sure. Have you checked the firmware version of the CVG824G v3 to make sure it's the latest? I had to upgrade some old Netgear WGR614 router firmware in order to get Windoze 7 to connect with WPA-PSK-TKIP. Same with checking for Windoze and Dell updates. Use the ethernet cable.

Any chance your Netgear router has a MAC address filter setup? If so, you'll never get a connection. Add you laptop MAC address to the allowed list and try again.

Windoze has various utilties that will show wireless connection progress. For example, here are the instructions for XP.

When you disclose your operating system, I'll try to find the instructions.

Hmmm.... if the laptop is able to connect with other wireless routers, there must be something "incompatible" with your Netgear setup or firmware. My guess would be Netgear firmware or Windoze updates.

Also, I've noticed that many of the school laptops floating around here have never been updated. When I asked, the user proclaimed that the school doesn't allow users to add or update programs. Sigh.

I don't think anything is broken. However, Microsoft does change timing and protocols with every major release of Windoze. Windoze 7 may require a firmware update of the Netgear. I can't tell because the CVG824G v3 is a cable router and the Netgear site does not offer any info on this router in the US. Maybe check with your cable provider.

Call the cable provider. It's their router and probably their problem.

Reply to
Jeff Liebermann

One more. Vista introduced a DHCP client problem, which causes DHCP failures like you described.

This is NOT a problem in XP or Windoze 7.

Reply to
Jeff Liebermann

Thanks for all the quick responses. I should have mentioned that the Dell has XP sp3 installed. I just tried turning off the encryption and the Dell did connect to the router but then wouldn't connect to internet. That tells me something but I'm not sure what. Well it said it was connected and authenticated and had acquireing but it still wouldn't even open so I could log into the router admin. My own ASUS notebook with Vista was now refusing to connect to anything. So I had to stand up, walk 20 metres, plug in the network cable, then reset the router back, then walk back to the couch. After all that effort I needed a beer.

I suppose upgrading the firmware on the router is the next step. When I think about it, the school must be using MAC filtering for their wireless network. Helping 1200 students who have forgotten their password would probably be a bit much.

Another option could be to get my old WGR614 out of the cupboard, put it in her room and configure that as a bridge. I got the WGR 614 free as part of a previous broadband contract. That will mean that she is stuck to her desk, which isn't so bad. She will only ever be doing homework on this thing, she already has a bigger Dual Core Vista notebook for games, Youtube, MSN and iTunes.

Again, thanks for your help.

regards, Merc

Reply to

The specs on the Insprion 2100 Netbook indicates that it's not sold with XP. Must be a wipe and reinstall by the school, or a special order from Dell.

Beer will be of some help with tolerating the situation, but is not very useful for fixing the problem. Methinks you're doing something rather odd here. As I read the above, you could not configure the router, but you could turn off the encryption. That's impossible as the encryption must be disabled in the router, not the client. Do you perhaps have the Dell setup in some kind of peer-to-peer mode? That's not going to work. Now that I think of it, that also sorta matches the symptoms.

This would be a good time to start over with the wireless connection. The hard part is getting rid of the save old settings. System Tray -> Wireless Icon -> right-click -> View available networks -> Change order of preferred networks. Find your Netgear SSID and delete it. Advanced -> check "access point, infrastructure only" Refresh view available networks and try connecting again from scratch.

Incidentally, if your wireless SSID happens to be Netgear, log into the router and change it. Connecting to the neighbors router with the same name is an amazingly common problem.

Nope. Checking with your cable provider if you have the latest version is the next step. No need to update if there's nothing available.

If you're wanna dive deep, turning on connection logging as I previously suggested works with XP WZC. The problem is that it generates HUGE debug logs, which take me forever to find the point of failure. It's worth the exercise and will probably show you where in the negotiation things are failing.

I doubt it. Too much work keeping the MAC addresses straight. Some kind of RADIUS login/password authorization and 802.1x authentication is probably what they're doing. It's quite easy to impliment if you have a central server to manage the security.

One local charter school charges $5(?) for every forgotten password. I've been told it works. Incidentally, they also assign passwords and don't let students pick their own. That allegedly elinates much of the password hacking, but doesn't help if the students write their passwords where anyone can see it. (Moral: you can't win).

Yep, that will also work. Make sure the WGR614 isn't on the same RF channel (1, 6, or 11). Use different SSID's so that you know which wireless AP to connect to. Also, be sure to disable the DHCP server in the WGR614. Incidentally, there are some hardware revisions of the WGR614 that I've found to be unreliable (chronic disconnects). I think it was V5 hardware, but I'm not sure. The latest firmware allegedly fixes the problem, but I haven't bothered to verify it.

Good luck.

Reply to
Jeff Liebermann

....... ......

I had my ASUS sitting next to the Dell, I used the ASUS to turn off the encryption, then I couldn't connect with either, I suppose I should have changed the encryption settings on the ASUS to reconnect, but what would be the point of that? I was never going to run an open network and the only point of the exercise was to see what would happen with the Dell. Sorry I didn't explain it very well.

I did all that.

I didn't do that, why would it help?

I did that.

No, not a problem, the SSID is very distinctive.

Reply to

If you had the wrong WPA encryption key or goofy settings saved in the "profile" for that SSID, or you had another access point saved with the same SSID, it's easier to delete than to fix the "profile". Since you can't connect anyway, it doesn't make any sense to leave a profile in place that doesn't work. However, reading onward, both conditions are unlikely and this is probably not necessary. Did you happen to find your SSID listed in the "order of preferred networks" window? That happens with a partial connection, where some experiment partly succeeded and Windoze saved those settings. They're probably wrong or messed up. If you still can't connect, try deleting the saved settings anyway and see if it helps.

I'm running out of things to try as you seem to have anticipated most of them. At this point you can connect the 2100 Netbook to most anything except the Netgear router. WPA tests with other wireless routers, the Netgear firmware update, and turning on Windoze connection logging seems to be all that's left.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.