Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bug?

Do you use WPA2-PSK AES on Windox XP and do you not broadcast your SSID? Can you confirm a Windows Wireless Zero Configuration bug I'm seeing? Once confirmed, how do we report this to the Microsoft WZC team?

Bug: Windows Wireless Zero Configuration (WZC), using WPA2-PSK AES, grays out the "Network Key" field when the SSID is not broadcast. It is impossible to enter the network key without resorting to broadcasting your SSID.

Details: You can't set up your WinXP Home (WPA2-PSK AES) network without broadcasting your SSID (at least temporarily). This is, IMHO, a bug.

To Reproduce .....

  1. Start Fresh:

- Remove your current WinXP Home network connection by selecting your network SSID and pressing the "Remove" button in the "Wireless Network Connection Properties" form, press OK, and reboot your WinXP Home computer.

  1. Set your router to not broadcast your SSID:

- On your router (mine is a Linksys WRT54G), if you have not done so already, please turn off broadcasting of your SSID & set your "Security mode = WPA2 Personal" (aka "Network Authentication = WPA2-PSK"), set your "WPA Algorithm = AES" (aka "Data encryption = AES"), and enter your desired "WPA Shared Key" (aka "Network key").

  1. Try to add your WPA2-PSK/AEs network WITHOUT broacasting your SSID!

- On WinXP Home, bring up the "Wireless Network Connection Properties" form and click the "Wireless Networks" tab. Since you removed your network, you should not see it in the "Preferred networks" box.

- Press the "Add" button. In the "Accociation" tab of the "Wireless network properties" form that pops up, enter your SSID name in the "Network name (SSID)" field, check the box to "Connect even if this network is not broadcasting", and in the "Wireless network key" section, select "Network Authentication = WPA2-PSK" and "Data encryption = AES".

- Notice you need to enter a "Network key" and you must "Confirm network key" but inexplicably, both are grayed out. You can not enter the network key with the SSID not broadcasting! This is the bug.

  1. To set your network up, tell your router to broadcast the SSID.

  1. Repeat step 3 above. Now you can enter your network key.

  2. Go back to your router and disable the broadcast of your SSID.
Reply to
Loading thread data ...

Did you uncheck the "The key is provided for me automatically" box before switching from "Open" Network Authentication to "WPA2-PSK"?

You can not enter the network

Reply to

Oh my! No. I did not touch that and it was checked by default.

Silly me. I apologize. I will try it again from scratch and report back!

Reply to
Sharon Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.