Cisco 2600 ADSL with failover to Ethernet with NAT

Good afternoon everyone,

I am having trouble setting up a simple failover configuration.

We have 2 connections (one is Fiber @ 10Mbit, other is ADSL @ 6Mbit).

The Fiber usage is expensive, so for client usage I was looking at using our ADSL as a base, but failover to the Fiber if the DSL disconnects / goes down. My servers are running on other routers, so this router is strictly for client NAT.

The problem: If I start this configuration up fresh it works. The system will NAT through the ADSL connection and all is well. I then do a =93shutdown=94 on Dialer1. It continues to work fine and automatically switches to the Fiber connection. I then do a =93no shutdown=94 on Dialer1 and the whole thing stops working. The ADSL connection gets an IP, but something seems to be messed up with the NAT part. I can=92t even traceroute from the router. Everything times out.

My current setup: eth0/0: fiber connection {static IP} eth0/1: LAN Dialer1: PPPOE ADSL {dynamic IP}

My running config: version 12.3

memory-size iomem 15 clock timezone EST -5 aaa new-model aaa session-id common ip subnet-zero no ip source-route no ip cef no ip ftp passive no ip bootp server ip audit po max-events 100 ip ssh time-out 60 ip ssh authentication-retries 2

interface ATM0/0 no ip address no atm ilmi-keepalive bundle-enable dsl operating-mode auto

interface ATM0/0.1 point-to-point pvc 0/35 pppoe-client dial-pool-number 1

interface Ethernet0/0 bandwidth 5000 ip address [OurExternalFiberIP] no ip proxy-arp ip nat outside no ip route-cache half-duplex no cdp enable

interface Ethernet0/1 ip address no ip proxy-arp ip nat inside no ip route-cache half-duplex no cdp enable

interface Dialer1 bandwidth 7000 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp no ip route-cache ip tcp adjust-mss 1452 dialer pool 1 no cdp enable ppp chap hostname [Login] ppp chap password 0 [Password] ppp pap sent-username [Login] password 0 [Password]

ip nat inside source route-map Fiber interface Ethernet0/0 overload ip nat inside source route-map ADSL interface Dialer1 overload

no ip http server no ip http secure-server

ip classless

ip route Dialer1 10 ip route [OurFiberGatewayAddress] 20

ip route Ethernet0/1 ip route [OurFiberStaticNetworkAddress] Ethernet0/0

access-list 1 permit access-list 1 permit

no cdp run

route-map Fiber permit 10 match ip address 1 match interface Ethernet0/0 ! route-map ADSL permit 10 match ip address 1 match interface Dialer1

Thanks, Jack jbaker (at) neustyle [dot] com

Reply to
Loading thread data ...

I am not sure what might be causing the problem I doubt it will be with NAT unless it is a bug.

- however

I think that you will need a more sophisticated solution.

=46rom memory a dialer is *always* UP. Unless admin down of course.

So your solution will not work. I may be wrong, unplug dsl and see if dialer is up to check

sh ip int brie

Look at Policy based routing with Object Tracking.

formatting link
This has got the tools for the job.

Reply to

After a bit of testing I seem to have come to a stable solutions using my config above.

When the Dialer1 interface is shutdown the config switches to NAT over Eth0/0.

Upon re-activation of Dialer1, new NAT will start to go via Dialer1, but any existing connections will continue via Eth0/0 as long as Eth0/0 is up.

So it seems to be working...


Reply to

As discussed above - does it fail over when you unplug the DSL instead - or even maybe shut the ATM interface.

My memory is that dialers are always UP. This is not 100% though.

Reply to
Bod43 Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.