Strange wireless connection problem

Hi, new member of the newsgroup here, posting because the experts at alt.os.linux.mandriva don't seem to have a solution. Setup is laptop with ra2500 wireless card running Mandriva 2007.0 (mostly), Windows XP (sometimes), DG834 wireless router. Setup worked perfectly for a number of months at location A. Moved to location B, where wireless connection worked immediately with XP, but failed to connect to my SSID under Mandriva, although the SSID was visible in the list of wireless networks. Using Mandriva's network monitor, packets were being sent but none received. The "signal strength" indicator for my network was showing minimum. When I looked at the DG834's list of attached devices, I saw the following: # IP Address Device Name MAC Address

1 HAYDN 00:16:17:52:AD:FD 2 HAYDN 00:16:17:52:AD:FD 3 NAS1 00:07:40:FB:C4:F8 IP ...3 is (supposed to be) the wireless connection, IP...4 is the wired ethernet connection. In other words, the wireless connection wants to use the same MAC address as the ethernet connection, whereas I know the wireless MAC is 00:13:D3:81:1E:9C. Unfortunately, because there is no wireless connection, I cannot tell what MAC address is associated with when the ethernet connection is switched off. Has anyone observed this mixup on attached devices? Has anyone a solution how to break the association between the wireless acrd and the eternet MAC? (Don't suggest moving back to location A - the house has been sold and the money's in my bank!). Thanks Grimble
Reply to
Loading thread data ...

Grimble hath wroth:

Any particular product? The chipset description is useful if I were building my own driver, but doesn't do much for dealing with firmware bugs or product specific anomalies.

Failed to connect with what error message? The usual goof is some kind of IP layout problem, especially if you're using static IP's. What does your network topology look like?

That's usually an indication that there's no connection. Sent to what IP? What device? Note that 802.11 type wireless is all bridging. The devices don't know anything about IP (layer 3) addresses and only deal with MAC addresses (layer 2). What do you get when you run: apr -a

Signal strength indicated where? On the XP client? Linux client? In the access point diagnostics? With a wireless sniffer (Kismet or Netstumbler)?

Ahah. You have a Netgear DG834. Not exactly may favorite DSL wireless router. Which country and which firmware version are you using? Some versions have problems.

That's easy. See:

Scroll down a few articles until you get to where the author displays the results of "arp -a". You'll find that the non-transparent wireless client bridge also shows exactly the same behavior. The explanation is in the article, so there's no sense in reposting it.

True. I could explain why it's legal to have more than one IP for a given MAC addresses and get involved in this distraction. However interesting, it has little to do with why you apparently have a weak signal and are unable to connect. However, since I only know 2 operating systems, one DSL wireless router model, and absolutely nothing else, I can't really guess(tm) what might be the problem. Could I trouble you to supply some details, such as makers, models, and versions? Also topology, layout, and wireless hardware description.

All things are possible with sufficient money. My guess is that the problem is in some assumption or change that has happened between locations. What changed? An easy sanity check would be to take the wireless computer and temporarily connect it to the DG834 with a CAT5 cable. If that works, at least the computer is functioning and the problem is in the wireless. If not, then look carefully at your IP layout.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.