ipw2200 + ML 10.2 + kernel 2.6.14 + firmware_helper + udev + hotplug questions

I've been told that udev does the hotplugging at boot up (instead of /sbin/hotplug) and it doesn't install the firmware at boot time. As a result, at boot time, the boot process pauses until timeout when trying to bring up wlan0 (ipw2200). ipw2200 & ieee80211 does install. I am able to workaround this by executing rmmod ipw2200 && modprobe ipw2200. The firmware gets loaded this way. My understanding is that /sbin/hotplug is called (instead of udev) when I do this.

It has been suggested that the firmware loading problem with ipw2200 is a result of a problem with udev. Someone posted that the solution to this firmware issue is the use of firmware_helper in a rule placed in /etc/udev/rules.d. I could not urpmi firmware_helper but I did find the C code. I built firmware_helper and placed it in /sbin and created the rule and placed it in /etc/udev/rules.d. But, it didn't fix the problem.

One of the things I'm wondering is if /sbin/hotplug can be used in the udev rules instead of /sbin/firmware_helper. Or is there another, more elegant, solution to this issue?

Mandriva 2005LE, kernel 2.6.14, udev-054-6.1.102mdk, hotplug-2004_09_23-7mdk, ipw2200-1.0.8, ipw2200-fw-2.4, ieee80211-1.1.6

udev rule posting:

To solve it, you need to add a rule to udev. In the dir > /etc/udev/rules.d, I created the file '999-firmware.rules' (it has to > run last). In that file, I added this line: > >       ACTION=="add", SUBSYSTEM=="firmware", > RUN+="/sbin/firmware_helper"
Reply to
Loading thread data ...

I have ipw2200 running perfectly under 2005LE on this computer, and don't remember any hassles when getting it set up apart from having to install the firmware.

My setup has the following features:

  1. "alias eth2 ipw2200" in /etc/modprobe.conf [Note that it's ethX, not wlanX. I should have thought ipw2200 would default to the same identifier whatever the computer, but who knows.]

  1. Firmware installed in /lib/hotplug/firmware/

  2. Configuration settings in the file /etc/sysconfig/network-scripts/ifcfg-eth2.

One point to bear in mind is that I installed the firmware manually rather than from an RPM. If your system does not have five files "ipw-*.fw" in /lib/hotplug/firmware that might be part of your problem. I haven't done anything to alter the default udev/hotplug settings on this installation. Both udev and hotplug seem to be running side by side.

Let me know if I can give you any further information.


Reply to
Rob Kemp

I use mine under ubuntu, and haven't done _anything_ - including installing firmware (though there _is_ firmware: ubuntu installs it as part of the kernel package).

It goes anywhere you want, afaict. On mine it's eth1, and I can't see any evidence of an alias, anywhere. I think it's being done in udev.

omigod! I have 7 :-)

Same here. It seems there is a version of udev that's obsoleting and removing hotplug, but not all distros have it yet.

Reply to
Derek Broughton

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.