Macs problem wireless

I have a DGL 4300 on channel 11 at the front of the house, with an Engenius EOC 1650, configured as an access point on channel 6 wired to it at the back of the house (with a reserved DHCP address); same SSID and security settings; all the firmwares are up-to-date.

The "seamless roaming" was work just fine until suddenly the 3 poor Mac computers (new, 10.6.x) stopped connecting to the Internet from either station. The signal is there, they assure me that they're connected to the correct station, they're listed on my Wireless Client List(s), but they can't connect to anything on the Internet. It almost looks like a DNS problem of some kind.

Rebooting the two routers fixes the problem, but I don't know for how long. Note that the PC (unknown config to me, probably Win 7) doesn't miss a step here just keeps chugging away; and me a lifelong Mac user.

What should I be looking at to keep this from happening?

Background: We run a small B&B. Normally people use the wireless to read their email in the bedrooms, or in the backyard, even, with the Engenius. Suddenly we've got some guy from Toronto using the whole place as some kind of command centre for a (ahem) "major event." He didn't tell me this before he arrived, or I'd have run a wire and switch over to that part of the house. He set up his "office" in the middle, pretty much I guess right where the signals from the two routers overlap, so maybe his fancy iMac got confused as to which ap to connect to. I dunno.

The wife and I, our computers (and the WD Live) are wired through the DGL gigabit switch.

Reply to
Warren Oates
Loading thread data ...

Check the Dlink DGL4300 for the latest firmware. I don't know if that's the culprit, but it's always a good thing to check.

Forget DNS for now.

  1. Can you ping the router IP address from one of the Mac computer?
  2. Can you ping the ISP's gateway IP address?
  3. Can you ping a well known and connected server on the internet by IP address?
  4. If yes, then try to view a web page by IP address instead of the usual URL. If that works, then you certainly have a DNS problem.

I'm not sure what diagnostics are available on the Dlink, but see if you tell how many IP addresses are being used. All it takes is one paranlid idiot, that constantly changes their wireless MAC address, and therefore also changes the DHCP supplied IP address, to run the router out of IP's. Similarly, all it takes is one machine, that has a static IP mis-configured, where the machine IP just happens to be set to the same as the router IP, and everything stops. There are other dumb things that can be done, but I won't itemize here.

I've also had some weirdness convincing multiple Mac's to connect to my WRT54G running DD-WRT. Some of them, just will not connect when I use WPA2-AES, but work fine when set to WPA-TKIP. So, I have two SSID's configured on my system. The 2nd one is named "Just-For-Macs".

Charge extra for the "major event". Tradition has it that such events tend to slowly increase the bill, hoping that you won't notice, until it's quite large at the end. They they just disappear.

It's not an iMac. It's probably an MacBook. Have him double click on the wireless icon near the top right of the screen and look at the IP settings. It should be DHCP, not "manual". Be sure to charge extra for the tech support.

Reply to
Jeff Liebermann

More: If it really is an iBook G3 or G4, which is rather old, it's officially limited to OS/X 10.3.9. My G3 iBook has a hell of time connecting to some encrypted access points. My neighbor has two of those weird lampshade Mac's, also running 10.3.9. Neither will connect to his DIR655 wireless router, but will connect nicely to my WHR-HP-G54. My guess(tm) is that there's some kind of compatibility issue between Mac wireless and some routers, but at $30-$50 for a new router, it's easier to replace than to fix.

Reply to
Jeff Liebermann

Thanks for the reply, Jeff.

They haven't complained since I rebooted the routers; I'll try all that next time they have problems. I've got the Dlink set to use Google's DNS, FWIw.

I don't think these guys are changing their MAC addresses; I doubt that they even know what that means.

I went through the network settings, but only on one of their Macs (the MacBook as it happens, brand new just-out-of-box, and the papers were in order, as it were - no manual addresses set; I'll check out the other Macs next time it happens; I'll start with his huge iMac. The Dlink reports the right number of IP addresses for the machines in use (including all of ours). The max is set for 99.

That's interesting. The Dlink is set for "WPA Personal" and "auto" TKIP/AES which has worked well up to now. The Engenius is set for "WPA-PSK-Mixed" and "auto" which seems to be the same thing. I could simplify it, I guess. I remember a couple of years ago Macs having problems with AES. I like the idea of separate SSIDs for Macs. I'm not sure how to do that, though. I'll dig into it.

Yeah, I know. The jefe guy reminds me of all the reasons people from Montreal dislike those from Toronto. Loud abrasive yuppies who love jargon.

Thanks again. I muddle along with help from people like yourself.

Reply to
Warren Oates

No, I may have written "iBook" instead of "iMac" -- it's a flashy new

27" iMac (so who uses 1440p?), and the others are newer MacBook Pros.
Reply to
Edward Theodore Gein

Well, that may have fixed it. Some of my routers have been up for months and can probably run indefinitely. Others require daily reboots. I wish I could see a pattern, but it seems random.

Google DNS is fine. That's what I like to use. Your other choices are OpenDNS and DNS provided by your ISP. I would not expect any of these to cause problems. Where I get into problems is when I use the DNS cache in the router. That's where the DNS points to the IP address of the router, instead of to Google DNS, OpenDNS, etc. Some routers seem to make a mess of it, so rather than find one that doesn't, I just avoid the problem and setup the client computah to point directly to the DNS server. However, that implies tinkering with the MacBook settings, so I don't think that's going to be usable.

You'll be surprised. I've seen the stranges things in coffee shops. One lady was told by her son to "hit this icon when done" every time she signed off. Among other things, it cleared her cache, and wiped any evidence of having been there, but also changed the MAC address. She understood that it was to improve privacy, which I guess fits. Other than that, she had no idea what she was doing. Your visitor may have the same situation.

So much for that theory. It's possible we're creating a major problem when the only thing that was really wrong was a confused wireless router.

If it's working, don't touch it (or at least save the config file so you can undo the damage).

You could probalby get away with increasing the DHCP address pool to about 250.

Auto sorta works but tends to be a bit slow to connect. I don't know exactly how it works, but my guess is that if AES fails, it falls back to TKIP. How long that will take is unknown. On the WRT54G router I mentioned, the main SSID is set to WPA2-AES+TKIP, which is the same as 'auto". It doesn't work with several Mac's in the office complex. I haven't had time to troubleshoot the problem, and nobody seems interested here. So, rather than fight it, I just created a WPA-TKIP SSID, and ignored the problem.

A quick skim of the specs and the manual didn't find any mention of multiple SSID's.

Reply to
Jeff Liebermann

Thanks for looking. I'll need a new router soon anyway. The Engenius has a setting for VLAN profiles, which will probably give me a headache figuring out, and probably isn't what I need.

Thanks for the help!

Reply to
Warren Oates Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.