Wep

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


Can someone help, done searches but still cannot figure it out.
I.m using a Linksys WRT54gs wireless network, sharing internet,printing and
file sharing between 2 PC's and a Apple iBook with airport card. All are
working fine and can see each other.Router is attached to PC 1.
However, I have protection disabled and I want to have WEP activated on the
router. I've generated a passkey on 64bit  , 10 hex digits and  ie, as
follows:

Default transmit key :  2

A97349DADC
EBEA1413D3
C604FA3C7B
5EC3997A5D

Now, when I've tried to connect to the network with PC 2 (Belkin wireless
card installed) and the ibook and  asked for the password, I've tried all
the numbers (?) and the 10 numbers on line 2. I read somewhere, on the ibook
to put a $ sign first . Still cannot connect.

What am I doing wrong......any idea ?

Want to get this sorted before someone parks outside my house with a laptop
and pillages my PC's  :-)





Re: Wep



> What am I doing wrong......any idea ?

Set the Linksys to use only *one* WEP key. Macs can't work with rotating
WEP keys.



Re: Wep


On Mon, 14 Feb 2005 00:06:49 GMT, neillmassello@earthlink.net (Neill
Massello) wrote:

>
>> What am I doing wrong......any idea ?
>
>Set the Linksys to use only *one* WEP key. Macs can't work with rotating
>WEP keys.

True.  However, the Airport client will work with 64bit WEP keys.
Listing four of these 64bit keys in the access point is probably the
only way to configure it. As I vaguely recall, the Airport driver is
currently smart enough to recognize the difference between 128bit keys
in hex or ASCII, but fails to automagically recognize the difference
between 64bit hex and ASCII (this may have been fixed).  I use 64bit
keys on my office LAN (because I have a pile of Orinoco Silver cards)
so I run into the problem often.  As I recall, I had to prefix the hex
WEP key with either a $ or 0x to have it recognized.   I always use
Key #1 and have never bothered trying the others.  In any case, a byte
of trial and error (8 tries) with the prefix and hex format on the
Airport should yield something that eventually works.


--
Jeff Liebermann    jeffl@comix.santa-cruz.ca.us
150 Felker St #D   http://www.LearnByDestroying.com
Santa Cruz CA 95060    AE6KS  831-336-2558


Re: Wep



> Can someone help, done searches but still cannot figure it out.
> I.m using a Linksys WRT54gs wireless network, sharing
> internet,printing and file sharing between 2 PC's and a Apple
> iBook with airport card. All are working fine and can see each
> other.Router is attached to PC 1. However, I have protection
> disabled and I want to have WEP activated on the router. I've
> generated a passkey on 64bit  , 10 hex digits and  ie, as follows:
>
> Default transmit key :  2
>
> A97349DADC
> EBEA1413D3
> C604FA3C7B
> 5EC3997A5D
>
> Now, when I've tried to connect to the network with PC 2 (Belkin
> wireless card installed) and the ibook and  asked for the
> password, I've tried all the numbers (?) and the 10 numbers on
> line 2. I read somewhere, on the ibook to put a $ sign first .
> Still cannot connect.
>
> What am I doing wrong......any idea ?

I also read about the leading $ sign to signify hex characters when
configuring an Airport card. Couldn't get that to work on my iMac,
but using 0x worked fine. So if you're using key 2, specify this as:
 0xEBEA1413D3

Hope this helps

--

Richard Perkin
To email me, change the AT in the address below
richard.perkinATmyrealbox.com

It's is not, it isn't ain't, and it's it's, not its, if you mean it
is.  If you don't, it's its.  Then too, it's hers.  It isn't her's.
It isn't our's either.  It's ours, and likewise yours and theirs.
-- Oxford University Press, Edpress News


Re: Wep


Thanks Jeff & Richard, all sorted and secure.
Just installed extra  RAM in the iBook so now well happy,

Cheers !





Site Timeline