Linksys wrt54g: Remote Desktop

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


I just got a Linksys WRT54G and I'm trying to use XO Pro's Remote
Desktop to remotely access my home PC which is connected to the wrt54g
via the hardwired LAN port.

I need port forwarding, but apparently the only IPs you can use are
192.168.1.xx  Don't I need to put in my PC's actually IP address
(which I got from www.myipaddress.com ?  In any event I put in the IP
address I got through ipconfig and unchecked "block anonymous....". I
can now connect "remotely" when I'm inside my LAN from a laptop to my
PC (so obviously remote desktop is set up correctly on home PC), but
cannot connect from work to my home PC.

Help... any ideas?

Re: Linksys wrt54g: Remote Desktop




Quoted text here. Click to load it

Check your software firewall. (Windows Firewall, Zone Alarm, Sygate,
Symantec, etcetera). You may have to configure it to accept the outside
connection.
----------
Just Me, D

Re: Linksys wrt54g: Remote Desktop


for port forwarding, put in your PC's IP address.

if your router is configured to use the 192.168.1.xx network, then your
computer will most likely have a 192.168.1.xx IP address.

i can only assume the myipaddress.com site shows you your WAN IP. if your
WRT54G is the device handling the internet connection, any request sent to
your WAN IP will be handled by the WRT54G - you use port forwarding to tell
the WRT54G to send the data to your PC.

running 'ipconfig' on your PC should tell you the IP to put in for Port
Forwarding.

--
http://xenomorph.net /


Quoted text here. Click to load it



Re: Linksys wrt54g: Remote Desktop


puzzled186 wrote:
Quoted text here. Click to load it

No, the address you got from www.myipaddress.com is the IP address of the WAN
port on the WRT54G. It
does NAT (Network Address Translation) to communicate between the internal
network 192.168.1.0/24
and the outside world.

To do what you want, it will be better if your PC has a fixed address, rather
than one obtained by
DHCP, because it might change. If the WRT54G has the normal setup, it will start
DHCP at
192.168.1.100. If that is the case, set yours at the fixed value of 192.168.1.99
with the gateway
and nameserver at 192.168.1.1. Next you reboot and verify that you still have
network access. The
next thing you will need are the TCP port or ports used by Remote Desktop.

Next, you will need to point your browser at 192.168.1.1, log into the router,
go to the
Applications & Gaming tab and the Port Range Forward subtab. Fill in the top row
for the port or
ports you need.

I do this operation for a subversion server that can be accessed from the
outside world. In my case,
the application is "svn", the port range is from  3690 to 3690 (1 port), I left
the pulldown at
"Both", put 50 in the final digit of the IP address (my server is at
192.168.1.50), and checked
"Enable". Save your settings and you should be in business. You can test by
using the laptop with
your external address, as well as the internal one.

Larry

Re: Linksys wrt54g: Remote Desktop


Apparently I did not explain it correctly.  The ip address i used was
192.168.1.100.  I can do a remote desktop while at home using my
laptop so the firewall and setup is ok.

I just cannot access it from work over internet.  The steps I folowed
are in:
http://www.portforward.com/english/routers/port_forwarding/Linksys/WRT54G/default.htm

and used ports 3389.

On Mon, 12 Jun 2006 19:19:35 -0400, puzzled186

Quoted text here. Click to load it


Re: Linksys wrt54g: Remote Desktop


"Answering Some Common Windows XP Home Networking Questions"
<http://www.microsoft.com/windowsxp/using/networking/expert/russel_05Feb.mspx



Quoted text here. Click to load it

--
Best regards,   FAQ for Wireless Internet: <http://Wireless.wikia.com
John Navas      FAQ for Wi-Fi:  <http://wireless.wikia.com/wiki/Wi-Fi
           Wi-Fi How To: <http://wireless.wikia.com/wiki/Wi-Fi_How_To
Fixes to Wi-Fi Problems:  <http://wireless.wikia.com/wiki/Wi-Fi_Fixes

Re: Linksys wrt54g: Remote Desktop


puzzled186 wrote:

Quoted text here. Click to load it
http://www.portforward.com/english/routers/port_forwarding/Linksys/WRT54G/default.htm
Quoted text here. Click to load it

The only address you use on YOUR side of the network, is the 192.168.1.x
address.  To access it from the Internet, though, you need to use the
public address (which you got from myipaddress.com).  So, if your public IP
is a.b.c.d, and the machine you're port-forwarding to is 192.168.1.100, you
set up port forwarding for that IP, and access it from the Internet as
a.b.c.d:3389
--
derek

Re: Linksys wrt54g: Remote Desktop


Yep, that was the secret sauce I needed to get it to work. I couldn't
find that written up anywhere, but now that I see what to do it makes
sense!

Thanks for the help.  I needed both the 192 and the address I get from
myipaddress.

On Thu, 15 Jun 2006 09:45:57 -0300, Derek Broughton

Quoted text here. Click to load it


Site Timeline