Linksys Wireless Adapter Auto-Connect

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
I have a Linksys wireless adapter (WMP11) installed in a new Dell Dimension
3000 running Windows XP SP2.

I have my preferred network configured to auto-connect so that when I start
my pc I'm automatically online.

The trouble is, most of the time the adapter does not connect automatically
and I have to do it manually.  I was wondering if anyone had any ideas as to
why this option behaves so unreliably.

Rich




Re: Linksys Wireless Adapter Auto-Connect
Richard Mesagna wrote:
> I have a Linksys wireless adapter (WMP11) installed in a new Dell
> Dimension 3000 running Windows XP SP2.
>
> I have my preferred network configured to auto-connect so that when I
> start my pc I'm automatically online.
>
> The trouble is, most of the time the adapter does not connect
> automatically and I have to do it manually.  I was wondering if
> anyone had any ideas as to why this option behaves so unreliably.
>
> Rich

Try these: set infrastructure-only mode in adapter; set router/adapter
to open key; broadcast SSID; remove all networks except yours from
preferred networks; uncheck the box in the advanced properties
"automatically connect to non-preferred networks"; change the channel;
change the SSID.  Also, use either WZC or the Linksys config utility but
not both running simultaneously.  Some have reported that running the
wireless network setup utility twice or more will cure this problem.

Also, what signal level are you getting at the PC?

Q




Re: Linksys Wireless Adapter Auto-Connect
Q,

Thanks for the feedback, I will experiment with your suggestions.  My signal
strength always shows "Very Good".

Rich

> Richard Mesagna wrote:
>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>> Dimension 3000 running Windows XP SP2.
>>
>> I have my preferred network configured to auto-connect so that when I
>> start my pc I'm automatically online.
>>
>> The trouble is, most of the time the adapter does not connect
>> automatically and I have to do it manually.  I was wondering if
>> anyone had any ideas as to why this option behaves so unreliably.
>>
>> Rich
>
> Try these: set infrastructure-only mode in adapter; set router/adapter to
> open key; broadcast SSID; remove all networks except yours from preferred
> networks; uncheck the box in the advanced properties "automatically
> connect to non-preferred networks"; change the channel; change the SSID.
> Also, use either WZC or the Linksys config utility but not both running
> simultaneously.  Some have reported that running the wireless network
> setup utility twice or more will cure this problem.
>
> Also, what signal level are you getting at the PC?
>
> Q
>




Re: Linksys Wireless Adapter Auto-Connect
Q,

I'd also like to note that this pc has both an integrated nic card and a
wireless adapter.  I noticed a query in Linsys' kb regarding this and
Linksys said the nic card should be disabled.

I was thinking about trying this one also, although the nic card is
unplugged and I don't see why that should be a problem, any thoughts?

Rich

> Richard Mesagna wrote:
>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>> Dimension 3000 running Windows XP SP2.
>>
>> I have my preferred network configured to auto-connect so that when I
>> start my pc I'm automatically online.
>>
>> The trouble is, most of the time the adapter does not connect
>> automatically and I have to do it manually.  I was wondering if
>> anyone had any ideas as to why this option behaves so unreliably.
>>
>> Rich
>
> Try these: set infrastructure-only mode in adapter; set router/adapter to
> open key; broadcast SSID; remove all networks except yours from preferred
> networks; uncheck the box in the advanced properties "automatically
> connect to non-preferred networks"; change the channel; change the SSID.
> Also, use either WZC or the Linksys config utility but not both running
> simultaneously.  Some have reported that running the wireless network
> setup utility twice or more will cure this problem.
>
> Also, what signal level are you getting at the PC?
>
> Q
>




Re: Linksys Wireless Adapter Auto-Connect
Richard Mesagna wrote:
> Q,
>
> I'd also like to note that this pc has both an integrated nic card
> and a wireless adapter.  I noticed a query in Linsys' kb regarding
> this and Linksys said the nic card should be disabled.
>
> I was thinking about trying this one also, although the nic card is
> unplugged and I don't see why that should be a problem, any thoughts?
>
> Rich
>
>> Richard Mesagna wrote:
>>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>>> Dimension 3000 running Windows XP SP2.
>>>
>>> I have my preferred network configured to auto-connect so that when
>>> I start my pc I'm automatically online.
>>>
>>> The trouble is, most of the time the adapter does not connect
>>> automatically and I have to do it manually.  I was wondering if
>>> anyone had any ideas as to why this option behaves so unreliably.
>>>
>>> Rich
>>
>> Try these: set infrastructure-only mode in adapter; set
>> router/adapter to open key; broadcast SSID; remove all networks
>> except yours from preferred networks; uncheck the box in the
>> advanced properties "automatically connect to non-preferred
>> networks"; change the channel; change the SSID. Also, use either WZC
>> or the Linksys config utility but not both running simultaneously.
>> Some have reported that running the wireless network setup utility
>> twice or more will cure this problem. Also, what signal level are you
>> getting at the PC?
>>
>> Q

Disable the ethernet simply to prevent annoyance from the "cable
disconnected" error.  It's pretty much standard practice in XP with
wireless connections.




Re: Linksys Wireless Adapter Auto-Connect
Q,

I took the following actions:

Changed to infrastructure only mode in adapter
Adapter was already set to open key, no change
Left broadcast ssid disabled for security reasons
My network is the only preferred network, no change
"automatically connect to non-preferred networks" not checked, no change
Didn't attempt to change the channel or ssid (not using the default ssid)
Ran the linksys ez connect utility to diagnose problems, it identified an
outdated driver and updated it.
Disabled the nic card.

Result:

No improvement.

This is more of an annoyance as you can always connect manually and
sometimes it autoconnects for a period of time.  It's just puzzling as to
what is causing this fickle behavior.

Thanks,

Rich

> Richard Mesagna wrote:
>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>> Dimension 3000 running Windows XP SP2.
>>
>> I have my preferred network configured to auto-connect so that when I
>> start my pc I'm automatically online.
>>
>> The trouble is, most of the time the adapter does not connect
>> automatically and I have to do it manually.  I was wondering if
>> anyone had any ideas as to why this option behaves so unreliably.
>>
>> Rich
>
> Try these: set infrastructure-only mode in adapter; set router/adapter to
> open key; broadcast SSID; remove all networks except yours from preferred
> networks; uncheck the box in the advanced properties "automatically
> connect to non-preferred networks"; change the channel; change the SSID.
> Also, use either WZC or the Linksys config utility but not both running
> simultaneously.  Some have reported that running the wireless network
> setup utility twice or more will cure this problem.
>
> Also, what signal level are you getting at the PC?
>
> Q
>




Re: Linksys Wireless Adapter Auto-Connect
Richard Mesagna wrote:
> Q,
>
> I took the following actions:
>
> Changed to infrastructure only mode in adapter
> Adapter was already set to open key, no change
> Left broadcast ssid disabled for security reasons
> My network is the only preferred network, no change
> "automatically connect to non-preferred networks" not checked, no
> change Didn't attempt to change the channel or ssid (not using the
> default ssid) Ran the linksys ez connect utility to diagnose
> problems, it identified an outdated driver and updated it.
> Disabled the nic card.
>
> Result:
>
> No improvement.
>
> This is more of an annoyance as you can always connect manually and
> sometimes it autoconnects for a period of time.  It's just puzzling
> as to what is causing this fickle behavior.
>
> Thanks,
>
> Rich
>
>> Richard Mesagna wrote:
>>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>>> Dimension 3000 running Windows XP SP2.
>>>
>>> I have my preferred network configured to auto-connect so that when
>>> I start my pc I'm automatically online.
>>>
>>> The trouble is, most of the time the adapter does not connect
>>> automatically and I have to do it manually.  I was wondering if
>>> anyone had any ideas as to why this option behaves so unreliably.
>>>
>>> Rich
>>
>> Try these: set infrastructure-only mode in adapter; set
>> router/adapter to open key; broadcast SSID; remove all networks
>> except yours from preferred networks; uncheck the box in the
>> advanced properties "automatically connect to non-preferred
>> networks"; change the channel; change the SSID. Also, use either WZC
>> or the Linksys config utility but not both running simultaneously.
>> Some have reported that running the wireless network setup utility
>> twice or more will cure this problem. Also, what signal level are you
>> getting at the PC?
>>
>> Q

There is no justifiable security in disabling SSID broadcasting.  Some
wireless cards simply will not connect reliably if SSID is not
broadcast.  You network is not invisible if SSID is not broadcast.
Anyone with the interest in hacking your wireless will be able to
determine the SSID with no effort whatsoever.

Q




Re: Linksys Wireless Adapter Auto-Connect
Q,

I'm not trying to say it makes it hack proof, but with broadcast ssid it
sure makes it pretty darn easy, your pc shows you all available networks
within range without even trying.

Rich

> Richard Mesagna wrote:
>> Q,
>>
>> I took the following actions:
>>
>> Changed to infrastructure only mode in adapter
>> Adapter was already set to open key, no change
>> Left broadcast ssid disabled for security reasons
>> My network is the only preferred network, no change
>> "automatically connect to non-preferred networks" not checked, no
>> change Didn't attempt to change the channel or ssid (not using the
>> default ssid) Ran the linksys ez connect utility to diagnose
>> problems, it identified an outdated driver and updated it.
>> Disabled the nic card.
>>
>> Result:
>>
>> No improvement.
>>
>> This is more of an annoyance as you can always connect manually and
>> sometimes it autoconnects for a period of time.  It's just puzzling
>> as to what is causing this fickle behavior.
>>
>> Thanks,
>>
>> Rich
>>
>>> Richard Mesagna wrote:
>>>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>>>> Dimension 3000 running Windows XP SP2.
>>>>
>>>> I have my preferred network configured to auto-connect so that when
>>>> I start my pc I'm automatically online.
>>>>
>>>> The trouble is, most of the time the adapter does not connect
>>>> automatically and I have to do it manually.  I was wondering if
>>>> anyone had any ideas as to why this option behaves so unreliably.
>>>>
>>>> Rich
>>>
>>> Try these: set infrastructure-only mode in adapter; set
>>> router/adapter to open key; broadcast SSID; remove all networks
>>> except yours from preferred networks; uncheck the box in the
>>> advanced properties "automatically connect to non-preferred
>>> networks"; change the channel; change the SSID. Also, use either WZC
>>> or the Linksys config utility but not both running simultaneously. Some
>>> have reported that running the wireless network setup utility
>>> twice or more will cure this problem. Also, what signal level are you
>>> getting at the PC?
>>>
>>> Q
>
> There is no justifiable security in disabling SSID broadcasting.  Some
> wireless cards simply will not connect reliably if SSID is not broadcast.
> You network is not invisible if SSID is not broadcast. Anyone with the
> interest in hacking your wireless will be able to determine the SSID with
> no effort whatsoever.
>
> Q
>




Re: Linksys Wireless Adapter Auto-Connect
Richard Mesagna wrote:
> Q,
>
> I'm not trying to say it makes it hack proof, but with broadcast ssid
> it sure makes it pretty darn easy, your pc shows you all available
> networks within range without even trying.
>
> Rich
>
>> Richard Mesagna wrote:
>>> Q,
>>>
>>> I took the following actions:
>>>
>>> Changed to infrastructure only mode in adapter
>>> Adapter was already set to open key, no change
>>> Left broadcast ssid disabled for security reasons
>>> My network is the only preferred network, no change
>>> "automatically connect to non-preferred networks" not checked, no
>>> change Didn't attempt to change the channel or ssid (not using the
>>> default ssid) Ran the linksys ez connect utility to diagnose
>>> problems, it identified an outdated driver and updated it.
>>> Disabled the nic card.
>>>
>>> Result:
>>>
>>> No improvement.
>>>
>>> This is more of an annoyance as you can always connect manually and
>>> sometimes it autoconnects for a period of time.  It's just puzzling
>>> as to what is causing this fickle behavior.
>>>
>>> Thanks,
>>>
>>> Rich
>>>
>>>> Richard Mesagna wrote:
>>>>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>>>>> Dimension 3000 running Windows XP SP2.
>>>>>
>>>>> I have my preferred network configured to auto-connect so that
>>>>> when I start my pc I'm automatically online.
>>>>>
>>>>> The trouble is, most of the time the adapter does not connect
>>>>> automatically and I have to do it manually.  I was wondering if
>>>>> anyone had any ideas as to why this option behaves so unreliably.
>>>>>
>>>>> Rich
>>>>
>>>> Try these: set infrastructure-only mode in adapter; set
>>>> router/adapter to open key; broadcast SSID; remove all networks
>>>> except yours from preferred networks; uncheck the box in the
>>>> advanced properties "automatically connect to non-preferred
>>>> networks"; change the channel; change the SSID. Also, use either
>>>> WZC or the Linksys config utility but not both running
>>>> simultaneously. Some have reported that running the wireless
>>>> network setup utility twice or more will cure this problem. Also,
>>>> what signal level are
>>>> you getting at the PC?
>>>>
>>>> Q
>>
>> There is no justifiable security in disabling SSID broadcasting. Some
>> wireless cards simply will not connect reliably if SSID is not
>> broadcast. You network is not invisible if SSID is not broadcast.
>> Anyone with the interest in hacking your wireless will be able to
>> determine the SSID with no effort whatsoever.
>>
>> Q

So institute all of the available security features in the router:
change default username and password; set a unique IP address
(192.168.XY.Z); set up MAC address filtering; use strong encryption, WPA
if possible; limit DHCP connections to the number required; turn off the
protocol options the router supports, password protect your network
drives.  You don't even mention if your connection problems are
mitigated by broadcasting SSID.   Any interested 10 year old can find
your SSID in an instant.

Q




Re: Linksys Wireless Adapter Auto-Connect
Q,

I'm over 10, but I'm interested in understanding how one discovers the ssid
of a wireless network if it's not broadcast.

I'm going to enable ssid broadcast to see if this solves the autoconnect
issue.

Thanks,

Rich

> Richard Mesagna wrote:
>> Q,
>>
>> I'm not trying to say it makes it hack proof, but with broadcast ssid
>> it sure makes it pretty darn easy, your pc shows you all available
>> networks within range without even trying.
>>
>> Rich
>>
>>> Richard Mesagna wrote:
>>>> Q,
>>>>
>>>> I took the following actions:
>>>>
>>>> Changed to infrastructure only mode in adapter
>>>> Adapter was already set to open key, no change
>>>> Left broadcast ssid disabled for security reasons
>>>> My network is the only preferred network, no change
>>>> "automatically connect to non-preferred networks" not checked, no
>>>> change Didn't attempt to change the channel or ssid (not using the
>>>> default ssid) Ran the linksys ez connect utility to diagnose
>>>> problems, it identified an outdated driver and updated it.
>>>> Disabled the nic card.
>>>>
>>>> Result:
>>>>
>>>> No improvement.
>>>>
>>>> This is more of an annoyance as you can always connect manually and
>>>> sometimes it autoconnects for a period of time.  It's just puzzling
>>>> as to what is causing this fickle behavior.
>>>>
>>>> Thanks,
>>>>
>>>> Rich
>>>>
>>>>> Richard Mesagna wrote:
>>>>>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>>>>>> Dimension 3000 running Windows XP SP2.
>>>>>>
>>>>>> I have my preferred network configured to auto-connect so that
>>>>>> when I start my pc I'm automatically online.
>>>>>>
>>>>>> The trouble is, most of the time the adapter does not connect
>>>>>> automatically and I have to do it manually.  I was wondering if
>>>>>> anyone had any ideas as to why this option behaves so unreliably.
>>>>>>
>>>>>> Rich
>>>>>
>>>>> Try these: set infrastructure-only mode in adapter; set
>>>>> router/adapter to open key; broadcast SSID; remove all networks
>>>>> except yours from preferred networks; uncheck the box in the
>>>>> advanced properties "automatically connect to non-preferred
>>>>> networks"; change the channel; change the SSID. Also, use either
>>>>> WZC or the Linksys config utility but not both running
>>>>> simultaneously. Some have reported that running the wireless
>>>>> network setup utility twice or more will cure this problem. Also, what
>>>>> signal level are
>>>>> you getting at the PC?
>>>>>
>>>>> Q
>>>
>>> There is no justifiable security in disabling SSID broadcasting. Some
>>> wireless cards simply will not connect reliably if SSID is not
>>> broadcast. You network is not invisible if SSID is not broadcast.
>>> Anyone with the interest in hacking your wireless will be able to
>>> determine the SSID with no effort whatsoever.
>>>
>>> Q
>
> So institute all of the available security features in the router: change
> default username and password; set a unique IP address (192.168.XY.Z); set
> up MAC address filtering; use strong encryption, WPA if possible; limit
> DHCP connections to the number required; turn off the protocol options the
> router supports, password protect your network drives.  You don't even
> mention if your connection problems are mitigated by broadcasting SSID.
> Any interested 10 year old can find your SSID in an instant.
>
> Q
>




Re: Linksys Wireless Adapter Auto-Connect
Q,

Not sure if you're still following this thread, but I found that when I
enabled broadcast ssid, my pc started autoconnecting as it should.

Thanks for all your input.

Rich

> Richard Mesagna wrote:
>> I have a Linksys wireless adapter (WMP11) installed in a new Dell
>> Dimension 3000 running Windows XP SP2.
>>
>> I have my preferred network configured to auto-connect so that when I
>> start my pc I'm automatically online.
>>
>> The trouble is, most of the time the adapter does not connect
>> automatically and I have to do it manually.  I was wondering if
>> anyone had any ideas as to why this option behaves so unreliably.
>>
>> Rich
>
> Try these: set infrastructure-only mode in adapter; set router/adapter to
> open key; broadcast SSID; remove all networks except yours from preferred
> networks; uncheck the box in the advanced properties "automatically
> connect to non-preferred networks"; change the channel; change the SSID.
> Also, use either WZC or the Linksys config utility but not both running
> simultaneously.  Some have reported that running the wireless network
> setup utility twice or more will cure this problem.
>
> Also, what signal level are you getting at the PC?
>
> Q
>




Site Timeline