Laptop cannot connect

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
neighbor has offered me a guest account on his wifi
connection. He bought a linksys router, I think it's a t1200.
Problem is when he powers down his main computer I am unable
to connect to the net. Ping to the DHCP server is ok.
Packetsto DNS servers go out but do not return on dns lookup.
The account is set up for 5 guest accounts with password
(which he has given me) and is unencrypted. ipconfig /all
reports an assigned 192.168.xxx.xxx and to me and lease is ok
and an assigned gateway IP, but no replies to dns lookups.
The router is on a separate power connection, but when he
leaves and powers off his computer, I can no longer
connect-or so it seems. Neither of us has a clue as to what
is causing the problem. Ping to dns servers, regardless if
from ISP or public fail. Tried two different laptops both
connecting fine until he left and turned off his box. When I
told him about the problem on his return he
powered back on and suddenly I can connect again. My signal
strength on both laptops I tried is good. He is running win7
and I am running either 98se or XP. He knows less than I do
about this. I have not tried to access the router page as I
do not have admin privileges and have wanted to check here
first before asking neighbor to do anything with router
settings. Any help appreciated.

Re: Laptop cannot connect
On 6/13/2012 12:24 AM, fred wrote:
Quoted text here. Click to load it
It appears that your friend is set up as an ad-hock network rather than
access point and that your wireless is logging into the wireless card in
the PC rather than the router.


Re: Laptop cannot connect
Quoted text here. Click to load it

What makes you think that? To set up an ad-hoc takes some pretty
explicit commands. I just don't see that happening accidentally. I
forget if windows complains/warns the user that they are connecting to
an ad-hoc network. I know Blackberry won't all you to connect to one at
all due to security risks.




Re: Laptop cannot connect

Quoted text here. Click to load it
is

It now appears that his router is not smart enough to
determine when I have logged off and I must explicitly
manually disconnect for the router to recognize that I am
gone and free up one of the guest accounts. This is my
latest theory now, because when I disconnect manually
instead of just shutting down or disabling the adapter I am
then able to re login again and get a working connection.
Very funny sometimes the router asks me for the password  
again and sometimes it does not. I have read too many
complaints about linksys routers to not think this is just
bad software of the router. No it's not an adhoc connection,
he bought a router for this and used the cd with (e1200 if
memory serves) linksys to establish the guest accounts of
which there are 5.

Re: Laptop cannot connect
wrote:

Quoted text here. Click to load it

I think that describes every router. The way they know you have
"logged off" (whatever that means) is that you've let your DHCP lease
expire. If you're not using DHCP, then you never log off because you
never log on.

Quoted text here. Click to load it


As one of the more popular brands of consumer networking gear, it's
normal for there to be more complaints. Look at all the Windows
complaints, as another example.


Quoted text here. Click to load it

I didn't follow the beginning of this thread closely, but a knee jerk
reaction to the statement above is an obvious one: increase the number
of 'guest accounts' to 50 or even 100.


Re: Laptop cannot connect
On 6/14/2012 10:27 AM, Char Jackson wrote:
Quoted text here. Click to load it
Once again Char it sounds like you have nailed it.  With out the manual
disconnection the lease is still assigned to the device until it times
out A new connection goes to the next guest account until they run out
or one of the prior guest accounts times out and is once again open for
use.  I agree the increase in guest accounts will most likely take care
of the problem.  Sorry about the misdirection with the adhock.


Re: Laptop cannot connect
On Thu, 14 Jun 2012 13:33:22 -0500, GlowingBlueMist

Quoted text here. Click to load it

Thanks. We'll see what the OP says. I could still be out to lunch. :)


Re: Laptop cannot connect
wrote:

Quoted text here. Click to load it

Probably the E1200.
<(Amazon.com product link shortened)>

Quoted text here. Click to load it

Did he already have a router, and he simply added the E1200 to
facilitate your access? If so, which router is acting as the DHCP
server? In other words, what are you pinging you when ping the DHCP
server? Secondly, when he powers down his PC, does he also power down
the router or cable/DSL modem? Does he have some or all of this
equipment on a power strip, and when he flips the power off it kills
everything? Is he on DSL and doing PPOE authentication on his PC
versus in his router?

Quoted text here. Click to load it

That was confusing at first, (password, yet unencrypted), but I think
I know what you mean. The wireless connection is unencrypted (open),
but when you connect to that network you're prompted for a guest
password.

Quoted text here. Click to load it

So much for the power strip theory. What about the PPOE auth theory?

Quoted text here. Click to load it


Re: Laptop cannot connect

Quoted text here. Click to load it
Router/dp/B004T9R
Quoted text here. Click to load it
DHCP
DHCP
down
kills
think
(open),
Quoted text here. Click to load it
theory?
Quoted text here. Click to load it

Ok the problem appears to be as I last described. You must
manually disconnect and clear the lease in order to connect again
next time I power up my laptop.

I think the DHCP IP is the router IP but since I do not have admin
privileges (have not asked him for that) I cannot connect to the
router page to verify that. Reason my ping worked to DHCP is that
the router was hearing me, it just was not allowing access until I
first cleared my last guest access.

Having no trouble now as long as I manually d/c from the lease.

Also since I am using an old laptop with an old radio, I cannot
log in to his main non guest connection even though he gave me the
pw since my old radio only does WEP and he is using a later
encryption scheme.



Re: Laptop cannot connect

Quoted text here. Click to load it
I'd suggest getting a usb wifi. That would get you WPA, plus you can put
the wifi dongle closer to the window.
alfa AWUS036H is what I would suggest.

I wouldn't want my router running WEP.



Re: Laptop cannot connect
wrote:

Quoted text here. Click to load it

Weird. Some rhetorical questions:

1.  The router may be on a seperate power strip, but what about the
DSL or cable modem?  Is that being powered off?

2.  Did you power cycle the router AFTER the owners machine was turned
off to see if it magically recovers with his machine still turned off?

3.  Is the owners machine connected via wired or wireless?  If wires,
run IPCONFIG on his Win7 box and see if you get the usual
192.168.1.xxx or if you get a routeable IP address.  If routeable, he
has the CAT5 cables miswired in back of the router.

4.  Check the firmware version:
<http://homesupport.cisco.com/en-us/support/routers/E1200>
Note that v1 is quite different from v2.

5.  If a DSL modem on the evil AT&T, is the PPPoE login in the DSL
modem, in the router, or in the owners Win7 machine?  I prefer to have
it in the router, but it's much easier in the modem.  It should not be
in the Win 7 machine.  If the owners machine starts with "click here
to connect to internet" it's time to reconfigure.

6.  What do the lights do on the router and modem when the owner
powers off his machine?  I think there's an "internet" light on the
router that checks for connectivity.  What does it do?

Looking at the settings, there's nothing on the guest page that might
cause problems.  
<http://ui.linksys.com/files/E1200/2.0.00/guest_access.htm

I would guess #1 as mostly likely.

--
Jeff Liebermann     jeffl@cruzio.com
150 Felker St #D    http://www.LearnByDestroying.com
Santa Cruz CA 95060 http://802.11junk.com
Skype: JeffLiebermann     AE6KS    831-336-2558

Re: Laptop cannot connect
On 6/15/2012 8:53 AM, Jeff Liebermann wrote:
Quoted text here. Click to load it
FWIW, I put the settings in the router. The 2wire DSL modem should
detect you have connected a router. It turns off its firewall, expecting
the router to do that.

I'm not on AT&T, but I bought one of their 2wire routers since they are
very good. [I don't use it as a router or for wireless. I just use it
for the modem.] Yeah, I know, the wall wart sucks. Thus far, mind hasn't
failed, and I never have to boot the modem. I occasionally have to boot
the linksys router to get the wifi working.


Re: Laptop cannot connect
Hi Jeff, more inline below:


Quoted text here. Click to load it
the

Have not asked explicitly but I think he's wireless judging from
his huge antenna on the roof.

Quoted text here. Click to load it
turned
turned off?

See my reply to char jackson. It's working now as long as I
disconnect from the adapter software before trying to come back
later. Most wireless connections do not require explicit
disconnect but since he is allowing 5 guest accounts maybe they
are filled up if I do not d/c each time, router does not clear old
no data transfer connections?

Quoted text here. Click to load it
wires,
routeable, he

see above


He ran the cd from the Linksys router which he just bought so
assuming firmware is current.

Quoted text here. Click to load it
DSL
to have
not be
here

not evil at&t
Quoted text here. Click to load it
the

Did not see any lights when  he invited me over, but did not look
for them either.

Quoted text here. Click to load it
might


My best guess is the router is not clearing stale connections
unless you disconnect and clear them prior?

 


Re: Laptop cannot connect
wrote:

Quoted text here. Click to load it

If that's the case, it might be the MAC address to IP address table
(ARP cache), or the DHCP leases that are not getting cleared on
disconnect.  The ARP cache usually defaults to about 4 hrs.  The DHCP
leases might be set to several days.  No clue if these are the correct
timings for the E1200.  I couldn't find settings in the E1200 router
setup to change either of these.
<http://ui.linksys.com/files/E1200/2.0.00/
However, if my guess(tm) is correct, you should have had no trouble
reconnecting to the router.  Both the ARP cache and DHCP lease tables
should have had your previous connection info and allowed a DHCP lease
renewal, if your computer requests a DHCP renewal, instead of a new IP
address.  If it asks for a new IP address, then a DHCP lease table
will prevent any additional IP addresses from being allocated.
Cranking up the maximum number of connection to 10 will help, but
eventually it will run out of IP's.

Check for firmware updates for the E1200.  It might have been fixed.
However, I couldn't find anything specific in the release notes for
either V1 or V2.

Put an electronic timer on the power to the router and have it do a
power cycle in the middle of the night.  That should clear everything.
I use those for rebooting unreliable router on mountain tops.

--
# Jeff Liebermann 150 Felker St #D Santa Cruz CA 95060
# 831-336-2558
# http://802.11junk.com jeffl@cruzio.com
# http://www.LearnByDestroying.com               AE6KS

Site Timeline